Printing Problem in 1.3.42

Printing Problem in 1.3.42

Post by Bradley Ow » Thu, 14 Dec 1995 04:00:00



I've just upgraded my kernel to 1.3.42 and now find that I can no longer
print. I'm sure it is the kernel since when I go back to 1.2.13 printing works
fine. This seems to be the only problem I've found. Anyone else experienced
this?

Bradley

 
 
 

Printing Problem in 1.3.42

Post by James Ya » Thu, 14 Dec 1995 04:00:00



>I've just upgraded my kernel to 1.3.42 and now find that I can no longer
>print. I'm sure it is the kernel since when I go back to 1.2.13 printing works
>fine. This seems to be the only problem I've found. Anyone else experienced
>this?

A silly question, but,

Did you remember to build lp support into the kernel?  Or did you forget to
insmod the lp module?  (I spent a few minutes with the same oversight last
night.)

--
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --+


 
 
 

Printing Problem in 1.3.42

Post by Peter Herttri » Sat, 16 Dec 1995 04:00:00



: >I've just upgraded my kernel to 1.3.42 and now find that I can no longer
: >print. I'm sure it is the kernel since when I go back to 1.2.13 printing works
: >fine. This seems to be the only problem I've found. Anyone else experienced
: >this?

: A silly question, but,

: Did you remember to build lp support into the kernel?  Or did you forget to
: insmod the lp module?  (I spent a few minutes with the same oversight last
: night.)

one more silly question, but

perhaps you have included plip in make-config ?

then the parallel-interface is also dead for printing.

peter

: --
: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --+

--
_____________________________________________________________________________

    Universitaet Karlsruhe    Tel.  +49 721 6083747 FAX +49 721 6086071
Institut fuer Nachrichtentechnik  ..life outside caves is complicated ...  
_____________________________________________________________________________

 
 
 

1. netatalk make problem with 1.3.42

:i am having a problem making netatalk. i downloaded 1.3.3b2 from
:terminator.here's the error messages.
:
:gcc -p  -O2 -I../../include -c asp_getsess.c
:In file included from /usr/include/linux/socket.h:6,
:                 from /usr/include/sys/socket.h:5,
:                 from asp_getsess.c:31:
:/usr/include/linux/uio.h:18: redefinition of `struct iovec'
:make[3]: *** [asp_getsess.o] Error 1
:make[3]: Leaving directory `/usr/src/netatalk-1.3.3/libatalk/asp'
:make[2]: *** [asp] Error 2
:make[2]: Leaving directory `/usr/src/netatalk-1.3.3/libatalk'
:make[1]: *** [../../libatalk] Error 2
:make[1]: Leaving directory `/usr/src/netatalk-1.3.3/sys/linux'
:make: *** [all] Error 2
:

:or post back here.. thanks !!!!

look in the two socket.h. It is mentioned in one of them that it will
clash with the other. So change the one without this comment.

I also suggest getting the final 1.3.3 now that you are at it.

--

Macintosh / Unix / Win (aaargghh) programmer -  System Administrator
New Microsoft philosophy: Why innovate when you can immitate

2. Server SSL

3. Is there a problem with 1.3.42?

4. ATAPI CD-ROM and ATAPI CD-R at same time. How?

5. Problem upgrading from 1.2.13 to 1.3.42 (Slackware)

6. gdbserver on Solaris7

7. 1.3.42 kernel, ftape, etc problems

8. k package management

9. ppp 2.2.0c and linux 1.3.42 freelist prob.

10. Anyone compile 1.3.42 with Mitsumi CD ROM????

11. 1.3.42: mode 80x50 no matter what

12. Kernel 1.3.42 doesn't boot with loadlin

13. "arp_device_event: bug" in 1.3.42