Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

Post by Kevin Esl » Thu, 21 Dec 1995 04:00:00



I recently built and installed kernel 1.3.45, but found that PPP
doesn't work.

Is there something I'm supposed to adjust to make this work ?

--

Boston, MA, USA.

 
 
 

Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

Post by Kevin Esl » Thu, 21 Dec 1995 04:00:00


I recently built and installed kernel 1.3.45, but found that PPP
doesn't work.

Is there something I'm supposed to adjust to make this work ?

--

Boston, MA, USA.

 
 
 

Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

Post by David McGo » Fri, 22 Dec 1995 04:00:00



 : I recently built and installed kernel 1.3.45, but found that PPP
 : doesn't work.
 :
 : Is there something I'm supposed to adjust to make this work ?
 :
 : --

 : Boston, MA, USA.
 :

Having just performed the 1.2.13=>1.3.48 upgrade myself over the past couple
of days, I can speak of my experience.

You will need to get a recent ppp source distribution.  I used pppd-2.2.0d
from Sunsite.  You will have to follow the instructions in the pppd package,
which includes patching and compiling the new kernel before compiling the
pppd package.  The package has scripts to do the patching, so just sit back and
watch.  Just follow the instructions exactly in README.Linux.

During kernel configuration, you must select CONFIG_MODVERSIONS = N for ppp
to be included in the kernel.  This is explained in the pppd source.  If you
want it as a kernel module, you will have to set CONFIG_MODVERSIONS = Y.  If
you use iBCS you MUST have CONFIG_MODVERSION = Y, then you have no choice
but to make ppp as a module.

After compiling and installing the kernel, then go back and make and
make install the ppp source.  After insmod'ing slhc.o and ppp.o (assuming
ppp is configured as a kernel module), then try out your script.  I found
that my original dialing script under the 2.1.2d version worked just fine
under 2.2.0d, after updating the paths of pppd and chat.

Good Luck, and happy dialing.

David

--
+----------------------+--------------------------+-----------------------+

| 206 Adams Ave        | Home: (703)683-1599      |     LINUX INSIDE!     |
| Alexandria, VA 22301 | Work: (703)416-1240      |                       |
+----------------------+--------------------------+-----------------------+

 
 
 

Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

Post by Michael Nels » Fri, 22 Dec 1995 04:00:00


|> I recently built and installed kernel 1.3.45, but found that PPP
|> doesn't work.
|>
|> Is there something I'm supposed to adjust to make this work ?

        Yep.

        If you aren't running ppp 2.2.0, you will need to upgrade to
either the .c or .d version of that revision.  If you ARE already running
2.2.0, you'll need to reinstall it under the new kernel.

        It should work fine then.

        Michael

--

San Francisco, CA

 
 
 

Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

Post by Naresh Sharma - aio fac L en » Fri, 22 Dec 1995 04:00:00


You need to use ppp2.2.0c from any site.
kernel 1.3.45 has a fancy bsd compression module that will speed up your
connection if you ftp any uncompressed data or run remote programs.

Read the docs in ppp-2.2.0* very carefully and compile the kernel with
ppp support. It works!

: I recently built and installed kernel 1.3.45, but found that PPP
: doesn't work.

: Is there something I'm supposed to adjust to make this work ?

: --

: Boston, MA, USA.

--

                      __________/ F      
                    c'____---__=_/    
Naresh _______________o_____o___________http://is.twi.tudelft.nl/~sharma/

 
 
 

1. FTAPE = broke (Kernel > 1.3.45?)

Hello all,

        Has anyone had any luck with zftape1.02 working with kernel's higher
than 1.3.45?  I got it to compile but I get segfaults when I try to use the
device.

        Also, I applied the _Jeff Coy Jr._ patch to ftape2.03b which is
supposed to allow it to work with kernel 1.3.48 and up, but It craps out in
the compile with a "redefinition of 'kernel_version'" error.

        Anyways, I tried zftape on 1.3.50 and it compiles, just doesn't
work.  Then I tried the patched ftape on 1.3.50 it doesn't even compile.  So
I am confused...

        I'm looking into the code to try and get-around the redefinition
problem, but I don't like tinkering with stuff I didn't write.  Heck I don't
like tinkering with shit I *DID* write.  :)

        I just don't get it, it /used/ to work... :)

--
C. Shamis                                       / This space intentionally  

2. Mouse *and* pointing device?

3. kernel 1.3.45 and PPP --> not working :(((

4. Problems Compiling iBCS Code

5. strange problems 1.2.13 --> 2.0.0 --> 1.2.13

6. How to shutdown Linux ?

7. kernel 1.3.45 and PPP

8. pnpdump.3.1: add board

9. ppp 2.2.0c /w kernel 1.3.45: freelist?

10. smbfs with kernel > 1.3.45 and NT server

11. experimental kernel 1.3.45 and ppp

12. Kernel 1.3.45 and PPP

13. kernel 1.3.45 and ppp!!!!