ide, via, unnecessary probe?

ide, via, unnecessary probe?

Post by O.Seze » Tue, 17 Jun 2003 10:00:11



Hello Alan, all:

To the first channel of my onboard via ide controller
are attached no devices, only to the second channel.
During boot, the kernel keeps trying to probe the
first channel, as seen below, and delaying the boot
unnecessarily:

VP_IDE: IDE controller at PCI slot 00:04.1
VP_IDE: chipset revision 16
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt82c596b (rev 23) IDE UDMA66 controller on pci00:04.1
     ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:pio, hdb:pio
     ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:DMA, hdd:DMA
SiI680: IDE controller at PCI slot 00:0a.0
SiI680: chipset revision 2
SiI680: not 100% native mode: will probe irqs later
SiI680: BASE CLOCK == 100
     ide2: MMIO-DMA , BIOS settings: hde:pio, hdf:pio
     ide3: MMIO-DMA , BIOS settings: hdg:pio, hdh:pio
hda: IRQ probe failed (0xfffffdf8)
hda: IRQ probe failed (0xfffffdf8)
hda: no response (status = 0x0a), resetting drive
hda: IRQ probe failed (0xfffffdf8)
hda: no response (status = 0x0a)
hdb: IRQ probe failed (0xfffffdf8)
hdb: IRQ probe failed (0xfffffdf8)
hdb: no response (status = 0x0a), resetting drive
hdb: IRQ probe failed (0xfffffdf8)
hdb: no response (status = 0x0a)
hdc: SONY CD-ROM CDU5221, ATAPI CD/DVD-ROM drive
hdd: RICOH CD-R/RW MP7200A, ATAPI CD/DVD-ROM drive

This is with 2.4.21-ac1 and 2.4.19-24mdk.

hda=noprobe hdb=noprobe  boot parameters solves the
issue, but there should be some automagic to handle
this more nicely. I can try any patches happily.

Best regards,
Ozkan Sezer

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. IDE Zip disk faster via ide-scsi ???

When I enabled SCSI interface emulation to my 100 MB IDE Zip drive
(via modprobe ide-scsi) I noticed significant performance improvements,
i.e. "dd if=/dev/zip of=/dev/null" started to run 20% faster with
zip=/dev/sda4 than it had been with zip=/dev/hdd4.  

Are there any reasons for that? I mean if you so easily can improve
performance by 20% with this trick why it is not on by default???

Regards, Igor

2. Boot Linux from floppy (was NT+Linux....etc...)

3. Using IDE CD-Writer via ide-scsi?

4. Needing advice

5. VIA IDE and SMP do not work together (2.2.19 ide patch)

6. RH 6.0 to RH 6.2 Upgrade

7. 4 ide drives & Mitsumi (IDE/ATAPI) CD-ROM via SB

8. Flat Panel LCDs?

9. 2.5.41: ide-probe.c: HD_IRQ undeclared

10. PATCH: ide-probe update

11. PATCH: ide-probe updates

12. PCMCIA CD ROM Won't mount - Anyone send me ide-probe.o ??

13. New Motherboard Problem Triton II PCI IDE not probed correctly.