/dev/input/mice problem with 2.4.19-pre9 & 10

/dev/input/mice problem with 2.4.19-pre9 & 10

Post by Michael De Ni » Sun, 09 Jun 2002 18:50:07



hey

I saved the old config from 2.4.18 (with make menuconfig) and loaded it
with kernel 2.4.19-pre9 and pre10. everything compiles etc, the kernel
boots, but my usb-mouse is not working any more ...

All modules were loaded and none gave any error.

When I move my mouse while catting /dev/input/mice, nothing appears ...

Other USB-device work...

michael

btw: sry for this n00b-bugreport :) plz tell me if you need any more
information

-----------------------------------------------------------------------

       Linux LiSa 2.4.18 #9 SMP zo mei 5 13:42:48 CEST 2002 i686
  11:37:01 up 33 days, 16:57, 16 users,  load average: 0.00, 0.02, 0.08
-----------------------------------------------------------------------

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

/dev/input/mice problem with 2.4.19-pre9 & 10

Post by Brad Hard » Sun, 09 Jun 2002 19:20:07



> hey

> I saved the old config from 2.4.18 (with make menuconfig) and loaded it
> with kernel 2.4.19-pre9 and pre10. everything compiles etc, the kernel
> boots, but my usb-mouse is not working any more ...

This probably should tell you that what you've done is a silly thing:
http://marc.theaimsgroup.com/?l=linux-usb-devel&m=101761858728615&w=2

If you'd done a make oldconfig, you'd have seen the new option for
CONFIG_USB_HIDINPUT.

Brad
--
http://conf.linux.org.au. 22-25Jan2003. Perth, Australia. Birds in Black.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

/dev/input/mice problem with 2.4.19-pre9 & 10

Post by Thunder from the hil » Sun, 09 Jun 2002 20:30:12


Hi,


> When I move my mouse while catting /dev/input/mice, nothing appears ...

> Other USB-device work...

Please try /dev/input/mouse0.


total 0
crw-r--r--    1 root     root      13,  63 Dec 31  1969 mice
crw-r--r--    1 root     root      13,  32 Dec 31  1969 mouse0

Regards,
Thunder
--
ship is leaving right on time   |       Thunder from the hill at ngforever
empty harbour, wave goodbye     |
evacuation of the isle          |       free inhabitant not directly
caveman's paintings drowning    |       belonging anywhere

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

/dev/input/mice problem with 2.4.19-pre9 & 10

Post by Brad Hard » Mon, 10 Jun 2002 09:00:09



> Hi,


> > When I move my mouse while catting /dev/input/mice, nothing appears ...

> > Other USB-device work...

> Please try /dev/input/mouse0.


> /dev/input/ total 0
> crw-r--r--    1 root     root      13,  63 Dec 31  1969 mice
> crw-r--r--    1 root     root      13,  32 Dec 31  1969 mouse0

That won't make any difference - it will say "no such device".

Both devices are created by the same input subsystem mouse driver. That driver
is loaded (because /dev/input/mice was able to be opened), but there is no
underlying USB support for the input subsystem. Input subsystem support was
made configurable in -pre9, and if you don't select that option, then the hid
parser directs the output to /dev/usb/hiddevX.

Brad

--
http://conf.linux.org.au. 22-25Jan2003. Perth, Australia. Birds in Black.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. kbuild25 version 3.0 for 2.4.19-pre9 and 2.4.19-pre9-ac3

kbuild.sf.net have kbuild25 version 3.0 released yesterday.

Also I fixed some silly bugs I've left in Makefile.in. I'm really happy that
people ARE interested in what I'm doing and provided feedback.

And filename is getting longer :)
http://stingr.net/l/kbuild25-3.0-for-2.4.19-pre9.bz2
http://stingr.net/l/kbuild25-3.0-for-2.4.19-pre9-ac3.bz2

-or-
ftp://stingr.net/pub/l/kbuild25-3.0-for-2.4.19-pre9.bz2
ftp://stingr.net/pub/l/kbuild25-3.0-for-2.4.19-pre9-ac3.bz2

--
Paul P 'Stingray' Komkoff 'Greatest' Jr /// (icq)23200764 /// (http)stingr.net
  When you're invisible, the only one really watching you is you (my keychain)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. Driver for AT CentreCOM LA-ISA Ethernet Adaptor

3. strange swap usage with ac branch of 2.4.19-pre9/10

4. SLIP with a router(Cisco-CS500)

5. nfs problem 2.4.19-pre9

6. video & ram

7. 2.4.19-pre9-ac3: Build problem

8. LINUX-WINDOWS USB

9. 2.4.19-pre9 SMP modules problem

10. ide-tape problem in 2.4.19-pre9?

11. Memory problem in 2.4.19-pre9-ac3

12. 2.4.19-rc2 -> 2.4.19-rc3 : no more eth (fwd)

13. 3Ware ok 2.4.19, dies 2.4.19-ac4