[2.5 patch] small documentation apdate regarding supported gcc versions

[2.5 patch] small documentation apdate regarding supported gcc versions

Post by Rusty Trivial Russel » Tue, 27 May 2003 09:00:13



[ Looks correct given the check in init/main.c. --RR ]

  The patch below against 2.5.68-bk11 contains a small documentation
  apdate regarding supported gcc versions.

  cu
  Adrian

--- trivial-2.5.69-bk18/README.orig     2003-05-26 16:17:24.000000000 +1000

 COMPILING the kernel:

- - Make sure you have gcc 2.95.3 available.
-   gcc 2.91.66 (egcs-1.1.2), and gcc 2.7.2.3 are known to miscompile
-   some parts of the kernel, and are *no longer supported*.
+ - Make sure you have gcc >= 2.95.3 available. *gcc 2.7.2.3 and gcc 2.91.66
+   (egcs-1.1.2) are no longer supported*.
    Also remember to upgrade your binutils package (for as/ld/nm and company)
    if necessary. For more information, refer to ./Documentation/Changes.

--- trivial-2.5.69-bk18/Documentation/Changes.orig      2003-05-26 16:17:24.000000000 +1000

 information about their gcc version requirements from another source.

 The recommended compiler for the kernel is gcc 2.95.x (x >= 3), and it
-should be used when you need absolute stability. You may use gcc 3.0.x
+should be used when you need absolute stability. You may use gcc 3.x
 instead if you wish, although it may cause problems. Later versions of gcc
 have not received much testing for Linux kernel compilation, and there are
 almost certainly bugs (mainly, but not exclusively, in the kernel) that
 will need to be fixed in order to use these compilers. In any case, using
 pgcc instead of plain gcc is just asking for trouble.

-gcc 2.91.66 (egcs-1.1.2) continues to be supported for SPARC64 requirements.
-
 The Red Hat gcc 2.96 compiler subtree can also be used to build this tree.
 You should ensure you use gcc-2.96-74 or later. gcc-2.96-54 will not build
 the kernel correctly.
--
  What is this? http://www.kernel.org/pub/linux/kernel/people/rusty/trivial/
  Don't blame me: the Monkey is driving

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

[2.5 patch] small documentation apdate regarding supported gcc versions

Post by David S. Mille » Tue, 27 May 2003 09:10:11



   Date: Mon, 26 May 2003 16:32:04 +1000

   [ Looks correct given the check in init/main.c. --RR ]

     The patch below against 2.5.68-bk11 contains a small documentation
     apdate regarding supported gcc versions.

Andrew merged in a similar patch today, I bet this one won't
apply.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. small documentation apdate regarding supported gcc versions

The patch below against 2.5.68-bk11 contains a small documentation
apdate regarding supported gcc versions.

cu
Adrian

--- linux-2.5.68-bk11/README.old        2003-05-02 17:47:22.000000000 +0200

 COMPILING the kernel:

- - Make sure you have gcc 2.95.3 available.
-   gcc 2.91.66 (egcs-1.1.2), and gcc 2.7.2.3 are known to miscompile
-   some parts of the kernel, and are *no longer supported*.
+ - Make sure you have gcc >= 2.95.3 available. *gcc 2.7.2.3 and gcc 2.91.66
+   (egcs-1.1.2) are no longer supported*.
    Also remember to upgrade your binutils package (for as/ld/nm and company)
    if necessary. For more information, refer to ./Documentation/Changes.

--- linux-2.5.68-bk11/Documentation/Changes.old 2003-05-02 17:48:51.000000000 +0200

 information about their gcc version requirements from another source.

 The recommended compiler for the kernel is gcc 2.95.x (x >= 3), and it
-should be used when you need absolute stability. You may use gcc 3.0.x
+should be used when you need absolute stability. You may use gcc 3.x
 instead if you wish, although it may cause problems. Later versions of gcc
 have not received much testing for Linux kernel compilation, and there are
 almost certainly bugs (mainly, but not exclusively, in the kernel) that
 will need to be fixed in order to use these compilers. In any case, using
 pgcc instead of plain gcc is just asking for trouble.

-gcc 2.91.66 (egcs-1.1.2) continues to be supported for SPARC64 requirements.
-
 The Red Hat gcc 2.96 compiler subtree can also be used to build this tree.
 You should ensure you use gcc-2.96-74 or later. gcc-2.96-54 will not build
 the kernel correctly.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. Xconfig for Diamond Stealth VRAM card?

3. 2.5.1pre6 vt_kern.h a small patch take 2

4. DE205 Net Card and linux network

5. Need patch, gcc > 2.6.0 for Solaris 2.5

6. procmail help needed. Please!

7. Small Patch for docbook documentation typo

8. Changing the password from within a script

9. [2.4] [2.5] [i386] Add support for GCC 3.1 -march=pentium{-mmx,3,4}

10. [RFC] [2.5 i386] GCC 3.1 -march support, PPRO_FENCE reduction, prefetch fixes and other CPU-related changes

11. [2.4] [2.5] [i386] Add support for GCC 3.1

12. [PATCH] 2.5 trivial reiserfs resizer patch (needed now that

13. regard perl5.004.03.SPARC.Solaris.2.5.pkg.tgz