modutils that works with 2.4 and 2.5?

modutils that works with 2.4 and 2.5?

Post by Dax Kelso » Fri, 14 Feb 2003 21:00:06



Does such a thing exist?

I would like to help out testing 2.5, but I need to still use 2.4 as
well.

Dax

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

modutils that works with 2.4 and 2.5?

Post by John Bradfor » Fri, 14 Feb 2003 21:10:05


Quote:> Does such a thing exist?

> I would like to help out testing 2.5, but I need to still use 2.4 as
> well.

You could always compile 2.5 without modules at all, which would be
the easy way :-)

John.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

modutils that works with 2.4 and 2.5?

Post by Thomas Molin » Sat, 15 Feb 2003 00:20:13



Quote:> Does such a thing exist?

> I would like to help out testing 2.5, but I need to still use 2.4 as
> well.

go to ftp.kernel.org/pub/linux/kernel/people/rusty/modules and grab the
latest.  If you have an rpm-capable system it is packaged as an rpm.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

modutils that works with 2.4 and 2.5?

Post by Muli Ben-Yehud » Sat, 15 Feb 2003 08:10:06



> Does such a thing exist?

> I would like to help out testing 2.5, but I need to still use 2.4 as
> well.

Rusty's modutils package maintains the old modutils binaries and falls
back to them if it discovers that you're running a 2.4 system. If
you're installing from source, take a look at the documentation for
how to tell the Makefile to rename your $MODULE_BIN to
$MODULE_BIN.old
--
Muli Ben-Yehuda
http://www.mulix.org
http://syscalltrack.sf.net

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

modutils that works with 2.4 and 2.5?

Post by Dax Kelso » Sat, 15 Feb 2003 20:10:10




> > Does such a thing exist?

> > I would like to help out testing 2.5, but I need to still use 2.4 as
> > well.

> Rusty's modutils package maintains the old modutils binaries and falls
> back to them if it discovers that you're running a 2.4 system.

Does it do this discovery at install time, or at each boot?

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

modutils that works with 2.4 and 2.5?

Post by Muli Ben-Yehud » Sat, 15 Feb 2003 20:30:17





> > > Does such a thing exist?

> > > I would like to help out testing 2.5, but I need to still use 2.4 as
> > > well.

> > Rusty's modutils package maintains the old modutils binaries and falls
> > back to them if it discovers that you're running a 2.4 system.

> Does it do this discovery at install time, or at each boot?

Each invocation, I suppose. Doesn't make much sense otherwise.

see for example lsmod.c, main() -> try_old_version().
--
Muli Ben-Yehuda
http://www.mulix.org
http://syscalltrack.sf.net

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

modutils that works with 2.4 and 2.5?

Post by Joel Becke » Sat, 15 Feb 2003 23:30:10



> > Does it do this discovery at install time, or at each boot?

> Each invocation, I suppose. Doesn't make much sense otherwise.

        Each invocation.  Note that because Rusty's modutils replaces
insmod.static, it nicely breaks machines that use initrds.

Joel

--

"And yet I fight,
 And yet I fight this battle all alone.
 No one to cry to;
 No place to call home."

Joel Becker
Senior Member of Technical Staff
Oracle Corporation

Phone: (650) 506-8127
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. FIONREAD / FIORDCHK -- doesn't work under 2.4 / 2.5?

Hi: I'm looking to port some legacy code which uses ioctl(..,FIONREAD,..);
The comments in the 2.4 header file indicates that this should still work,
but it doesn't. I get ioctl errors, and other errors such as interrupted
system call (depending on where this happens).

Question is: is there a *real* replacement for FIONREAD? (In 2.4
there's this mysterious note re. FIORDCHK, but no references to it
in the man pages or other header files :)

Thanks much in advance.

2. Native Pthreads Support

3. Help with ProcTool requested (broken for me on 2.4 but works on 2.5!??)

4. rest of: Segmentation fault in Linux 2.0.x NFS

5. ProCtool broken on 2.4, works great on 2.5 - have tried all troubleshooting tips in the manual!!!

6. Avalon project at 19.2 BOPS...

7. USB harddrive not working (2.4, 2.5)

8. Connecting Sun's to MS Exchange

9. 2.5.x, 2.4.y / pcmcia xircom serial doesn't work

10. ProCtool broken on 2.4, works great on 2.5 - have tried all troubleshooting tips in the manual!!!

11. NFS works between 2.4 & 2.5 ???

12. Can't eject ZIP IDE with 2.5.* (works in 2.4)

13. 2.4: Minor build fix for ext3 (2.4 and 2.5)