2.5.47: make modules_install fails

2.5.47: make modules_install fails

Post by Priit Lae » Wed, 13 Nov 2002 10:50:13



when doing make modules_install, it fails with the following error
messages:
depmod: *** Unresolved symbols in /lib/modules/2.5.47/kernel/drivers/net/8390.o
depmod:         crc32_be_Rb7b61546
depmod: *** Unresolved symbols in /lib/modules/2.5.47/kernel/drivers/net/pcmcia/smc91c92_cs.o
depmod:         mii_ethtool_sset
depmod:         mii_link_ok
depmod:         mii_ethtool_gset
depmod:         generic_mii_ioctl
depmod:         mii_nway_restart
depmod:         crc32_be_Rb7b61546
i will attach my dot config too.

  dot.config
19K Download
 
 
 

2.5.47: make modules_install fails

Post by Matt_Dom.. » Wed, 13 Nov 2002 16:00:17


Quote:> when doing make modules_install, it fails with the following error
> messages:
> depmod: *** Unresolved symbols in
> /lib/modules/2.5.47/kernel/drivers/net/8390.o
> depmod:         crc32_be_Rb7b61546
> depmod:         crc32_be_Rb7b61546

For the crc32 bits, you've got CONFIG_CRC32=y, but CONFIG_SMC91C92=m, and
nothing built-in is using the crc32 functions, so the linker is throwing
them out.  Set CONFIG_CRC32=m, if something built-in needs it it'll get set
to =y by them.

Thanks,
Matt

--
Matt Domsch
Sr. Software Engineer, Lead Engineer, Architect
Dell Linux Solutions www.dell.com/linux

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/