2.4.21-pre3 PDC20265 DMA disabled dma_intr: status=0x51 { DriveReady SeekComplete Error }

2.4.21-pre3 PDC20265 DMA disabled dma_intr: status=0x51 { DriveReady SeekComplete Error }

Post by Thomas Husema » Sat, 11 Jan 2003 12:42:25



Hi *

I've problems with my onboard raid controller
(linux/drivers/ide/pdc202xx.c        Version 0.36). 2.4.19 patched by
SuSE works fine for me(.linux/drivers/ide/pdc202xx.c        Version
0.32).

Any help is welcome :-)

regards Thomas


11:15:51 CET 2003
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009d400 (usable)
 BIOS-e820: 000000000009d400 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
 BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
 BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
511MB LOWMEM available.
On node 0 totalpages: 131056
zone(0): 4096 pages.
zone(1): 126960 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/hdc1 vga=791 pci=biosirq ide2=ata66
hda=ide-scsi
ide_setup: ide2=ata66
ide_setup: hda=ide-scsi
...
ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
PDC20265: IDE controller at PCI slot 00:0f.0
PCI: Found IRQ 10 for device 00:0f.0
PCI: Sharing IRQ 10 with 00:10.3
PDC20265: chipset revision 2
PDC20265: not 100% native mode: will probe irqs later
PDC20265: (U)DMA Burst Bit ENABLED Primary MASTER Mode Secondary
MASTER Mode.
    ide2: BM-DMA at 0xd400-0xd407, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xd408-0xd40f, BIOS settings: hdg:pio, hdh:pio
VP_IDE: IDE controller at PCI slot 00:11.1
PCI: No IRQ known for interrupt pin A of device 00:11.1.
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci00:11.1
    ide0: BM-DMA at 0xe400-0xe407, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xe408-0xe40f, BIOS settings: hdc:DMA, hdd:pio
hda: AOPEN CD-RW CRW2440, ATAPI CD/DVD-ROM drive
hdb: TOSHIBA DVD-ROM SD-M1712, ATAPI CD/DVD-ROM drive
hda: DMA disabled
hdb: DMA disabled
hdc: IBM-DTTA-351010, ATA DISK drive
hdc: DMA disabled
blk: queue c02fc0ec, I/O limit 4095Mb (mask 0xffffffff)
hde: IBM-DTLA-307030, ATA DISK drive
hdf: IBM-DTLA-307030, ATA DISK drive
blk: queue c02fc538, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c02fc674, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide2 at 0xc400-0xc407,0xc802 on irq 10
hdc: host protected area => 1
hdc: 19807200 sectors (10141 MB) w/466KiB Cache, CHS=19650/16/63,
UDMA(33)
hde: host protected area => 1
hde: 60036480 sectors (30739 MB) w/1916KiB Cache, CHS=59560/16/63,
UDMA(100)
hdf: host protected area => 1
hdf: 60036480 sectors (30739 MB) w/1916KiB Cache, CHS=59560/16/63,
UDMA(100)
Partition check:
 hdc: hdc1
 hde:<6> [PTBL] [3737/255/63] hde1 hde2 hde3 < >
 hdf: unknown partition table
 ataraid/d0: ataraid/d0p1 ataraid/d0p2 ataraid/d0p3 < ataraid/d0p5
ataraid/d0p6 >
Drive 0 is 29314 Mb (33 / 0)
Drive 1 is 29314 Mb (33 / 64)
Raid0 array consists of 2 drives.
Promise Fasttrak(tm) Softwareraid driver for linux version 0.03beta
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 249k freed
VFS: Mounted root (ext2 filesystem).
hdb: ATAPI 48X DVD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: AOPEN     Model: CD-RW CRW2440     Rev: 2.08
  Type:   CD-ROM                             ANSI SCSI revision: 02
Journalled Block Device driver loaded
EXT2-fs warning (device ide1(22,1)): ext2_read_super: mounting ext3
filesystem as ext2

VFS: Mounted root (ext2 filesystem) readonly.
Trying to move old root to /initrd ... failed
Unmounting old root
Trying to free ramdisk memory ... okay
Freeing unused kernel memory: 112k freed
hda: DMA disabled
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.5+(22/07/2002) module loaded
hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x04 { DriveStatusError }
hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x04 { DriveStatusError }
hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x04 { DriveStatusError }
hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x04 { DriveStatusError }
hde: DMA disabled
hdf: DMA disabled
PDC202XX: Primary channel reset.
PDC202XX: Secondary channel reset.
hde: DMA disabled
ide2: reset: master: error (0x00?)
hde: MULTI-READ assume all data transfered is bad status=0x59
hde: task_mulin_intr: status=0x59 { DriveReady SeekComplete
DataRequest Error }
hde: task_mulin_intr: error=0x04 { DriveStatusError }
hde: MULTI-READ assume all data transfered is bad status=0x59
hde: task_mulin_intr: status=0x59 { DriveReady SeekComplete
DataRequest Error }
hde: task_mulin_intr: error=0x04 { DriveStatusError }
hde: MULTI-READ assume all data transfered is bad status=0x59
hde: task_mulin_intr: status=0x59 { DriveReady SeekComplete
DataRequest Error }
hde: task_mulin_intr: error=0x04 { DriveStatusError }
hde: MULTI-READ assume all data transfered is bad status=0x59
hde: task_mulin_intr: status=0x59 { DriveReady SeekComplete
DataRequest Error }
hde: task_mulin_intr: error=0x04 { DriveStatusError }
PDC202XX: Primary channel reset.
PDC202XX: Secondary channel reset.
hde: DMA disabled
ide2: reset: master: error (0x00?)
end_request: I/O error, dev 21:03 (hde), sector 0

Linux ronja 2.4.19-tom #5 Fri Jan 3 23:43:12 CET 2003 i686 unknown:

cat /proc/scsi/FastTrak/0
PROMISE FastTrak Series Linux Driver Version 1.02.0.25
Adapter1 - FastTrak100 Lite/SMARAID, IRQ(10)
Array    - Array[1] : 2+0 Stripe (OK)
Drive    -
  1: IBM-DTLA-30703 Pri/Master Array[1]  30738MB BASE(0xc400)
BM(0xd400) UDMA5
  2: IBM-DTLA-30703 Pri/Slave  Array[1]  30738MB BASE(0xc400)
BM(0xd400) UDMA5

works fine!