2.4.6 APM suspend kills Dell inspiron 3500 sound card, but revives network card.

2.4.6 APM suspend kills Dell inspiron 3500 sound card, but revives network card.

Post by Rob Landle » Sun, 08 Jul 2001 07:50:07



My devices on my laptop work very strangely with kernel 2.4.6.

-- Sound problems:

The sound card on my laptop (Dell Inspiron 3500) works fine when the system
first boots up, but stops working with the first suspend.  Any attempt to
write sound to it after that blocks indefinitely.  I don't even get console
beeps until I reboot.

That's under kde with their not-esd daemon (I.E. using noatun).  If I do the
same from the console it still plays fine before the suspend (using mpg123),
and afterwords plays short samples in a loop with "DMA timeout" error
messages to the console.

-- Network problems.

I have 3 pcmcia network cards (10baseT xircomm, 100baseT cardbus thing that
isn't with me right now, and a wireless card.)  The two 10baseT (pcmica) ones
have about the same behavior, the 100baseT (cardbus?) one's a little
different.

Under previous kernels (the mutuant red hat 7.1 2.4.2), the pcmcia network
card would work fine on boot but die when the system suspends.  (I didn't
mind because I could pop it out and put it back in and it would work again.)  
Now with 2.4.6 it's exactly the OPPOSITE behavior: the network card doesn't
work at all until I suspend and resume, but when the system comes back up
after a suspend the card works fine.  Before the suspend, popping it out and
putting it back in accomplish nothing.  Afterwards popping out and putting in
work great, re-runs dhcpcd and everything.

Back under red hat's 2.4.2, putting the cardbus card in, suspending,
resuming, and popping the card out produced a kernel panic.  I haven't tried
with 2.4.6 (don't have the card with me), but I can try to reproduce this
under 2.4.6 if it sounds interesting to anybody...

-- Fun little detail:

The two cardbus bridges and the sound card are all on IRQ 11, it seems.  
/proc/pci attached.

Rob

(P.S.  I take it the XFree86 hangs are an XFree86 problem, not kernel?  Rat
pointer still moves, drive still chugs a bit in the background, so the kernel
seems sort of still there...  Can't get out of the frozen gui though, no
ctrl-alt-F1, no ctrl-alt-backspace...  Oh well.)

  pci
1K Download

  modules
< 1K Download