capability flag for ATAPI MO (from kernel mailing list)

capability flag for ATAPI MO (from kernel mailing list)

Post by Pascal Schmid » Sat, 31 May 2003 11:40:12




> Is optical (or CDC_OPTICAL) a good name for this capability?
> After all, CD CD-R CD-RW DVD DVD+/-R(W) are all optical.

Well, I simply used something similar to ide_optical from IDE code, but
I agree that it's not optimal.

Quote:> That said, a better name does not immediately spring to mind
> (unless MOPTICAL works for you - magneto-optical seems too long).

I'll see what Jens has to say about the name. CDC_MOPTICAL looks ugly
to me, and CDC_MO too short. Maybe CDC_MO_DRIVE would work if
CDC_OPTICAL is not acceptable.

--
Ciao,
Pascal

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

capability flag for ATAPI MO (from kernel mailing list)

Post by Jens Axbo » Tue, 03 Jun 2003 12:50:09




> > Is optical (or CDC_OPTICAL) a good name for this capability?
> > After all, CD CD-R CD-RW DVD DVD+/-R(W) are all optical.

> Well, I simply used something similar to ide_optical from IDE code, but
> I agree that it's not optimal.

> > That said, a better name does not immediately spring to mind
> > (unless MOPTICAL works for you - magneto-optical seems too long).

> I'll see what Jens has to say about the name. CDC_MOPTICAL looks ugly
> to me, and CDC_MO too short. Maybe CDC_MO_DRIVE would work if
> CDC_OPTICAL is not acceptable.

CDC_MO_DRIVE would be fine with me, it's right to the point. But
basically I don't really care, I think it's pretty clear even if named
CDC_OPTICAL.

--
Jens Axboe

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/