2.4.19-pre10-ac2 PDC20265 IDE BUGS.

2.4.19-pre10-ac2 PDC20265 IDE BUGS.

Post by Nick Evgenie » Sun, 09 Jun 2002 00:00:13



Hi,

2.4.19-pre10-ac2 still has bugs in its promise 20265 ide controller driver.
I've got ide lost interrupt messages on console just in a few hours after
reboot. (BTW could someone explain me what does it means for drives in
UDMA100 mode?)
Below is a kernel.log messages:

Quote:>----------------------------

Jun  7 17:43:16 vzhik kernel: hdg: status timeout: status=0xd0 { Busy }
Jun  7 17:43:16 vzhik kernel:
Jun  7 17:43:16 vzhik kernel: hdg: drive not ready for command
Jun  7 17:43:16 vzhik kernel: hdg: status timeout: status=0xd0 { Busy }
Jun  7 17:43:16 vzhik kernel:
Jun  7 17:43:16 vzhik kernel: hdg: DMA disabled
Jun  7 17:43:17 vzhik kernel: ide3: reset: success
Jun  7 17:43:18 vzhik kernel: PDC202XX: Secondary channel reset.
Jun  7 17:43:18 vzhik kernel: hdg: drive not ready for command
Jun  7 17:43:38 vzhik kernel: hde: timeout waiting for DMA
Jun  7 17:44:03 vzhik kernel: PDC202XX: Primary channel reset.
Jun  7 17:44:03 vzhik kernel: ide_dmaproc: chipset supported ide_dma_timeout
func only: 16
Jun  7 17:44:03 vzhik kernel: hde: timeout waiting for DMA
Jun  7 17:44:03 vzhik kernel: PDC202XX: Primary channel reset.
Jun  7 17:44:03 vzhik kernel: ide_dmaproc: chipset supported ide_dma_timeout
func only: 16
Jun  7 17:44:03 vzhik kernel: hde: status timeout: status=0xd1 { Busy }
Jun  7 17:44:03 vzhik kernel:
Jun  7 17:44:03 vzhik kernel: PDC202XX: Primary channel reset.
Jun  7 17:44:03 vzhik kernel: hde: drive not ready for command
Jun  7 17:44:03 vzhik kernel: ide2: reset: success
Jun  7 17:49:21 vzhik kernel: hdg: status error: status=0x58 { DriveReady
SeekComplete DataRequest }
Jun  7 17:49:21 vzhik kernel:
Jun  7 17:49:21 vzhik kernel: hdg: drive not ready for command
Jun  7 17:49:21 vzhik kernel: hdg: status timeout: status=0xd0 { Busy }

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. PROBLEM: 2.4.19-pre10-ac2 bug in page_alloc.c:131

I'm already using the 1.0-2960 version, and that's the version in the
report. It's possible that the NVdriver module is the cause of the
problem, but the bug spots in kernel's vm, in a place which it's no
supposed to, at the point I understand. So, or the module does something
very ugly, or the kernel really have a bug, or yet it's nothing related
to the nvdriver. Unfortunately, the backtrace don't help me figuring
that out, since I'm no vm expert, but perhaps someone will. I may
attempt to forward this to Nvidia folks, but reporting a bug which only
spotted once and in a "pre" series kernel may hurt their feelings...

Thanks,

Alexandre

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. hub lite blinking rapidly

3. tcp wrappers

4. BUG: UFS Problem with 2.4.19-pre10-ac2 and 2.5.23

5. 2.4: Fix for jbd compiler warnings.

6. 2.4.19-pre10-ac2, compile warnings/failures

7. Why is my harddisk so slo

8. Problem with 2.4.19-pre10-ac2 and i2o SX6000 controller

9. CMD649 on SMP 2.4.19-pre10-ac2: still not working: please help

10. Oddities with HighPoint HPT374, 2.4.19-pre10-ac2

11. kbuild-2.5 on 2.4.19-pre10-ac2 build error when modular support turned off

12. Kernel 2.4.19-pre10-ac2 Oops in mke2fs on HPT374 RAID Array