kernel/module issue

kernel/module issue

Post by Rick » Sat, 09 Feb 2002 03:40:13



I'm running kernel 2.4.17. I've recompiled the kernel and now I'm getting a
weird error message that I've not seen before - well...not a module I've
seen.

Feb  7 01:25:19 genesis modprobe: modprobe: Can't locate module binfmt-e0ff
Feb  7 01:26:10 genesis last message repeated 4 times
Feb  7 01:26:41 genesis last message repeated 5 times
Feb  7 01:28:50 genesis modprobe: modprobe: Can't locate module binfmt-e0ff
Feb  7 01:29:54 genesis last message repeated 4 times
Feb  7 01:30:59 genesis last message repeated 8 times
Feb  7 01:30:59 genesis modprobe: modprobe: Can't locate module binfmt-e0ff
Feb  7 01:44:49 genesis modprobe: modprobe: Can't locate module binfmt-e0ff
Feb  7 01:44:52 genesis last message repeated 3 times
Feb  7 01:47:47 genesis modprobe: modprobe: Can't locate module binfmt-e0ff

Can anyone tell me what binfmt-e0ff is used for? What it does? and is it
serious?

Please CC me any answers or comments. I'm not yet on the list.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. kernel module issues

I am having problems upgrading from kernel 2.2.16 to 2.4.7 I am using
Slackware 7.1. I downloaded the 2.4.7 kernel source and did a make xconfig
(I also tweaked it a bit with menuconfig). The did a make dep clean modules
modules_install bzImage to produce the new image. I moved the new image to
the /boot directory and ran lilo to configure it at boot. Then I did a
/sbin/depmod -a -F /usr/src/linux/System.map 2.4.7

The problem is, that when I boot up none of my modules are being
loaded. Looking at /lib/modules/2.4.7/modules.dep, I see it is a 0 byte
file, and modprobe which needs modules.dep uses that file to load the
modules. insmod can load the modules manually. My modules.conf is pretty
short, and is pasted at the end.

Can anybody tell me what is going on with depmod (which is version 2.3.11
and came with the distribution), and how can I get it to work...BTW, it
looks like the structure of /lib/modules/2.4.7 is different from
/lib/modules/2.2.16 in that all modules are placed in the kernel directory
which doesn't exist in the 2.2.16 tree. Is this normal?

If you can email me any ideas, it would be most appreciated. Thanks,
Scott Savarese

2. root unable to change file ownership

3. kernel modules compile issue

4. S3 Trio 3D/2X not supported by 3.3.5?

5. DPT SmartRaid III, EATA driver module issues with kernel 2.2.5

6. Passing a handle via command line

7. Opening a kernel module from another kernel module

8. AIX/SP Installed Base in NoVa and Atlanta

9. Security issues/kernel modules..

10. help: use of third party kernel modules: license issue?

11. possible issues on SMP machine for Netfilter based kernel module

12. Ft. Worth - Linux Kernel Module Programmer - Unix kernel modules & Unix device drivers

13. aha1542, module vs kernel, kernel doesn't work, need kernel