2.5.5 - Linking error

2.5.5 - Linking error

Post by Gregor Jasn » Sat, 23 Feb 2002 02:20:09



Hi,

On my debian sid with binutils 2.11.93.0.2-1 I get the following linking
error:

ld -m elf_i386 -T /usr/src/linux-2.5.5/arch/i386/vmlinux.lds -e stext
arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o
init/version.o init/do_mounts.o \
        --start-group \
        arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o
fs/fs.o ipc/ipc.o \
        /usr/src/linux-2.5.5/arch/i386/lib/lib.a
/usr/src/linux-2.5.5/lib/lib.a /usr/src/linux-2.5.5/arch/i386/lib/lib.a \
         drivers/acpi/acpi.o drivers/base/base.o drivers/char/char.o
drivers/block/block.o drivers/misc/misc.o drivers/net/net.o
drivers/media/media.o drivers/char/agp/agp.o drivers/char/drm/drm.o
drivers/ide/idedriver.o drivers/scsi/scsidrv.o drivers/cdrom/driver.o
drivers/pci/driver.o drivers/video/video.o \
        net/network.o \
        --end-group \
        -o vmlinux
drivers/net/net.o(.data+0xd4): undefined reference to `local symbols in
discarded section .text.exit'
make[1]: *** [vmlinux] Error 1
make[1]: Leaving directory `/usr/src/linux-2.5.5'

What must I change that it links properly?

Best Regards,
-G. Jasny
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

2.5.5 - Linking error

Post by Dave Jone » Sat, 23 Feb 2002 02:40:12


 > drivers/net/net.o(.data+0xd4): undefined reference to `local symbols in
 > discarded section .text.exit'
 > make[1]: *** [vmlinux] Error 1
 > make[1]: Leaving directory `/usr/src/linux-2.5.5'
 > What must I change that it links properly?

See 'Compile errors' in http://www.codemonkey.org.uk/Linux-2.5.html

--
| Dave Jones.        http://www.codemonkey.org.uk
| SuSE Labs
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. Pilot-Link error when running ./configure

When I run the Pilot-Link configure program I'm getting an error saying "host type is not recognizable...must be specified".

Anyone know what I need to do to get Pilot-Link to install correctly?  I'm running RH 6.0.

Thanks,
Larry

2. Any distrib install from EXP pcmcia ext cdrom???

3. strange link error with gcc...

4. Select call

5. Cross-device link error?

6. Intel Etherexpress Pro 10/100B T4

7. link errors building profiled Oracle OCI exe on Solaris

8. Newbie install SNAFUs

9. Link Error after mkdev .scsi

10. Kernel Link Error after mkdev mouse

11. File Locking Link Error

12. Too many symbolic links error?!?

13. driver link error