2.5.43 and the VIA vt8233 IDE controller.

2.5.43 and the VIA vt8233 IDE controller.

Post by Jason William » Thu, 17 Oct 2002 22:40:09



I am suspecting something is amist with the via controller code in
2.5.43, because my promise controller goes through the same routines
just fine.  I started to try to back trace everything to hunt down the
culperate myself, but alas, I couldn't find the cause.  So if anyone can
give me a hand here, I would be very grateful.  What follows is the
bottom snippet of kernel output.  If you require anything further, let
me know I will send it.

Jason

  kerneloutput.txt
1K Download
 
 
 

2.5.43 and the VIA vt8233 IDE controller.

Post by Jason William » Fri, 18 Oct 2002 15:20:08


Just a small addendum to this post I made yesterday, I took the VIA IDE
controller code out of the kernel and it booted just fine.  And again,
my Promise RAID controller was seen just fine by the kernel, so I am
leaning even more toward a problem in the VIA driver.

Jason


> I am suspecting something is amist with the via controller code in
> 2.5.43, because my promise controller goes through the same routines
> just fine.  I started to try to back trace everything to hunt down the
> culperate myself, but alas, I couldn't find the cause.  So if anyone can
> give me a hand here, I would be very grateful.  What follows is the
> bottom snippet of kernel output.  If you require anything further, let
> me know I will send it.

> Jason

> ----

> VP_IDE: chipset revision 6
> VP_IDE: not 100% native mode: will probe irqs later
> ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
> VP_IDE: VIA vt8233 (rev 00) IDE UDMA100 controller on pci00:11.1
>     ide1: BM-DMA at 0x9008-0x900fUnable to handle kernel NULL pointer dereference at virtual address 00000650
>  printing eip:
> c024a52b
> *pde = 00000000
> Oops: 0000

> CPU:    0
> EIP:    0060:[<c024a52b>]    Not tainted
> EFLAGS: 00010202
> EIP is at ide_iomio_dma+0xbb/0x1c0
> eax: 00000000   ebx: c052cbb4   ecx: c03aa274   edx: 00000001
> esi: c052cbc4   edi: 00009008   ebp: 00000008   esp: dffcbeb4
> ds: 0068   es: 0068   ss: 0068
> Process swapper (pid: 1, threadinfo=dffca000 task=dffc8040)
> Stack: c0380d6f 00009008 00000008 c052cbc4 c1526000 c052cbb4 c03e7a50 c052cbb4
>        c024a687 c052cbb4 00009008 00000008 00000089 c04195dd c1526000 00009008
>        c0418a58 c052cbb4 00009008 00000008 c02488be c052cbb4 00009008 00000004
> Call Trace:
>  [<c024a687>] ide_setup_dma+0x27/0x380
>  [<c02488be>] ide_hwif_setup_dma+0x10e/0x150
>  [<c0248bce>] do_ide_setup_pci_device+0x16e/0x330
>  [<c0248dbb>] ide_setup_pci_device+0x2b/0x80
>  [<c02388e8>] via_init_one+0x38/0x40
>  [<c010507a>] init+0x3a/0x160
>  [<c0105040>] init+0x0/0x160
>  [<c0105641>] kernel_thread_helper+0x5/0x14

> Code: 8b 80 50 06 00 00 89 83 4c 06 00 00 c7 04 24 77 0d 38 c0 e8
>  <0>Kernel panic: Attempted to kill init!

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. vcdxrip , CDROM_SEND_PACKET, and 2.5.42->2.5.43 ide-cd changes

Hi,

  I often use vcdxrip to pull mpeg data off of
old vcd's/svcds to archive to tape/dvd. This
worked fine in the 2.5 kernel series up to
2.5.42 where it worked after running the app
more then once ( i assumed it was an initialization
error someplace). After kernel 2.5.43 it no longer
works. I've sent mail to the authors and they
suggested switching it from using ioctl(CDROM_SEND_PACKET)
to ioctl(CDROMREADMODE2) , which does work only
a little slower.

 I've traced it down to cdrom_queue_packet_command() in ide-cd.c
returning a 0 error status from ide_do_drive_cmd(), and
req.data_len is 0, and there doesn't appear to be any sense
available.

I'd appreciate any suggestions for tracking this further
or ideas on possible causes.

-pee

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. ATA TCQ problems in 2.5.59

3. 2.5.43+: IDE as modules, when?

4. Where to get the latest kernels?

5. 2.5.43 IDE not powered down on shutdown

6. Fault LED in Solaris

7. Problems in the sk98lin driver (2.5.43)

8. How to test for file/directory status on UNIX?

9. i2c-elektor (2.5.43) non-fatal error: unresolved symbol cli, sti

10. 2.5.43-menuconfig

11. 2.5.43 : net/ipv4/ip_forward.c compile error

12. 2.5.43 oops in adaptec driver

13. LSM changes for 2.5.43