2.5.50 keyboard won't work

2.5.50 keyboard won't work

Post by ruck » Sun, 01 Dec 2002 22:40:06



In 2.5.50 i am completly unable to get my keyboard to work.  I have selected the input device->keyboard support, but nevertheless it just doesn't work.  The machine operates fine, as in the daemons all work, just no keyboard working.  

1) This is probably a stupid stupid stupid user error.
2) I have been playing with this for the past 4 hours trying different options.
3) I am baffled.
4) Sorry if this isn't the right place for this.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

2.5.50 keyboard won't work

Post by Anes Lihova » Sun, 01 Dec 2002 22:52:53


On Sat, 30 Nov 2002 21:40:06 +0100


> In 2.5.50 i am completly unable to get my keyboard to work.  I have selected the input device->keyboard support, but nevertheless it just doesn't work.  The machine operates fine, as in the daemons all work, just no keyboard working.  

> 1) This is probably a stupid stupid stupid user error.
> 2) I have been playing with this for the past 4 hours trying different options.
> 3) I am baffled.
> 4) Sorry if this isn't the right place for this.
> -
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/

You have to Compile them in(not Module, and USB and Joystick must be enabled).
For me this works. Has your compile build the modules.dep files ???
Mine are missing ! Any idea how to do this by hand ???

Regards
Anes

 
 
 

2.5.50 keyboard won't work

Post by Andries Brouwe » Sun, 01 Dec 2002 23:50:09



> In 2.5.50 i am completly unable to get my keyboard to work.
> I have selected the input device->keyboard support

Check that you have enabled everything needed for the keyboard,
there is a whole list of options and they are all needed
(and the top ones explicitly say so).

[Input devices, Serial I/O, KBD controller, Keyboards, AT keyboard (or so)]
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. 2.5.50 / pcmcia doesn't work anymore

At least not for me. :/

If I insert the Xircom RealPort card into the slot whilst the laptop is
running, the event gets registered but all I get out of it is:

PCI: Device 02:00.0 not available because of resource collisions
PCI: Device 02:00.1 not available because of resource collisions

And no serial or ethernet devices. When I eject the card I get an oops:

Unable to handle kernel NULL pointer dereference at virtual address 00000004
 printing eip:
c01e9c39
*pde = 00000000
Oops: 0002
CPU:    0
EIP:    0060:[pci_remove_device+25/64]    Not tainted
EFLAGS: 00010296
EIP is at pci_remove_device+0x19/0x40
eax: 00000000   ebx: cf6b7800   ecx: cf6b7894   edx: 00000000
esi: 00000000   edi: cf6b7800   ebp: c12aff04   esp: c12aff00
ds: 0068   es: 0068   ss: 0068
Process events/0 (pid: 3, threadinfo=c12ae000 task=c12b2c40)
Stack: cf6b7800 c12aff1c c029f75c cf6b7800 cfdfe000 cfdfe000 c055b240 c12aff44
       c029ca16 cfdfe000 cfdfe000 cfdfe000 cfdfe00c cfdfe000 00000080 c055b240
       c12aff48 c12aff58 c029cd25
029cd65
Call Trace:
 [cb_free+40/104] cb_free+0x28/0x68
 [shutdown_socket+126/244] shutdown_socket+0x7e/0xf4
 [do_shutdown+93/100] do_shutdown+0x5d/0x64
 [parse_events+57/208] parse_events+0x39/0xd0
 [yenta_bh+59/68] yenta_bh+0x3b/0x44
 [worker_thread+467/684] worker_thread+0x1d3/0x2ac
 [worker_thread+0/684] worker_thread+0x0/0x2ac
 [yenta_bh+0/68] yenta_bh+0x0/0x44
 [default_wake_function+0/52] default_wake_function+0x0/0x34
 [default_wake_function+0/52] default_wake_function+0x0/0x34
 [kernel_thread_helper+5/12] kernel_thread_helper+0x5/0xc

Code: 89 50 04 89 02 8b 53 04 8b 03 89 50 04 89 02 53 e8 9e ff ff
 <5>cs: socket cfdfe000 timed out during reset.  Try increasing setup_delay.

At this point I have no option but to reboot the laptop. Console
switching does not work and neither is the reboot clean (no processes
wind up getting killed from memory).

In 2.5.49 the card was detected nicely and at least ethernet worked
(serial didn't, but that's for another bug report). The card would oops
on eject but that was only when I had the ethernet driver for it (either
old or new version) compiled in.

If you require further info, or any debugging, please holler and I'll
try and help.

--
        All people are equal,
        But some are more equal then others.
            - George W. Bush Jr, President of the United States
              September 21, 2002 (Abridged version of security speech)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. Memory addition problem

3. for 2.5.50, sysfs works wrong in some cases

4. printing to an lexmark with network card

5. 2.5.50 working great so far

6. AIX-driver for Quantum DLT7000

7. vesafb no longer works on 2.5.50/51

8. limit user programs

9. scx200_gpio.c doesn't compile in 2.5.50

10. 2.5.50 / compiling with frame pointers doesn't

11. can't load 8139too/mii in 2.5.50

12. 2.5.50 responsiveness

13. [2.5.50][PnP]: Issue with SBAWE32 Gameport and Serial port & IDE controller conflict