2.2.19: config help text about "TCO timer"

2.2.19: config help text about "TCO timer"

Post by Ulrich Wind » Fri, 13 Apr 2001 16:10:07



Hi,

I know I'm late, but Configure.help in 2.2.19 says:

..."The TCO (Total Cost of Ownership) timer is a watchdog"...

I know TCO meaning that, but I can't believe it for a mainboard
component. Should the user then throw the PC away, or what? Or is it
more safe to reboot frequently. What has this to do with costs?

Confused,
Ulrich

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

2.2.19: config help text about "TCO timer"

Post by Alan Co » Fri, 13 Apr 2001 20:10:05


Quote:> I know TCO meaning that, but I can't believe it for a mainboard
> component. Should the user then throw the PC away, or what? Or is it
> more safe to reboot frequently. What has this to do with costs?

Its a watchdog timer. It reduces the <buzzword>TCO</buzzword> by letting you
arrange for your machine to reboot regularly if not poked. Its wonderful and
one of the reasons I deploy i815 motherboards with VIA processors (to avoid
the need for/regular failure of CPU fans) for remote servers.

Alan

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. 2.2.19/ide.03252001 bug: "kernel timer added twice"

I just spotted these messages in my xconsole:

Apr 12 11:22:19 emma1 kernel: hda: status error: status=0x50 { DriveReady SeekComplete }
Apr 12 11:22:19 emma1 kernel: hda: no DRQ after issuing MULTWRITE
Apr 12 11:22:19 emma1 kernel: hda: ide_set_handler: handler not null; old=c01acc04, new=c01acc04
Apr 12 11:22:19 emma1 kernel: bug: kernel timer added twice at c01a835d.

My system.map mentions these in the vicinity of that address:
c01a8308 T ide_set_handler
c01a836c T current_capacity

The mentioned ide_set_handler:
c01acc04 T task_no_data_intr

The kernel has been compiled with gcc 2.95.2 with some other patches
which should not interfere however. (IDE 2.2.19.03252001, I2C 2.5.5,
ReiserFS 3.5.32, Serial 5.05, autofs4 from 4.0.0pre10, ext3 0.0.6b,
OpenWall OW1 patch)

I cannot tell what has happened exactly, at the time of this writing,
I'm running amanda (backup) which comprises dump and tar and this
message has not shown up again in the past 16 minutes.

This is a Western Digital Caviar AC420400D (seems to be IBM DJNA OEM)
attached to a VIA KT133 (board is a Gigabyte 7ZXR):

lspci info:

00:07.1 IDE interface: VIA Technologies, Inc. VT82C586 IDE [Apollo] (rev 10) (pr
        Flags: bus master, medium devsel, latency 32
        I/O ports at ffa0
        Capabilities: [c0] Power Management version 2

hdparm v3.6 info:

/dev/hda:
 multcount    = 16 (on)
 I/O support  =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 nowerr       =  0 (off)
 readonly     =  0 (off)
 readahead    =  8 (on)
 geometry     = 2482/255/63, sectors = 39876480, start = 0

 Model=WDC AC420400D, FwRev=J58OA30K, SerialNo=[NOT SHOWN]
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=34
 BuffType=3(DualPortCache), BuffSize=1966kB, MaxMultSect=16, MultSect=16
 DblWordIO=no, OldPIO=2, DMA=yes, OldDMA=2
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=39876480
 tDMA={min:120,rec:120}, DMA modes: mword0 mword1 mword2
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, PIO modes: mode3 mode4
 UDMA modes: mode0 mode1 mode2 mode3 *mode4
 Drive Supports : ATA/ATAPI-4 T13 1153D revision 17 : ATA-1 ATA-2 ATA-3 ATA-4

--
Matthias Andree
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. COLA FAQ 6 of 7 09-Nov-2002

3. Kernel 2.2.19: ERROR after "CU idle while -2 tcbs to tx" message

4. Help: internal router setup

5. "unresolved symbol strlen_user" for Linux 2.2.19?

6. solaris to connect to Broadband

7. ide-scsi detecting CDR as "CD-ROM" in 2.2.19

8. P90 system w/ Enhanced IDE?

9. Error from kernel(2.2.19 to 2.2.20) in use "make dep"

10. 2.2.19 hangs just before "Uncompressing Linux"

11. 2.2.19 + ide 2.2.19 03252001 patch problem

12. GETSERVBYNAME()????????????????????"""""""""""""

13. Why doesn't echo "text" 'command' "more text" work?