Help with SiS 648 chipset and agpgart

Help with SiS 648 chipset and agpgart

Post by Tim Le » Wed, 16 Apr 2003 00:50:06



Hi,

I need to get agpgart to work with a SiS 648 chipset and I
haven't seen any implementation of such yet.  I'm currently
using a 2.4.19 kernel.  Without a working implementation I
can't use accelerated OpenGL with an ATI Radeon 9500 pro
because the ATI drivers require working agp support.  I've
tried just using the generic-sis but that causes the driver
to mess up big time.

Any ideas?

Regards,
Tim Lee
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

Help with SiS 648 chipset and agpgart

Post by Murray J. Roo » Wed, 16 Apr 2003 01:10:06



> Hi,

> I need to get agpgart to work with a SiS 648 chipset and I
> haven't seen any implementation of such yet.  I'm currently
> using a 2.4.19 kernel.  Without a working implementation I
> can't use accelerated OpenGL with an ATI Radeon 9500 pro
> because the ATI drivers require working agp support.  I've
> tried just using the generic-sis but that causes the driver
> to mess up big time.

> Any ideas?

the SiS648 isn't in the main 2.4.x tree. It works in the -ac tree, though.

--
Murray J. Root

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

Help with SiS 648 chipset and agpgart

Post by Alan Co » Wed, 16 Apr 2003 01:20:12



Quote:> I need to get agpgart to work with a SiS 648 chipset and I
> haven't seen any implementation of such yet.  I'm currently
> using a 2.4.19 kernel.  Without a working implementation I
> can't use accelerated OpenGL with an ATI Radeon 9500 pro
> because the ATI drivers require working agp support.  I've
> tried just using the generic-sis but that causes the driver
> to mess up big time.

Currently no documentation is the problem. That may (fingers
cross) change soon. Until then sorry..

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

Help with SiS 648 chipset and agpgart

Post by Dave Jone » Wed, 16 Apr 2003 01:40:07



 > > I need to get agpgart to work with a SiS 648 chipset and I
 > Currently no documentation is the problem. That may (fingers
 > cross) change soon. Until then sorry..

I've had the 648 docs for a while under NDA, but the lack
of hardware has pushed this further down my TODO list.
I'll get to it eventually if no-one else does..

                Dave

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

Help with SiS 648 chipset and agpgart

Post by Tim Le » Wed, 16 Apr 2003 15:40:10




> > Hi,

> > I need to get agpgart to work with a SiS 648 chipset and I
> > haven't seen any implementation of such yet.  I'm currently
> > using a 2.4.19 kernel.  Without a working implementation I
> > can't use accelerated OpenGL with an ATI Radeon 9500 pro
> > because the ATI drivers require working agp support.  I've
> > tried just using the generic-sis but that causes the driver
> > to mess up big time.

> > Any ideas?

> the SiS648 isn't in the main 2.4.x tree. It works in the -ac tree, though.

In what -ac, the most recent for the 2.4.21-pre7-ac1?

Thanks,
Tim Lee

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

Help with SiS 648 chipset and agpgart

Post by Murray J. Roo » Thu, 17 Apr 2003 00:00:19





> > > Hi,

> > > I need to get agpgart to work with a SiS 648 chipset and I
> > > haven't seen any implementation of such yet.  I'm currently
> > > using a 2.4.19 kernel.  Without a working implementation I
> > > can't use accelerated OpenGL with an ATI Radeon 9500 pro
> > > because the ATI drivers require working agp support.  I've
> > > tried just using the generic-sis but that causes the driver
> > > to mess up big time.

> > > Any ideas?

> > the SiS648 isn't in the main 2.4.x tree. It works in the -ac tree, though.

> In what -ac, the most recent for the 2.4.21-pre7-ac1?

The last one that I used was 2.4.20<something> and it worked for agp.
I just use 2.5.x now cause it works a lot better with SiS chipsets (for
me, anyway).

--
Murray J. Root

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. SiS 648 / SiS 963L - which kernel?

I'm thinking of getting a
P4 - Socket 478 - Microstar ATX 648 DDR333 - LAN
which has the SiS 648 / SiS 963L chipsets.

Is anybody using this chipset combination?
If so, what kernel do you use and are there any  problems for eg with
on-board lan/audio/agp 8x etc...
I have today Suse 8.0, kernel 2.4.18.

2. Running console application in KDE

3. information for SiS 648 chip support

4. Linux Frequently Asked Questions with Answers (Part 4 of 6)

5. SiS 648

6. rsh path

7. UDMA 66 - cmd 648

8. iptabe related

9. Here's a list of 648 companies using Linux in their day-to-day operations

10. IDE UDMA on a CMD-648 Chip

11. agpgart for sis 745 and Linux

12. SiS 5595 chipset and X settings: help, please!

13. Help on accessing SiS and Super IO chipset...