[PATCH] patch's for vmware 2.0.4 for use with linux-2.4.8 kernel

[PATCH] patch's for vmware 2.0.4 for use with linux-2.4.8 kernel

Post by Alexander Hoogerhui » Sun, 19 Aug 2001 19:20:06




> > [PATCH] patch's for vmware 2.0.4 for use with linux-2.4.8 kernel


> > Date: Thu Aug 16 2001 - 03:49:38 EST

> > attached are two very small patches for those that want them. they make
> > vmware's kernel modules compile with 2.4.8. Its not all my work, its a
> > combination of what was posted a while back and my work.

> Jason,

>  a small gotcha in your vmmon patch. You moved up hostif.h in driver.c,
> but you forgot to remove the original include. See my attached new
> version of the patch.

> Martin
> --

I've applied the patch with your fixes, and I've always noticed that
VMware seem to leak a bit of memory (occording to top and ps). Running
with 128Mb in a Win2k box it started off at 161Mb process size (140Mb
RSS) and within 5 minutes it had turned into 203Mb process size (still
only 140Mb RSS). Have anyone seen similar behavior, and does anyone
have any pointers to where I can find more info on it?

mvh,
A
--
Alexander Hoogerhuis
FYI: perl -e 'print $i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10);'
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. util-linux patch inside int'l kernel patch

I applied the util-linux patch for util-linux-2.9w (available after
applying the int'l patch 2.2.13-2 to the kernel sources) to
util-linux-2.10. It seems to work. But I'm not quite confident to
proceed to a final 'make install' for the new patched util-linux.

Someone can confirm if it will hurt or not?

2. SiS 6202 anybody was able to make it work as SVGA?

3. How to patch kernel with 'Unfified IDE patch'

4. Color changes on focus

5. Help can't compile InterViews with gcc patches and Linux patches

6. Can anyone point to where I can find drivers for the SoundBlaster PCI128

7. MPC855T + Linux kernel 2.4.18 + ppc patch + bridge patch = somtimes OOPS

8. ftape and CMS DJ-10

9. Can't compile linux-2.4.8

10. Can't make module emu10k1.o with linux-2.4.8

11. Patches, patches and more patches

12. Patches Patches Patches