from intel onboard Lan and audo to install 2.4.50

from intel onboard Lan and audo to install 2.4.50

Post by eric li » Tue, 10 Dec 2002 20:00:30




 >
 >
 >> the following dmesg seem to show it detect my ac97 is i810_audio but
 >>it said Primary codec not ready
 >>
 >>please help on this
 >>in 2.4.20 intel borad
 >>/* eepro is also not work, both I all put in my /etc/modules */
 >>
 >>sincere ERic
 >>www.linuxspice.com
 >>linux pc for sale
 >>
 >>eepro_init_module: Probe is very dangerous in ISA boards!
 >>eepro_init_module: Please add "autodetect=1" to force probe
 >>CSLIP: code copyright 1989 Regents of the University of California
 >>PPP generic driver version 2.4.2
 >>PPP Deflate Compression module registered
 >>PPP BSD Compression module registered
 >>Intel 810 + AC97 Audio, version 0.21, 23:23:34 Nov 30 2002
 >>PCI: Found IRQ 3 for device 00:1f.5
 >>PCI: Sharing IRQ 3 with 00:1f.3
 >>PCI: Setting latency timer of device 00:1f.5 to 64
 >>i810: Intel ICH4 found at IO 0xe080 and 0xe400, IRQ 3
 >>i810_audio: Audio Controller supports 6 channels.
 >>i810_audio: Primary codec not ready.
 >>
 >>
 >
 >As far as I can tell, this happens if the i810 doesn't have the ac97
 >codec. Assuming that it really is an i810 card [1], you might have
 >better luck getting a response from the linux-kernel mailing list.
 >
 >[1] You've explicitly put it in /etc/modules, so who knows! Note that I
 >    don't have to explicitly add i810_audio to /etc/modules or
 >    /etc/modutils/* for my laptop; instead the kernel works it out
 >    automatically.
 >
 >
 >
 >>eepro_init_module: Probe is very dangerous in ISA boards!
 >>eepro_init_module: Please add "autodetect=1" to force probe
 >>
 >>
 >
 >The eepro module needs at least an io argument to set the I/O base
 >address(es), and possibly an irq argument too. You can use 'options'
 >lines in /etc/modutils/* to set options that are always added when
 >probing named modules; see the modules.conf(5) man page and remember to
 >run update-modules after editing files in /etc/modutils.
 >
my lspci -v result related to intel onboard LAN(assume is eepro)

 >02:08.0 Ethernet controller: Intel Corp.: Unknown device 1039 (rev 82)
 >        Subsystem: Intel Corp.: Unknown device 3015
 >        Flags: bus master, medium devsel, latency 32, IRQ 11
 >        Memory at feafe000 (32-bit, non-prefetchable) [size=4K]
 >        I/O ports at d880 [size=64]
 >        Capabilities: <available only to root>
 >

 >If it's a PCI card, you might want eepro100 instead?
 >
 >
 >
I tried put a line in /etc/modutils/actions
insmod eepro autodetect=1 IO=d880 IRQ=11
reboot , still not work
(may be sytax is wrong, have any opinion? do see man page have its
syntax on the option feature)

some say newest kernel 2.5.50 can solve all above hardware(intel board
on board LAN and audio ) problem, so I download full tar.gz, choose what
my hardware fit
make install

error happen, I justify one of it, first one, in
linux-2.4.50/include/asm-i386/io_apic.h
containing sis_apic_bug  not include its .h file

then re do  make install
still error, this time I have no clue
-----------------------------------------------------
in.o  sound/built-in.o  arch/i386/pci/built-in.o  net/built-in.o
--end-group  -o vmlinux
drivers/built-in.o(.text+0x11f15): In function `kd_nosound':
: undefined reference to `input_event'
drivers/built-in.o(.text+0x11f31): In function `kd_nosound':
: undefined reference to `input_event'
drivers/built-in.o(.text+0x11fc8): In function `kd_mksound':
: undefined reference to `input_event'
drivers/built-in.o(.text+0x12baa): In function `kbd_bh':
: undefined reference to `input_event'
drivers/built-in.o(.text+0x12bb8): In function `kbd_bh':
: undefined reference to `input_event'
drivers/built-in.o(.text+0x12bc9): more undefined references to
`input_event' follow
drivers/built-in.o(.text+0x13003): In function `kbd_connect':
: undefined reference to `input_open_device'
drivers/built-in.o(.text+0x1301f): In function `kbd_disconnect':
: undefined reference to `input_close_device'
drivers/built-in.o(.init.text+0xd71): In function `kbd_init':
: undefined reference to `input_register_handler'
make: *** [vmlinux] Error 1

------------------------------------------------------------

also I have difficult(unsuccess) patch 2.5.50
I did
gzip -cd patch-2.5.50-ac1.gz  | patch -p0
in my home direction which I untar unzip linux-2.5.50.tar.gz
it ask file to patch
I type patch-2.5.50-ac1.gz again,   not right, so produc .orig and .rej
files, please help on that

highly appreciate your help and your time
sincere Eric
www.linuxspice.com
linux pc for sale

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

 
 
 

1. from intel onboard Lan and audo to install 2.4.50

I did,
but it terminate with error

  gcc -Wp,-MD,drivers/pci/.quirks.o.d -D__KERNEL__ -Iinclude -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686
-Iarch/i386/mach-generic -Iarch/i386/mach-defaults -nostdinc
-iwithprefix include    -DKBUILD_BASENAME=quirks -DKBUILD_MODNAME=quirks
   -c -o drivers/pci/quirks.o drivers/pci/quirks.c
drivers/pci/quirks.c: In function `quirk_ioapic_rmw':
drivers/pci/quirks.c:354: `sis_apic_bug' undeclared (first use in this
function)
drivers/pci/quirks.c:354: (Each undeclared identifier is reported only once
drivers/pci/quirks.c:354: for each function it appears in.)
make[3]: *** [drivers/pci/quirks.o] Error 1
make[2]: *** [drivers/pci] Error 2
make[1]: *** [drivers] Error 2
make[1]: Leaving directory `/home/fsshl/linux-2.5.50'
make: *** [stamp-build] Error 2
www:/home/fsshl/linux-2.5.50#

if someone know it be modifed, please drop me a note where I can get the
fixed source.
it's on 2.5.50.ac-1 patched 2.5.50 from kernel.org
hihgly apprecaite

--
Sincere Eric
www.linuxspice.com
linux pc for sale

--


2. 3c509 NICs and Red Hat 6.1

3. Linux 2.4.50: aha152x does not compile

4. Problem with Matrox Millennium II Graphics Server in XFree86

5. 2.4.50 - 8250_cs does NOT work

6. how to use macutils?!?!

7. Intel 82558 100/10Mbps LAN Onboard

8. Device Driver Writing Tools

9. Asus P4PE onboard lan driver bcm4401 / bcm4400 RedHat 8.0 linux install : SOLVED

10. Seeking Linux laptop (Name brand, Intel chipset, ATI/Intel video, LAN)

11. Onboard LAN and WLAN PCI card don't work together

12. K5S7A onboard LAN w/ linux (mandrake)

13. Wake On Lan with RedHat 9 and onboard Realtek 8139