How to load an XML to DOM in eVc?

How to load an XML to DOM in eVc?

Post by Marsha » Tue, 25 Sep 2001 15:26:19



Could you tell me How to load an XML to a DOM object in
eVc?We are getting error when we are using loadXML of
DOMDocument object.Intresting thing is loadXML is working
in all paltforms except in wince device.
 
 
 

How to load an XML to DOM in eVc?

Post by Noam » Tue, 25 Sep 2001 18:26:03


the loadXML method should work (i use it in my code...
VARIANT_BOOL tBool = VARIANT_FALSE ;

m_pDoc->loadXML(CComBSTR(xml), &tBool);

)

please note that there is a bug in the 'load' methode, so don't use it (the
document is deleted after loading)

-Noam


Quote:> Could you tell me How to load an XML to a DOM object in
> eVc?We are getting error when we are using loadXML of
> DOMDocument object.Intresting thing is loadXML is working
> in all paltforms except in wince device.


 
 
 

How to load an XML to DOM in eVc?

Post by suvra » Tue, 25 Sep 2001 18:43:34


Noam, I had also noticed this line in msdn that load deletes the document.
However, I am using load method in my code, and so far have not encountered
this bug.
Maybe it is outright stupid question, but still: when you say the document
is deleted after loading, what exactly do you mean by this. I notice that my
xml file is very much in the device.
Thanks,
Suvrat


> the loadXML method should work (i use it in my code...
> VARIANT_BOOL tBool = VARIANT_FALSE ;

> m_pDoc->loadXML(CComBSTR(xml), &tBool);

> )

> please note that there is a bug in the 'load' methode, so don't use it
(the
> document is deleted after loading)

> -Noam



> > Could you tell me How to load an XML to a DOM object in
> > eVc?We are getting error when we are using loadXML of
> > DOMDocument object.Intresting thing is loadXML is working
> > in all paltforms except in wince device.

 
 
 

How to load an XML to DOM in eVc?

Post by Richar » Tue, 25 Sep 2001 23:53:34


I tried to use the LoadXML method but found if when debugging I passed in
invalid XML the function never returns.

eg If i were to call
    m_pDoc->loadXML(CComBSTR(L"<tag1Hello</tag1><tag2>xml</tag2>"), &tBool);

this would not return while debugging over network card. Seemed to work when
running app on device but not through debugging environment.

Just an observation.

Richard


> the loadXML method should work (i use it in my code...
> VARIANT_BOOL tBool = VARIANT_FALSE ;

> m_pDoc->loadXML(CComBSTR(xml), &tBool);

> )

> please note that there is a bug in the 'load' methode, so don't use it
(the
> document is deleted after loading)

> -Noam



> > Could you tell me How to load an XML to a DOM object in
> > eVc?We are getting error when we are using loadXML of
> > DOMDocument object.Intresting thing is loadXML is working
> > in all paltforms except in wince device.

 
 
 

How to load an XML to DOM in eVc?

Post by Noam » Tue, 25 Sep 2001 20:56:38


Well, maybe you are lucky...
seriously, when using the 'load' method, the file is deleted from the file
system. perhaps your file is read-only or in read-only memory ?
did your XML file loaded into the DOM at all ? maybe it is not deleted due
to the fact it is not loaded...
-Noam


> Noam, I had also noticed this line in msdn that load deletes the document.
> However, I am using load method in my code, and so far have not
encountered
> this bug.
> Maybe it is outright stupid question, but still: when you say the document
> is deleted after loading, what exactly do you mean by this. I notice that
my
> xml file is very much in the device.
> Thanks,
> Suvrat



> > the loadXML method should work (i use it in my code...
> > VARIANT_BOOL tBool = VARIANT_FALSE ;

> > m_pDoc->loadXML(CComBSTR(xml), &tBool);

> > )

> > please note that there is a bug in the 'load' methode, so don't use it
> (the
> > document is deleted after loading)

> > -Noam



> > > Could you tell me How to load an XML to a DOM object in
> > > eVc?We are getting error when we are using loadXML of
> > > DOMDocument object.Intresting thing is loadXML is working
> > > in all paltforms except in wince device.

 
 
 

1. eVC to Load a Local File into XML Parser

Does anyone have sample code for loading a local file into
the XML DOM with eVC? The MS Article "Using C++ to Load a
Local File into the XML Parser" By Chris Muench, Apr. 10,
2001 requires a class "FileStream" but there is no info as
to how to implement such a class.

2. Hayes Modems - Channnel 2 or Call Waiting Feature

3. Is it possible to load a XML Document from file into XDLDOM using Load in PIE?

4. Power on or off?

5. eVB XML-DOM-CE SQL corrupting File control?

6. Gigs Needed

7. XML DOM

8. Accessing the HTML DOM Tree in eVC++?

9. "Failed to load XML parser COM object" on ppc2002 emulator start

10. XML load method, does it really work ????

11. Using C++ to Load a Local File into the XML Parser

12. loading xml files always failed, why ?