CGI script execution in SSL problem

CGI script execution in SSL problem

Post by Forest John » Thu, 18 Nov 1999 04:00:00



I have a site up on a Apache unix server. I am running a CGI shopping cart
script in the root directory. In order to do this, I have the following
htaccess file:

Options ExecCGI
AddHandler cgi-script .cgi
AddHandler server-parsed .html

However, when I try to run the script in Secure SSL mode, it does not
execute (ie. http://www.site.com/cart.cgi works, but
https://www.site.com/cart.cgi just shows the text of the script and is not
executed. Any ideas why this is happening? Need an answer ASAP.

Thanks all.

--
Forest Johns

Fifth Gear Marketing Systems
12A 1950 Government Street
Victoria, B.C., V8T 4N8
(250) 388-9422

 
 
 

1. CGI script execution problem in SSL

I have a site up on a Apache unix server. I am running a CGI shopping cart
script in the root directory. In order to do this, I have the following
htaccess file:

Options ExecCGI
AddHandler cgi-script .cgi
AddHandler server-parsed .html

However, when I try to run the script in Secure SSL mode, it does not
execute (ie. http://www.site.com/cart.cgi works, but
https://www.site.com/cart.cgi just shows the text of the script and is not
executed. Any ideas why this is happening? Need an answer ASAP.

Thanks all.

--
Forest Johns

Fifth Gear Marketing Systems
12A 1950 Government Street
Victoria, B.C., V8T 4N8
(250) 388-9422

2. Looking for clock.

3. Apache CGI/Perl script execution problem

4. Scan a Directory/cron question

5. Execution of CGI scripts in Apache

6. Tape Backup Software

7. apache setup/enabling execution of cgi scripts

8. Disabling laptop LCD panel (C&T 65550)

9. Non execution of CGI scripts

10. CGI-Execution with UID/GID of script-owner

11. CGI Script Execution Error

12. ssl cgi script not running?

13. CGI Script Forcing a SSL Connection...can this be done?