perl problem

perl problem

Post by boler.. » Sat, 01 Apr 2000 04:00:00



My machine is running Solaris 7 on E250
I have download Perl from www.sunfreeware.com

in my perl script, there are two lines:
use LWP::Socket;        # network socket module
use CGI qw(:all);       # CGI forms etc

when i invoke the perl script, it showed me the errors:

/usr/local/lib/perl5/5.00503/sun4-solaris /usr/local/lib/perl5/5.00503
/usr/local/lib/perl5/site_perl/5.005/sun4-solaris
/usr/local/lib/perl5/site_perl/5.005 .)
 at bored.pl line 3.
BEGIN failed--compilation aborted at bored.pl line 3.

How to solve this problem?

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

perl problem

Post by Martin Hepwort » Sat, 01 Apr 2000 04:00:00


Hi
sounds like you haven't got the LWP:: bundle installed.

use CPAN to install it, its the easiest way...

http://www.cpan.org/misc/cpan-faq.html

Martin


> My machine is running Solaris 7 on E250
> I have download Perl from www.sunfreeware.com

> in my perl script, there are two lines:
> use LWP::Socket;        # network socket module
> use CGI qw(:all);       # CGI forms etc

> when i invoke the perl script, it showed me the errors:

> /usr/local/lib/perl5/5.00503/sun4-solaris /usr/local/lib/perl5/5.00503
> /usr/local/lib/perl5/site_perl/5.005/sun4-solaris
> /usr/local/lib/perl5/site_perl/5.005 .)
>  at bored.pl line 3.
> BEGIN failed--compilation aborted at bored.pl line 3.

> How to solve this problem?

> Sent via Deja.com http://www.deja.com/
> Before you buy.


 
 
 

perl problem

Post by boler.. » Tue, 04 Apr 2000 04:00:00


I have gone through CPAN site and can't find LWP::Socket
under the LWP directory, this is no Socket related module at

http://www.perl.com/CPAN-local/modules/by-module/LWP/

thank you.



> Hi
> sounds like you haven't got the LWP:: bundle installed.

> use CPAN to install it, its the easiest way...

> http://www.cpan.org/misc/cpan-faq.html

> Martin


> > My machine is running Solaris 7 on E250
> > I have download Perl from www.sunfreeware.com

> > in my perl script, there are two lines:
> > use LWP::Socket; # network socket module
> > use CGI qw(:all); # CGI forms etc

> > when i invoke the perl script, it showed me the errors:

> > /usr/local/lib/perl5/5.00503/sun4-solaris

/usr/local/lib/perl5/5.00503

Quote:> > /usr/local/lib/perl5/site_perl/5.005/sun4-solaris
> > /usr/local/lib/perl5/site_perl/5.005 .)
> > at bored.pl line 3.
> > BEGIN failed--compilation aborted at bored.pl line 3.

> > How to solve this problem?

> > Sent via Deja.com http://www.deja.com/
> > Before you buy.

Sent via Deja.com http://www.deja.com/
Before you buy.
 
 
 

perl problem

Post by Jenny Holmber » Tue, 04 Apr 2000 04:00:00



> I have gone through CPAN site and can't find LWP::Socket
> under the LWP directory, this is no Socket related module at

> http://www.perl.com/CPAN-local/modules/by-module/LWP/

First, use
perldoc CPAN

Second, to find a module, do
perldoc -MCPAN -e shell

cpan> i LWP::Socket

and you'll be told in which file the module is to be found, in this
case:

Module id = LWP::Socket

    CPAN_VERSION 1.24
    CPAN_FILE    GAAS/LWP-attic-1.00.tar.gz
    INST_FILE    (not installed)

--
Jenny With the Axe, and the Temper   http://www.algonet.se/~jenny-h/
#include <std_disclaimer.h>
"You are in front of me. If you value your lives, be somewhere else."
--Ambassador Delenn, B5

 
 
 

perl problem

Post by Ilyas Guennou » Tue, 04 Apr 2000 04:00:00



> My machine is running Solaris 7 on E250
> I have download Perl from www.sunfreeware.com

> in my perl script, there are two lines:
> use LWP::Socket;        # network socket module
> use CGI qw(:all);       # CGI forms etc

> when i invoke the perl script, it showed me the errors:

> /usr/local/lib/perl5/5.00503/sun4-solaris /usr/local/lib/perl5/5.00503
> /usr/local/lib/perl5/site_perl/5.005/sun4-solaris
> /usr/local/lib/perl5/site_perl/5.005 .)
>  at bored.pl line 3.
> BEGIN failed--compilation aborted at bored.pl line 3.

> How to solve this problem?


it will display the path of the library used by perl
then you can verify if the library CGI and LWP exist (i don't think it
will )
if you know where they are located you can use the "-I path_of_the_lib"
option in the interpretor line.

--
GUENNOUN Ilyas
Alcatel Telecom Maroc  Network Management
telephone: (212-7) 81-98-45          via alcanet 2620-145

 
 
 

1. Apache 2.0.35 and perl problem: bad $0 (path) variable

Hello, I'm french and my english is poor, sorry.

I have a lot of perl script who use the $0 variable ( path of the
script ) and with apache 2.0.35, this variable is bad:

with apache 1.3.xx: $0 = /export/home/drds/script/example.pl

with apache 2.0.35: $0 = example.pl

In httpd.conf:

ScriptAlias /cgi /export/home/drds/script

How can I configure apache to have the complete path ?

Thanks, DrDS.

2. setting up multiple domains??

3. SSLeay for SSL - perl problem????

4. Partitioning

5. perl problem

6. XV question

7. Apache or Perl problem - image won't display

8. SCO UNIX Security

9. mirror/perl problem

10. Perl problem on LinuxPPC 2000

11. I have got a Perl problem

12. Perl problem

13. apache rewrite prg / perl problems