Apache 1.3.27+SSL httpd memory issues

Apache 1.3.27+SSL httpd memory issues

Post by Christine Mille » Fri, 20 Dec 2002 03:22:00



Hello -

I'm having problems building Apache 1.3.27 with openssl-0.9.6h,
mod_ssl-2.8.12-1.3.27, php 4.23, postgresql 7.3 and mm-1.21.
Symptom:  running ./apachectl startssl produces httpd processes that are
137 MB in size.
Contrariwise running ./apachectl start produces httpd processes that are
about 4.5 MB in size.

No compile time errors.

I have a Sunfire v880 w/ 4GB of RAM running Solaris 8 at current patch
levels.

I use gcc 3.2, gmake 3.80, perl 5.80 and zlib-1.1.4.  All are built from
source code with the exception of perl which was built using a Sun
package.  
I also build pdflib, but I don't think it is related to the problem.  

Here are my path and ld_libary_path statements:
setenv PATH
/usr/local/bin:/usr/bin:/usr/sbin:/usr/local/sbin:/usr/ccs/bin:/usr
/man:/usr/local/lib:/usr/ucb:$PATH
setenv LD_LIBRARY_PATH
/usr/local/lib:/usr/local/ssl/lib:/usr/local/include

Here are my build scripts:  
I've tried various tweaks, but every tweak produces the same results.  

openssl-0.9.6h
./config shared (have also tried -fPIC and no-threads)
make
make test
make install

mm-1.2.1
./configure (have also tried -disable-shared)
make
make test
make install

mod_ssl-2.8.12-1.3.27
./configure -with-apache=/path/to/apache/src

apache_1.3.27
EAPI__MM="/www/src/mm-1.2.1" SSL_BASE="/usr/local/ssl" ./configure \
--prefix=/www/apache_1.3.27 \
--enable-module=unique_id \
--enable-module=rewrite \
--enable-module=expires \
--enable-module=info \
--enable-module=log_agent \
--enable-module=log_referer \
--enable-module=usertrack \
--enable-module=proxy \
--enable-module=userdir \
--enable-module=so \
--enable-shared=ssl \
--enable-module=ssl \
make
make install

mod_dav-1.0.3-1.3.6
./configure -with-apxs=/path/to/apache/bin/apxs
make
make install

postgresql-7.3
./configure \
--enable-odbc \
--with-unixodbc \
--with-pam \
--with-openssl \

php-4.2.3
./configure \
--with-apxs=/www/apache_1.3.27/bin/apxs \
--with-pgsql=/usr/local/pgsql \
--enable-track-vars \
--with-openssl=/usr/local/ssl \
--enable-ftp \
--enable-sysvsem \
--enable-sysvshm \
--enable-sockets \
--with-pdflib=/usr/local \
--with-mm=/www/src/mm-1.2.1 \
--with-zlib-dir=/www/src \

I'm looking forward to solving this one.  I'm sorry if this question has
been posted before.  I've done a lot of searching during the past few
days, but for some reason, I've come up empty.  

Here is top output:
PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
    70 root      12  48    0 5736K 5504K sleep    0:07  0.99% picld
last pid:   401;  load averages:  0.03,  0.04,  0.02                  
08:07:38
48 processes:  47 sleeping, 1 on cpu
CPU states: 97.0% idle,  1.8% user,  1.2% kernel,  0.0% iowait,  0.0%
swap
Memory: 4096M real, 3800M free, 190M swap in use, 4306M swap free

   PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
    70 root      12  48    0 5744K 5512K sleep    0:08  1.08% picld
   401 root       1  58    0 2608K 1712K cpu/0    0:00  0.25% top
   395 root       3  58    0  137M 5320K sleep    0:00  0.15% httpd
   379 root       1  48    0 2736K 2344K sleep    0:00  0.03% tcsh
   400 nobody     4  11    0  137M 1736K sleep    0:00  0.01% httpd
   397 nobody     3  41    0  137M 1728K sleep    0:00  0.01% httpd
   363 cemiller   1  58    0 5968K 1776K sleep    0:00  0.01% sshd
   345 root       1  59    0   25M   66M sleep    0:00  0.01% Xsun
   399 nobody     3  21    0  137M 1728K sleep    0:00  0.00% httpd
   398 nobody     3  31    0  137M 1728K sleep    0:00  0.00% httpd
   297 root       1  31    0 1008K  392K sleep    0:00  0.00% efdaemon
   278 root       1  32    0 1720K 1264K sleep    0:00  0.00% smcboot
   361 root       1  35    0 5944K 2432K sleep    0:00  0.00% sshd
   238 root       1  41    0 1096K  712K sleep    0:00  0.00% sf880drd
   280 root       1  42    0 1720K  760K sleep    0:00  0.00% smcboot

Note:  This is a pre-production server.  I don't have any code on the
server yet.  Our primary development environment is php/postgres.

Thanks for your help,
Christine

--
Christine E. Miller
Director of Information Technology
Franklin College Dean's Office

Office: 706-542-1546
Fax: 706-542-3422
http://www.franklin.uga.edu/

 
 
 

Apache 1.3.27+SSL httpd memory issues

Post by ting » Fri, 20 Dec 2002 12:31:12


Christine,

Top output can be quite confusing sometimes. If serveral processes share
memory, the size of each
process will be shown as <process size + shared memory size>. For example,
if you have 10 Apache
processes running and each of them is 7M, and they all share a pool of 130M
memory. Top will show each
process takes up 137M, which does not mean all 10 processes use 137x10M
because 130M is
shared. That may be why you still have 3800M free in Top output.

Tony


> Hello -

> I'm having problems building Apache 1.3.27 with openssl-0.9.6h,
> mod_ssl-2.8.12-1.3.27, php 4.23, postgresql 7.3 and mm-1.21.
> Symptom:  running ./apachectl startssl produces httpd processes that are
> 137 MB in size.
> Contrariwise running ./apachectl start produces httpd processes that are
> about 4.5 MB in size.

> No compile time errors.

> I have a Sunfire v880 w/ 4GB of RAM running Solaris 8 at current patch
> levels.

> I use gcc 3.2, gmake 3.80, perl 5.80 and zlib-1.1.4.  All are built from
> source code with the exception of perl which was built using a Sun
> package.
> I also build pdflib, but I don't think it is related to the problem.

> Here are my path and ld_libary_path statements:
> setenv PATH
> /usr/local/bin:/usr/bin:/usr/sbin:/usr/local/sbin:/usr/ccs/bin:/usr
> /man:/usr/local/lib:/usr/ucb:$PATH
> setenv LD_LIBRARY_PATH
> /usr/local/lib:/usr/local/ssl/lib:/usr/local/include

> Here are my build scripts:
> I've tried various tweaks, but every tweak produces the same results.

> openssl-0.9.6h
> ./config shared (have also tried -fPIC and no-threads)
> make
> make test
> make install

> mm-1.2.1
> ./configure (have also tried -disable-shared)
> make
> make test
> make install

> mod_ssl-2.8.12-1.3.27
> ./configure -with-apache=/path/to/apache/src

> apache_1.3.27
> EAPI__MM="/www/src/mm-1.2.1" SSL_BASE="/usr/local/ssl" ./configure \
> --prefix=/www/apache_1.3.27 \
> --enable-module=unique_id \
> --enable-module=rewrite \
> --enable-module=expires \
> --enable-module=info \
> --enable-module=log_agent \
> --enable-module=log_referer \
> --enable-module=usertrack \
> --enable-module=proxy \
> --enable-module=userdir \
> --enable-module=so \
> --enable-shared=ssl \
> --enable-module=ssl \
> make
> make install

> mod_dav-1.0.3-1.3.6
> ./configure -with-apxs=/path/to/apache/bin/apxs
> make
> make install

> postgresql-7.3
> ./configure \
> --enable-odbc \
> --with-unixodbc \
> --with-pam \
> --with-openssl \

> php-4.2.3
> ./configure \
> --with-apxs=/www/apache_1.3.27/bin/apxs \
> --with-pgsql=/usr/local/pgsql \
> --enable-track-vars \
> --with-openssl=/usr/local/ssl \
> --enable-ftp \
> --enable-sysvsem \
> --enable-sysvshm \
> --enable-sockets \
> --with-pdflib=/usr/local \
> --with-mm=/www/src/mm-1.2.1 \
> --with-zlib-dir=/www/src \

> I'm looking forward to solving this one.  I'm sorry if this question has
> been posted before.  I've done a lot of searching during the past few
> days, but for some reason, I've come up empty.

> Here is top output:
> PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
>     70 root      12  48    0 5736K 5504K sleep    0:07  0.99% picld
> last pid:   401;  load averages:  0.03,  0.04,  0.02
> 08:07:38
> 48 processes:  47 sleeping, 1 on cpu
> CPU states: 97.0% idle,  1.8% user,  1.2% kernel,  0.0% iowait,  0.0%
> swap
> Memory: 4096M real, 3800M free, 190M swap in use, 4306M swap free

>    PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
>     70 root      12  48    0 5744K 5512K sleep    0:08  1.08% picld
>    401 root       1  58    0 2608K 1712K cpu/0    0:00  0.25% top
>    395 root       3  58    0  137M 5320K sleep    0:00  0.15% httpd
>    379 root       1  48    0 2736K 2344K sleep    0:00  0.03% tcsh
>    400 nobody     4  11    0  137M 1736K sleep    0:00  0.01% httpd
>    397 nobody     3  41    0  137M 1728K sleep    0:00  0.01% httpd
>    363 cemiller   1  58    0 5968K 1776K sleep    0:00  0.01% sshd
>    345 root       1  59    0   25M   66M sleep    0:00  0.01% Xsun
>    399 nobody     3  21    0  137M 1728K sleep    0:00  0.00% httpd
>    398 nobody     3  31    0  137M 1728K sleep    0:00  0.00% httpd
>    297 root       1  31    0 1008K  392K sleep    0:00  0.00% efdaemon
>    278 root       1  32    0 1720K 1264K sleep    0:00  0.00% smcboot
>    361 root       1  35    0 5944K 2432K sleep    0:00  0.00% sshd
>    238 root       1  41    0 1096K  712K sleep    0:00  0.00% sf880drd
>    280 root       1  42    0 1720K  760K sleep    0:00  0.00% smcboot

> Note:  This is a pre-production server.  I don't have any code on the
> server yet.  Our primary development environment is php/postgres.

> Thanks for your help,
> Christine

> --
> Christine E. Miller
> Director of Information Technology
> Franklin College Dean's Office

> Office: 706-542-1546
> Fax: 706-542-3422
> http://www.franklin.uga.edu/


 
 
 

Apache 1.3.27+SSL httpd memory issues

Post by Christine Mille » Fri, 20 Dec 2002 23:40:48


Hi Tony --

Thanks for your reply.  

I have to admit I don't know anything about shared memory.  The size of
the process just makes me nervous.

Happy holidays,
Christine


> Christine,

> Top output can be quite confusing sometimes. If serveral processes share
> memory, the size of each
> process will be shown as <process size + shared memory size>. For example,
> if you have 10 Apache
> processes running and each of them is 7M, and they all share a pool of 130M
> memory. Top will show each
> process takes up 137M, which does not mean all 10 processes use 137x10M
> because 130M is
> shared. That may be why you still have 3800M free in Top output.

> Tony



> > Hello -

> > I'm having problems building Apache 1.3.27 with openssl-0.9.6h,
> > mod_ssl-2.8.12-1.3.27, php 4.23, postgresql 7.3 and mm-1.21.
> > Symptom:  running ./apachectl startssl produces httpd processes that are
> > 137 MB in size.
> > Contrariwise running ./apachectl start produces httpd processes that are
> > about 4.5 MB in size.

> > No compile time errors.

> > I have a Sunfire v880 w/ 4GB of RAM running Solaris 8 at current patch
> > levels.

> > I use gcc 3.2, gmake 3.80, perl 5.80 and zlib-1.1.4.  All are built from
> > source code with the exception of perl which was built using a Sun
> > package.
> > I also build pdflib, but I don't think it is related to the problem.

> > Here are my path and ld_libary_path statements:
> > setenv PATH
> > /usr/local/bin:/usr/bin:/usr/sbin:/usr/local/sbin:/usr/ccs/bin:/usr
> > /man:/usr/local/lib:/usr/ucb:$PATH
> > setenv LD_LIBRARY_PATH
> > /usr/local/lib:/usr/local/ssl/lib:/usr/local/include

> > Here are my build scripts:
> > I've tried various tweaks, but every tweak produces the same results.

> > openssl-0.9.6h
> > ./config shared (have also tried -fPIC and no-threads)
> > make
> > make test
> > make install

> > mm-1.2.1
> > ./configure (have also tried -disable-shared)
> > make
> > make test
> > make install

> > mod_ssl-2.8.12-1.3.27
> > ./configure -with-apache=/path/to/apache/src

> > apache_1.3.27
> > EAPI__MM="/www/src/mm-1.2.1" SSL_BASE="/usr/local/ssl" ./configure \
> > --prefix=/www/apache_1.3.27 \
> > --enable-module=unique_id \
> > --enable-module=rewrite \
> > --enable-module=expires \
> > --enable-module=info \
> > --enable-module=log_agent \
> > --enable-module=log_referer \
> > --enable-module=usertrack \
> > --enable-module=proxy \
> > --enable-module=userdir \
> > --enable-module=so \
> > --enable-shared=ssl \
> > --enable-module=ssl \
> > make
> > make install

> > mod_dav-1.0.3-1.3.6
> > ./configure -with-apxs=/path/to/apache/bin/apxs
> > make
> > make install

> > postgresql-7.3
> > ./configure \
> > --enable-odbc \
> > --with-unixodbc \
> > --with-pam \
> > --with-openssl \

> > php-4.2.3
> > ./configure \
> > --with-apxs=/www/apache_1.3.27/bin/apxs \
> > --with-pgsql=/usr/local/pgsql \
> > --enable-track-vars \
> > --with-openssl=/usr/local/ssl \
> > --enable-ftp \
> > --enable-sysvsem \
> > --enable-sysvshm \
> > --enable-sockets \
> > --with-pdflib=/usr/local \
> > --with-mm=/www/src/mm-1.2.1 \
> > --with-zlib-dir=/www/src \

> > I'm looking forward to solving this one.  I'm sorry if this question has
> > been posted before.  I've done a lot of searching during the past few
> > days, but for some reason, I've come up empty.

> > Here is top output:
> > PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
> >     70 root      12  48    0 5736K 5504K sleep    0:07  0.99% picld
> > last pid:   401;  load averages:  0.03,  0.04,  0.02
> > 08:07:38
> > 48 processes:  47 sleeping, 1 on cpu
> > CPU states: 97.0% idle,  1.8% user,  1.2% kernel,  0.0% iowait,  0.0%
> > swap
> > Memory: 4096M real, 3800M free, 190M swap in use, 4306M swap free

> >    PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
> >     70 root      12  48    0 5744K 5512K sleep    0:08  1.08% picld
> >    401 root       1  58    0 2608K 1712K cpu/0    0:00  0.25% top
> >    395 root       3  58    0  137M 5320K sleep    0:00  0.15% httpd
> >    379 root       1  48    0 2736K 2344K sleep    0:00  0.03% tcsh
> >    400 nobody     4  11    0  137M 1736K sleep    0:00  0.01% httpd
> >    397 nobody     3  41    0  137M 1728K sleep    0:00  0.01% httpd
> >    363 cemiller   1  58    0 5968K 1776K sleep    0:00  0.01% sshd
> >    345 root       1  59    0   25M   66M sleep    0:00  0.01% Xsun
> >    399 nobody     3  21    0  137M 1728K sleep    0:00  0.00% httpd
> >    398 nobody     3  31    0  137M 1728K sleep    0:00  0.00% httpd
> >    297 root       1  31    0 1008K  392K sleep    0:00  0.00% efdaemon
> >    278 root       1  32    0 1720K 1264K sleep    0:00  0.00% smcboot
> >    361 root       1  35    0 5944K 2432K sleep    0:00  0.00% sshd
> >    238 root       1  41    0 1096K  712K sleep    0:00  0.00% sf880drd
> >    280 root       1  42    0 1720K  760K sleep    0:00  0.00% smcboot

> > Note:  This is a pre-production server.  I don't have any code on the
> > server yet.  Our primary development environment is php/postgres.

> > Thanks for your help,
> > Christine

> > --
> > Christine E. Miller
> > Director of Information Technology
> > Franklin College Dean's Office

> > Office: 706-542-1546
> > Fax: 706-542-3422
> > http://www.franklin.uga.edu/

--
Christine E. Miller
Director of Information Technology
Franklin College Dean's Office

Office: 706-542-1546
Fax: 706-542-3422
http://www.franklin.uga.edu/
 
 
 

Apache 1.3.27+SSL httpd memory issues

Post by ting » Sat, 21 Dec 2002 09:17:42


Christine,

It's not as bad as it looks. As long as there is no performance issues, you
have nothing to worry about.

Happy holidays to you too,
Tony


> Hi Tony --

> Thanks for your reply.

> I have to admit I don't know anything about shared memory.  The size of
> the process just makes me nervous.

> Happy holidays,
> Christine


> > Christine,

> > Top output can be quite confusing sometimes. If serveral processes share
> > memory, the size of each
> > process will be shown as <process size + shared memory size>. For
example,
> > if you have 10 Apache
> > processes running and each of them is 7M, and they all share a pool of
130M
> > memory. Top will show each
> > process takes up 137M, which does not mean all 10 processes use 137x10M
> > because 130M is
> > shared. That may be why you still have 3800M free in Top output.

> > Tony



> > > Hello -

> > > I'm having problems building Apache 1.3.27 with openssl-0.9.6h,
> > > mod_ssl-2.8.12-1.3.27, php 4.23, postgresql 7.3 and mm-1.21.
> > > Symptom:  running ./apachectl startssl produces httpd processes that
are
> > > 137 MB in size.
> > > Contrariwise running ./apachectl start produces httpd processes that
are
> > > about 4.5 MB in size.

> > > No compile time errors.

> > > I have a Sunfire v880 w/ 4GB of RAM running Solaris 8 at current patch
> > > levels.

> > > I use gcc 3.2, gmake 3.80, perl 5.80 and zlib-1.1.4.  All are built
from
> > > source code with the exception of perl which was built using a Sun
> > > package.
> > > I also build pdflib, but I don't think it is related to the problem.

> > > Here are my path and ld_libary_path statements:
> > > setenv PATH
> > > /usr/local/bin:/usr/bin:/usr/sbin:/usr/local/sbin:/usr/ccs/bin:/usr
> > > /man:/usr/local/lib:/usr/ucb:$PATH
> > > setenv LD_LIBRARY_PATH
> > > /usr/local/lib:/usr/local/ssl/lib:/usr/local/include

> > > Here are my build scripts:
> > > I've tried various tweaks, but every tweak produces the same results.

> > > openssl-0.9.6h
> > > ./config shared (have also tried -fPIC and no-threads)
> > > make
> > > make test
> > > make install

> > > mm-1.2.1
> > > ./configure (have also tried -disable-shared)
> > > make
> > > make test
> > > make install

> > > mod_ssl-2.8.12-1.3.27
> > > ./configure -with-apache=/path/to/apache/src

> > > apache_1.3.27
> > > EAPI__MM="/www/src/mm-1.2.1" SSL_BASE="/usr/local/ssl" ./configure \
> > > --prefix=/www/apache_1.3.27 \
> > > --enable-module=unique_id \
> > > --enable-module=rewrite \
> > > --enable-module=expires \
> > > --enable-module=info \
> > > --enable-module=log_agent \
> > > --enable-module=log_referer \
> > > --enable-module=usertrack \
> > > --enable-module=proxy \
> > > --enable-module=userdir \
> > > --enable-module=so \
> > > --enable-shared=ssl \
> > > --enable-module=ssl \
> > > make
> > > make install

> > > mod_dav-1.0.3-1.3.6
> > > ./configure -with-apxs=/path/to/apache/bin/apxs
> > > make
> > > make install

> > > postgresql-7.3
> > > ./configure \
> > > --enable-odbc \
> > > --with-unixodbc \
> > > --with-pam \
> > > --with-openssl \

> > > php-4.2.3
> > > ./configure \
> > > --with-apxs=/www/apache_1.3.27/bin/apxs \
> > > --with-pgsql=/usr/local/pgsql \
> > > --enable-track-vars \
> > > --with-openssl=/usr/local/ssl \
> > > --enable-ftp \
> > > --enable-sysvsem \
> > > --enable-sysvshm \
> > > --enable-sockets \
> > > --with-pdflib=/usr/local \
> > > --with-mm=/www/src/mm-1.2.1 \
> > > --with-zlib-dir=/www/src \

> > > I'm looking forward to solving this one.  I'm sorry if this question
has
> > > been posted before.  I've done a lot of searching during the past few
> > > days, but for some reason, I've come up empty.

> > > Here is top output:
> > > PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
> > >     70 root      12  48    0 5736K 5504K sleep    0:07  0.99% picld
> > > last pid:   401;  load averages:  0.03,  0.04,  0.02
> > > 08:07:38
> > > 48 processes:  47 sleeping, 1 on cpu
> > > CPU states: 97.0% idle,  1.8% user,  1.2% kernel,  0.0% iowait,  0.0%
> > > swap
> > > Memory: 4096M real, 3800M free, 190M swap in use, 4306M swap free

> > >    PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
> > >     70 root      12  48    0 5744K 5512K sleep    0:08  1.08% picld
> > >    401 root       1  58    0 2608K 1712K cpu/0    0:00  0.25% top
> > >    395 root       3  58    0  137M 5320K sleep    0:00  0.15% httpd
> > >    379 root       1  48    0 2736K 2344K sleep    0:00  0.03% tcsh
> > >    400 nobody     4  11    0  137M 1736K sleep    0:00  0.01% httpd
> > >    397 nobody     3  41    0  137M 1728K sleep    0:00  0.01% httpd
> > >    363 cemiller   1  58    0 5968K 1776K sleep    0:00  0.01% sshd
> > >    345 root       1  59    0   25M   66M sleep    0:00  0.01% Xsun
> > >    399 nobody     3  21    0  137M 1728K sleep    0:00  0.00% httpd
> > >    398 nobody     3  31    0  137M 1728K sleep    0:00  0.00% httpd
> > >    297 root       1  31    0 1008K  392K sleep    0:00  0.00% efdaemon
> > >    278 root       1  32    0 1720K 1264K sleep    0:00  0.00% smcboot
> > >    361 root       1  35    0 5944K 2432K sleep    0:00  0.00% sshd
> > >    238 root       1  41    0 1096K  712K sleep    0:00  0.00% sf880drd
> > >    280 root       1  42    0 1720K  760K sleep    0:00  0.00% smcboot

> > > Note:  This is a pre-production server.  I don't have any code on the
> > > server yet.  Our primary development environment is php/postgres.

> > > Thanks for your help,
> > > Christine

> > > --
> > > Christine E. Miller
> > > Director of Information Technology
> > > Franklin College Dean's Office

> > > Office: 706-542-1546
> > > Fax: 706-542-3422
> > > http://www.franklin.uga.edu/

> --
> Christine E. Miller
> Director of Information Technology
> Franklin College Dean's Office

> Office: 706-542-1546
> Fax: 706-542-3422
> http://www.franklin.uga.edu/

 
 
 

1. setting up Apache 1.3.27 with the ssl on Freebsd 4.7(stable)

I am trying to setup Apache on FreeBSD 4.7(stable).  I installed the
apache+mod_ssl-1.3.27+2.8.11 package. I configured the httpd.conf
without trouble and it passed the syntax tests. I ran the command:

# apachectl configtest

and "Syntax OK" was returned. When i run

# apachectl start
or
# apachectl startssl

this was returned:

apachectl start: httpd could not be started
or
apachectl startssl: httpd could not be started
respectively.

I am very confused by this nebulous error. I don't know where to go
from here. I am not sure what i could test to determine the a
solution.

I have another question about how i could get it to start on boot up.
I did not see a way to start it in the rc.conf file. Is there another
way have it on startup.

Thank you for your help,
Robert Stickney

2. Acer CD-RW 8x4x32x vs. Linux Kenerl-2.4.0-test11

3. Apache 1.3.27 Installation (Start) with SSL

4. ftp not work under "bash" in solaris 2.8

5. Compiling Apache 1.3.27+SSL on Solaris 2.8

6. hp720c Driver

7. Httpd child processes run wild under heavy load (1.3.27)

8. java runnables on linuxPPS do not run

9. Apache 1.3.27 Binary files

10. using .htaccess files in apache 1.3.27 virtual dirs

11. apache 1.3.27 make errors

12. mod_dir to use hostname instead of ServerName (Apache 1.3.27)

13. Apache 1.3.27 + PHP + ISO-10646-UCS-4