Apache PHP/FI module on HPUX?

Apache PHP/FI module on HPUX?

Post by Aura » Thu, 17 Oct 1996 04:00:00



Hello,
        I have followed all the instructions for installing PHP as a
module of apache. Yet at  the final link stage of apache httpd, things are
blowing up because apache_php_module_main is not found.
nm of libphp.a shows that
apache_php_module_main|         0|extern|entry  |$CODE$

it indeed it extern.

So what did I do wrong. mod_php.c is defining this as extern and needs
it.
Platform: HP UX 10.10 gcc 2.7.2.1, apache 1.1.1 and php 2.0b7
Here is the error. Any help Appreciated.

        gcc   -o httpd alloc.o http_main.o http_core.o http_config.o
http_request.o  http_log.o http_protocol.o rfc1413.o util.o util_script.o
modules.o buff.o md5c.o util_md5.o explain.o http_bprintf.o mod_mime.o  
mod_access.o  mod_auth.o  mod_negotiation.o  mod_include.o  mod_dir.o  
mod_cgi.o  mod_userdir.o  mod_alias.o  mod_env.o  mod_log_common.o  
mod_asis.o  mod_imap.o  mod_actions.o  mod_log_agent.o  
mod_log_referer.o  mod_log_config.o  mod_status.o  mod_info.o  
mod_auth_anon.o  mod_php.o  mod_cookies.o
collect2: ld returned 1 exit status
/usr/bin/ld: Unsatisfied symbols:
   apache_php_module_main (code)
*** Error exit code 1

Thanks

 
 
 

Apache PHP/FI module on HPUX?

Post by Tobin Frick » Sun, 20 Oct 1996 04:00:00


Quote:> Hello,
>         I have followed all the instructions for installing PHP as a
> module of apache. Yet at  the final link stage of apache httpd, things
are
> blowing up because apache_php_module_main is not found.
> nm of libphp.a shows that
> apache_php_module_main|         0|extern|entry  |$CODE$
> it indeed it extern.

I had a very similar problem, but overcame it after tweaking a few lines in
the source code.  If you're still having this problem, I might be able to
figure out what I did to make it work, but it was a long time ago. Are you
using GCC or the cc compiler that comes with HP-UX?

Tobin Fricke

 
 
 

Apache PHP/FI module on HPUX?

Post by Brian Andrew » Wed, 23 Oct 1996 04:00:00




Quote:

> > Hello,
> >         I have followed all the instructions for installing PHP as a
> > module of apache. Yet at  the final link stage of apache httpd, things
> are
> > blowing up because apache_php_module_main is not found.
> > nm of libphp.a shows that
> > apache_php_module_main|         0|extern|entry  |$CODE$
> > it indeed it extern.

> I had a very similar problem, but overcame it after tweaking a few lines
in
> the source code.  If you're still having this problem, I might be able to
> figure out what I did to make it work, but it was a long time ago. Are
you
> using GCC or the cc compiler that comes with HP-UX?

> Tobin Fricke

I had this problem yesterday and all it was in my situation was that I
missed a period (.) off the EXTRA_LIBS line in the Apache Configuration
file!.  The line started with -L. -lphp etc...  

Worth a try,

brian

--

----------------------------------------------------------------------------
----
Brian Andrews
InforMate Technologies Limited
Technology Consultants for Information Automation
Auckland, New Zealand
Ph  (+64) 9-489-1001
Fax (+64) 9-489-1002
Mob (+64) 21-OFFICE (633-423)

http://informate.co.nz
----------------------------------------------------------------------------
----

 
 
 

1. Apache 1.2.4 config/run problem with PHP/FI module.

I have instal PHPFI module.
I have copy phpfi lib's in /etc/src/apache1_2_4/src
I have add in Configuration  "EXTRA_LIBS=-lmod_php-static"
and "Module php_module mod_php.o"
I have compiled httpd from "/etc/src/apache1_2_4/src"
after i have copy httpd in /httpd directory
I restart Apache, and receive message:
" httpd /httpd/httpd: can't load library 'libmod_php-static.so' "
That is wrong

Please help

thanks all
serghej

2. Connect Linux to Win NT Proxy Server

3. PHP/FI 2.0.1 as Apache 1.3.6 module

4. FL-Jobs for UNIX Syst Admin -TOP $$'s

5. php/fi as module in apache 1.2

6. at705 terminal screen codes required

7. Help: 'Malformed option' when trying to compile with PHP/FI as module.

8. How to accomplish centralized timebased data polling ?

9. Problems with GDBM, PHP/FI and Apache under FreeBSD

10. APACHE with PHP/FI

11. Apache+SSL+PHP/FI+frontpage

12. Apache + PHP/FI + mod_perl incompatibilities

13. Apache DBAuth / GDBM / PHP/FI