Apache's SSI doesn't work for virtural hosts' directories.

Apache's SSI doesn't work for virtural hosts' directories.

Post by Tony Ya » Tue, 19 Mar 1996 04:00:00



Hi there,

I am using Apache httpd server 1.0.3.  For the Server Side Include function, it
works fine if the .shtml doc was put in user's directory and requested using

http://www.my.domain/~someone/****.shtml

However when I moved the file to one of the virtural hosts' directory

/htdoc/VIRTURAL.COM/****.shtml

and accessed vie

http://www.virtural.com/****.shtml

Apache will get confuesd and dump the content of the file out as a plan text
file.

If anybody knows hot to solve this, please help!


 
 
 

1. ping -g 'gateway-IP' 'host-IP' DOESN'T work!

Hello guys,

I have a machine with two interfaces, each connected to
a gateway. This two gateways are then connected to a common
network and I want to ping another router in that network over
the two interfaces.

Looks like this:
                        Gateway 1
                           ----
               ------------|  |------------
              | Subnet A   ----            |
            ----
Machine    |  |                Subnet C   Router
            ----
              | Subnet B   ----            |
               ------------|  |------------
                           ----
                        Gateway 2

Now if I type following on my machine it doesn't work:

ping -g 'IP in Subnet A of Gateway 1' 'Router-IP-address'

But if I do a ping (Defaultgateway is 'IP in Subnet A of Gateway 1'
(without -g) it works fine:

ping 'Router-IP-address'

Can someone give me a hint? Thanks in advance!

Cheers, Walter

2. Please suggest a Linux compatible CPU+MB = $250

3. Apache - 'AllowOverride None' doesn't work!!!

4. RARP problem with 2.0.29

5. 'ppp-on' Works, 'ifup ppp0' Doesn't

6. Red Hat with Athlon???

7. Apache: SSI #include virtual doesn't work properly?

8. Linux Frequently Asked Questions with Answers (Part 3 of 6)

9. Re. bffcreate -X doesn't work Re: bffcreate -X Doesn't Work

10. Apache 1.2b7, ssi doesn't work in htdocs/

11. Apache 1.2.4: SSI doesn't work

12. SSI works and doesn't work

13. Problems running SSI system commands from 'user' directories