OS/390 APACHECTL START fails to setuid

OS/390 APACHECTL START fails to setuid

Post by Bob Van Di » Sun, 09 Jun 2002 05:22:07



I downloaded the binary file for APACHE 2.0.32 and have instaleld it
in USS. I followed the directions in the README and in the redbook
(open source software for z/OS) at startup i get the following in
/usr/local/apache2/logs/error_log

YFri Jun 07 16:07:12 2002 Ywarn pid file
/usr/local/apache2/logs/httpd.pid ove
YFri Jun 07 16:07:13 2002 Ynotice Apache/2.0.32 (Unix) configured --
resuming
YFri Jun 07 16:07:13 2002 Yalert (157)EDC5157I An internal error has
occurred.
: setuid: unable to change to uid: 2001
YFri Jun 07 16:07:13 2002 Yalert (157)EDC5157I An internal error has
occurred.
: setuid: unable to change to uid: 2001
YFri Jun 07 16:07:13 2002 Yalert (157)EDC5157I An internal error has
occurred.
: setuid: unable to change to uid: 2001
YFri Jun 07 16:07:14 2002 Yalert Child 174 returned a Fatal error...
Apache is exiting!
CEE5205S The signal SIGTERM was received.
YFri Jun 07 16:07:14 2002 Yalert (157)EDC5157I An internal error has
occurred.
: setuid: unable to change to uid: 2001
******************************** Bottom of Data
********************************
I defined the follwing to ACF2 as documented

BPX.DAEMON CLASS(FAC) ID(APACHE) ACCESS(READ)  

 I issued the APACHECTL START from a supoeruser id (UID=0)
I have the following in httpd.conf  

 User APTST                
 Group OEDFLTG            

They are valid userids/groups

Any idea why I HTTPD cannot do a setuid without getting EDC5157I  - I
looked up the error message and it just said EMVSERR - internal error
has occured - I find nothing in security system logs

 
 
 

1. Apachectl start fails

On a new install of RedHat 7.1, I've installed Apache, open-ssl from
source.  The install went without problem.

When I enter "apachectl start"  It responds "httpd started"

But it doesn't start

The error log reads [warn] pid file
/usr/local/ssl-apache/logs/httpd.pid overwritten --Unclean shutdown of
previous Apache run?

This is a clean install, both OS and Apache so there was no previous
apache run.

Any comments or suggestions will be greatly appreciated

2. Unusual mail problem - Help!

3. FTP from AIX to OS/390 question

4. file size > 2GB

5. Analog on OS/390

6. identd, cidentd on a RedHat 5.1 i386 sys

7. AIX SP2 Connection to MVS OS/390-Host

8. NFS automounting problem, RH5.2

9. bash on OS/390?

10. how to syncronize Aix time from OS/390 timed server?

11. Apache supported on OS/390 UNIX?

12. Time synchronization on AIX servers with an OS/390 mainframe

13. Wierd zip/unzip problem between Solaris and OS/390