Server Side Include setup

Server Side Include setup

Post by Joe Bednar » Sat, 08 Feb 1997 04:00:00



I've been pounding my head against the monitor for about the last hour
now because I've done everything I'm "supposed" to do to set up Server
Side Includes, but it still doesn't work.

I am currently using Apache 1.2beta6 on a Linux box.

If anyone could step me through the process, I would GREATLY appreciate
it.

Thanks ahead of time

joe

 
 
 

Server Side Include setup

Post by Kurt J. Lanz » Sat, 08 Feb 1997 04:00:00



> I've been pounding my head against the monitor for about the last hour
> now because I've done everything I'm "supposed" to do to set up Server
> Side Includes, but it still doesn't work.

Well, you probably missed something, but we don't know because you
don't give us a clue. Like, what error does the browser show?

Quote:

> I am currently using Apache 1.2beta6 on a Linux box.

> If anyone could step me through the process, I would GREATLY appreciate
> it.

It would also help if we knew something about the symptoms of
"not working". Would you go to a doctor and say "I don't feel good --
what's wrong?" and expect him to tell you? Would you call a mechaninc
and say, "My car doesn't start, what should I do?"
I could come up with more examples, but surlely you get the point?

Quote:

> Thanks ahead of time

> joe

--
Kurt J. Lanza


 
 
 

Server Side Include setup

Post by J.D. Baldw » Tue, 11 Feb 1997 04:00:00




>I've been pounding my head against the monitor for about the last hour
>now because I've done everything I'm "supposed" to do to set up Server
>Side Includes, but it still doesn't work.

Well, after wasting an hour, one would have thought you could spend
the extra three minutes it would have taken to *describe* your problem
in your post.  But as a recent victim of SSI, I'll take a guess that
perhaps you are doing the same thing I was:

    <!--#include virtual="/file_to_include.htm">

The missing close-comment operator "--" caused my parent .shtml file
to load the stuff before the #include, the #include-ed material itself,
and then to cold, failing to load anything below the #include.  This
drove me nuts for 45 minutes before I figured it out.  So watch your
syntax.
--
 From the catapult of J.D. Baldwin  |+| "If anyone disagrees with anything I

 _|70|___:::)=}-  for PGP public    |+| retract it, but also to deny under
 \      /         key information.  |+| oath that I ever said it." --T. Lehrer
***~~~~-----------------------------------------------------------------------