PHP/FI 2.0.1 as Apache 1.3.6 module

PHP/FI 2.0.1 as Apache 1.3.6 module

Post by Cedric Royakker » Mon, 07 Jun 1999 04:00:00



Hi

I've been trying very desperately to get PHP/FI 2.0.1 running as an apache
module under my Apache 1.3.6.  I got it working as a CGI, butI'd prefer a
module.

This is what I do:
untar php-2.0.1.tar.gz and apache-1.3.6.tar.gz and gd1.2.tar.gz
cd gd1.2
make
cp gdlib.a /usr/lib
cd apache_1.3.6
./configure --prefix=/usr/local/apache
cd ../php-2.0.1
./install
  No databases
  Acces logging, file upload support
  Build as apache module (apache > 1.1)
  Build as ELF shared library
  Apache include dur /usr/src/apache_1.3.6/src/include
  Additional dirs to search for .h files: /usr/src/gd1.2
  Not the bundled regex library
make

After a few seconds make stops.  It says the file ap_config_auto.h as found
in ap_config.h could not be found.

Someone can help me?

Cu
Cedric Royakkers

 
 
 

PHP/FI 2.0.1 as Apache 1.3.6 module

Post by David R. Newma » Mon, 07 Jun 1999 04:00:00



> I've been trying very desperately to get PHP/FI 2.0.1 running as an apache
> module under my Apache 1.3.6.  I got it working as a CGI, butI'd prefer a
> module.

Why have you been trying to get an old, out-of-date, version of PHP working
with the latest Apache, rather than using PHP3? PHP3 will work as a
dynamically loaded module.

 
 
 

PHP/FI 2.0.1 as Apache 1.3.6 module

Post by Umm » Tue, 15 Jun 1999 04:00:00


Quote:>Why have you been trying to get an old, out-of-date, version of PHP working
>with the latest Apache, rather than using PHP3? PHP3 will work as a
>dynamically loaded module.

Can it be "Compatibility"?

"Fear leads to Anger, Anger leads to Hate, Hate leads to Suffering"
--Yoda from Star Wars: Episode One
Remove "nospam" to E-Mail me.....

 
 
 

1. Apache PHP/FI module on HPUX?

Hello,
        I have followed all the instructions for installing PHP as a
module of apache. Yet at  the final link stage of apache httpd, things are
blowing up because apache_php_module_main is not found.
nm of libphp.a shows that
apache_php_module_main|         0|extern|entry  |$CODE$

it indeed it extern.

So what did I do wrong. mod_php.c is defining this as extern and needs
it.
Platform: HP UX 10.10 gcc 2.7.2.1, apache 1.1.1 and php 2.0b7
Here is the error. Any help Appreciated.

        gcc   -o httpd alloc.o http_main.o http_core.o http_config.o
http_request.o  http_log.o http_protocol.o rfc1413.o util.o util_script.o
modules.o buff.o md5c.o util_md5.o explain.o http_bprintf.o mod_mime.o  
mod_access.o  mod_auth.o  mod_negotiation.o  mod_include.o  mod_dir.o  
mod_cgi.o  mod_userdir.o  mod_alias.o  mod_env.o  mod_log_common.o  
mod_asis.o  mod_imap.o  mod_actions.o  mod_log_agent.o  
mod_log_referer.o  mod_log_config.o  mod_status.o  mod_info.o  
mod_auth_anon.o  mod_php.o  mod_cookies.o
collect2: ld returned 1 exit status
/usr/bin/ld: Unsatisfied symbols:
   apache_php_module_main (code)
*** Error exit code 1

Thanks

2. Help on install, please.

3. Apache 1.2.4 config/run problem with PHP/FI module.

4. TRIDENT 9440. Come on!!

5. php/fi as module in apache 1.2

6. solaris 8 install question

7. Help: 'Malformed option' when trying to compile with PHP/FI as module.

8. Fix strlen_user usage in module.c

9. Problems with GDBM, PHP/FI and Apache under FreeBSD

10. APACHE with PHP/FI

11. Apache+SSL+PHP/FI+frontpage

12. Apache + PHP/FI + mod_perl incompatibilities

13. Apache DBAuth / GDBM / PHP/FI