where is the libphp4.so?

where is the libphp4.so?

Post by tomm » Mon, 07 Jul 2003 19:24:32



I want to install a server using apache2, mysql and php4 in the linux 7.3.
And I have follow the documentation in the php.net
But in the latest step, I can not find the libphp4.so file in the modules file
http://www.php.net/manual/en/install.apache2.php
would sombody help me?
 
 
 

where is the libphp4.so?

Post by Andreas Paasc » Mon, 07 Jul 2003 21:39:29



> I want to install a server using apache2, mysql and php4 in the linux 7.3.
> And I have follow the documentation in the php.net
> But in the latest step, I can not find the libphp4.so file in the modules
> file http://www.php.net/manual/en/install.apache2.php
> would sombody help me?

www.rpmfind.net should help you finding that module.
But basically you should have it, so you need to find it on your system.
find or slocate to find it.

HTH,

/Andreas

--
Registeret Linux user #292411

 
 
 

where is the libphp4.so?

Post by tomm » Tue, 08 Jul 2003 12:13:55




> > I want to install a server using apache2, mysql and php4 in the linux 7.3.
> > And I have follow the documentation in the php.net
> > But in the latest step, I can not find the libphp4.so file in the modules
> > file http://www.php.net/manual/en/install.apache2.php
> > would sombody help me?

> www.rpmfind.net should help you finding that module.
> But basically you should have it, so you need to find it on your system.
> find or slocate to find it.

> HTH,

> /Andreas

Thank you for your help~^^
And i want to ask a question that after I have found that module
and add lines in the http-conf file to load the moudule.
When I type in  /usr/local/apache2/bin/apachectl start
The following error massage occurs:
Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server:
/usr/local/apache2/modules/libphp4.so:undefined symbol:
ap_block_alarms
what is this error?
 
 
 

1. Cannot load libphp4.so?

I'm stumped. I've just finished compiling and installing Apache with PHP
and MySQL. When I go to start Apache with apachectl, I get this error
below. I really have no idea what the problem is as libphp4.so is in the
libexec directory. What's undefined symbol: and uncompress mean?


Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress
./apachectl start: httpd could not be started

Could someone give me some insight as to what my problem may be? Line 205
of my conf file is as follows...

LoadModule php4_module        libexec/libphp4.so

TIA,
Scott

2. ATT: Pls help again: Problems

3. libphp4.so can not be loaded into Apache Server

4. SCSI errors, timeout

5. libphp4.so - Apache + PHP

6. NetBSD 1.5 floppy support for VAX?

7. php/mysql error: cannot load libphp4.so

8. Looking for ATI Xpert@work drivers

9. pb with libphp4.so

10. libphp4.so on IBM Apache 2.0.42

11. "libphp4.so is garbled" with Apache 1.3.12

12. This clone thing...am I stupid, or am I right?