sendmail config -- what am I doing wrong?

sendmail config -- what am I doing wrong?

Post by rob » Wed, 17 Mar 1999 04:00:00



I'm running a site on Apache on Linux (and I'm a real newbie with
Apache), and I'm trying to use a script that emails a user's comments to
me.  The script calls sendmail and passes a recipient parameter that

The script works.  But:

When I send mail this way, my root mailbox gets the message with the
following errors:

Returned mail: local configuration error

The following addresses had permanent fatal errors:

553 pop.mydomain.com config error: mail loops back to me (MX problem?)

--end of error msgs.

In /etc/aliases I added webmaster and made it an alias for root, but
that didn't fix it.  I know I'm missing something here (brain cells?)
but don't know what I need to do.  Everything else on the site works
fine, it's just this one little thing bugging me!

thanks,

Robert Boyd

-----------== Posted via Newsfeeds.Com, Uncensored Usenet News ==----------
 http://www.newsfeeds.com/       The Largest Usenet Servers in the World!
-----------== Over 66,000 Groups, Plus  a  Dedicated  Binaries Server ==----------

 
 
 

sendmail config -- what am I doing wrong?

Post by Joshua Sliv » Wed, 17 Mar 1999 04:00:00



> I'm running a site on Apache on Linux (and I'm a real newbie with
> Apache), and I'm trying to use a script that emails a user's comments to
> me.  The script calls sendmail and passes a recipient parameter that

> The script works.  But:
> When I send mail this way, my root mailbox gets the message with the
> following errors:
> Returned mail: local configuration error
> The following addresses had permanent fatal errors:

> 553 pop.mydomain.com config error: mail loops back to me (MX problem?)
> --end of error msgs.

My best guess:

Your smtp server (probably sendmail) is not configured to receive mail
for mydomain.com.  Try adding mydomain.com to the sendmail.cw file or
to class Cw in your sendmail.cf.

In addition, since this question really has nothing to do with www
servers, you should probably direct it to one of the comp.mail
newsgroups.

--
Joshua Slive

http://finance.commerce.ubc.ca/~slive/

 
 
 

sendmail config -- what am I doing wrong?

Post by SambaVWM » Fri, 26 Mar 1999 04:00:00


Just go install Qmail.  Its just so easy.
So easy to configure.
www.qmail.org

Brock Eastman

 
 
 

1. Dual Homed Linux - what am I doing wrong?

I have a RH 5.0 Linux PC setup with two Ethernet interfaces configured and
connected to two different LANs. Each LAN has a way out to the Internet, and
I've disabled IP forwarding on Linux to prevent the PC from routing between
the two LANs (which is my intention). The routing table entries for the first
LAN (eth0) simply has the usual loopback and LAN entries, and a default route
pointing to the gateway to the Internet. This works just fine.

On the eth1 interface, I have set up the Cisco router on the second LAN to use
RIP to broadcast routes on the second LAN. I then configure Linux to run
routed with -q (listen only) so that it can pick up the RIP routes and know to
use the second interface for routes to networks serviced by the Cisco. This
isn't working.

When I start routed -q, I end up with a route to the serial side of the Cisco
(that's good) and a second default route pointing to the Cisco on eth1 is
created (not good). With two default routes, Linux seems to pick the first
available default route when it doesn't know where to go - hence, all my
traffic continues out the eth0 interface when a better path is available on
eth1.

The route table never fills with routes known by the Cisco, so my question is
what am I doing wrong? Is this a known problem with Linux? Why is it creating
a second (and useless) default route instead of filling up with routes learned
via RIP?

Dan Peterka

2. Why does Sndconfig lock up on me?

3. Am I doing something wrong?? - (SAMBA)

4. tcsh multi-line, nested aliases

5. One more question - What am I doing wrong?

6. TTy setup Help

7. KNode (No Caching) - What am I doing no wrong

8. UDB system recommended?

9. gethostbyname misbehavior - what am i doing wrong.

10. What am I doing wrong?????

11. Ip-Masquerade and games over the net...what am I doing wrong????????

12. What I am doing wrong?

13. What am I doing wrong?