Help: 'Malformed option' when trying to compile with PHP/FI as module.

Help: 'Malformed option' when trying to compile with PHP/FI as module.

Post by Joachim Str?mbergso » Tue, 01 Apr 1997 04:00:00



Tja!

I'm trying to add PHP/FI version 2.0b10 as a module to Apache 1.2b7. I
add the -D\"PHP/FI-2.0b10\" to the EXTRA_CFLAGS row in the beginning of
the Configuration file. I then run 'Configure' successfully, but when
running 'make', it almost immeadetly aborts with:

alloc.c:0: malformed option '-D "PHP/FI-2.0b10"

Obviously something is wrong, I just can't find out what. Any help
extremely greatly appreciated.

--
Cheers!
Joachim - Alltid i harmonisk sv?ngning
--------------------------------------------------------
Joachim Str?mbergson  MSc Student, nice to CUTE animals.

977 54 Lule?       C64       phone: +46(0)920 - 22 16 42
Sweden         -FairLight-   alt:   +46(0)10 - 22 10 543
--------------------------------------------------------

 
 
 

Help: 'Malformed option' when trying to compile with PHP/FI as module.

Post by Toni van de Wie » Wed, 02 Apr 1997 04:00:00




Quote:> I'm trying to add PHP/FI version 2.0b10 as a module to Apache 1.2b7. I
> add the -D\"PHP/FI-2.0b10\" to the EXTRA_CFLAGS row in the beginning of

You don't need to do that.
Just add 'libphp.a -lm' to EXTRA_LIBS and mod_php.o to the MODULES.
Also make sure you link or copy mod_php.c and mod_php.h to the apache source
dir.

I also removed the -O2 compiler option as it was not supported by the Sun
C-compiler.

The problem that remains in my setup is that Apache won't run properly.
Sometimes a request from a browser just hangs. Browser stays busy, but the
server does not send data and a socket is kept open between one of the httpd
processes and the browser until you press the stop-control.
A similar problem is occuring in another network server that I wrote myself.
I suspect a Solaris networking bug, but I can't be sure.

Anyone compiled Apache on Solaris and running it _without_ problems?

++Toni;
--
Toni van de Wiel



 
 
 

1. PHP/FI - is it limited in scope/ability vs. 'other' cgi mthds?

Have heard little here about php/fi and apache, and am wondering if
commercial, full-scale applications (e.g. shopping cart systems,
full-blown classified ad systems) are feasible - or if it is necessary to
use Perl or another 'cgi' language/tool?

What are you using and why? Especially in conjunction with apache httpd.

Any shared experiences and insight would be appreciated.

Brett

2. Offline message reader for usenet newsgroups.

3. Q: Can not build PHP/FI with mSQL support - what's the problem ?

4. How to 100% flush lp's buffers? I've rm'd spool-files, lp stop, lp start

5. php won't parse: (I've tried the usual suspects)

6. SOL8 as DHCP

7. 'insmod' won't load newly compiled modules

8. cooling bits for the kn133

9. insmod: 'couldn't find the kernel version the module was compiled for'

10. Need help for 'ipfw' with 'fwd' option

11. '-i' option for 'cp' and 'mv'

12. Apache PHP/FI module on HPUX?

13. Apache 1.2.4 config/run problem with PHP/FI module.