Solais and .htaccess not working

Solais and .htaccess not working

Post by AIPro Webmaste » Tue, 13 Apr 1999 04:00:00



Hi -

I'm having a VERY hard time getting 1.3.6 on Solaris to "prompt" ANYONE.

I've got Apache working fine on Linux boxes, but using exact copies of
.htaccess
I can't  get Solaris to stop people from getting in.

I'm "out of ideas", and in need of help, sooo....

HELP!

Thanks

cg


 
 
 

Solais and .htaccess not working

Post by Joshua Sliv » Tue, 13 Apr 1999 04:00:00



> Hi -
> I'm having a VERY hard time getting 1.3.6 on Solaris to "prompt" ANYONE.
> I've got Apache working fine on Linux boxes, but using exact copies of
> .htaccess
> I can't  get Solaris to stop people from getting in.

Try this:
http://www.apache.org/docs/misc/FAQ.html#htaccess-work

And post again if this is not the problem.

--
Joshua Slive

http://finance.commerce.ubc.ca/~slive/

 
 
 

Solais and .htaccess not working

Post by AIPro Webmaste » Tue, 13 Apr 1999 04:00:00



> Hi -

> I'm having a VERY hard time getting 1.3.6 on Solaris to "prompt" ANYONE.

> I've got Apache working fine on Linux boxes, but using exact copies of
> .htaccess
> I can't  get Solaris to stop people from getting in.

> I'm "out of ideas", and in need of help, sooo....

> HELP!

> Thanks

> cg



Having now "vented" I see I didn't include very much use able info with my
previous post.

http.conf file
------------------
ServerType standalone
HostnameLookups off
User nobody
Group #60001
BrowserMatch Mozilla/2 nokeepalive

ServerRoot /usr/local/apache
ErrorLog logs/error_log
TransferLog logs/access_log
PidFile logs/httpd.pid
ScoreBoardFile logs/apache_status
ServerName sun.aipro.com
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MinSpareServers 20
MaxSpareServers 10
StartServers 20
MaxClients 60
MaxRequestsPerChild 100
Port 80
DocumentRoot /usr/local/apache/htdocs
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory "/usr/local/apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
NameVirtualHost 216.64.16.254:80
<VirtualHost 216.64.16.254>

    ServerName 216.64.16.254
    TransferLog logs/216.64.16.254-access
DocumentRoot /user/DefaultDomainMarkers/216.64.16.254
</VirtualHost>
<VirtualHost www.aipro.com>

    ServerName www.aipro.com
    TransferLog logs/www.aipro.com-access
    DocumentRoot /user/www.aipro.com/web
    AddHandler server-parsed html shtml
</VirtualHost>

.htaccess file
-----------------
deny from all
AuthType Basic
AuthUserFile /user/www.aipro.com/web/accounts.pwd
AuthName Restricted
require valid-user
satisfy any

So.... "What am I missing?"

 
 
 

Solais and .htaccess not working

Post by Kurt J. Lanz » Tue, 13 Apr 1999 04:00:00



> Hi -

> I'm having a VERY hard time getting 1.3.6 on Solaris to "prompt" ANYONE.

> I've got Apache working fine on Linux boxes, but using exact copies of
> .htaccess
> I can't  get Solaris to stop people from getting in.

> I'm "out of ideas", and in need of help, sooo....

How about some more information, Bunky? Like, is there any clue in the
access log? The error log? Have you double-checked your configuration?
Tried accessing the server with telnet and looking at the raw HTTP
response? How about the permissions on the relevant files?
 
 
 

Solais and .htaccess not working

Post by Ron Klatchk » Tue, 13 Apr 1999 04:00:00



> http.conf file
> ------------------
>     AllowOverride None

> So.... "What am I missing?"

Read up on the AllowOverride directive.

moo
----------------------------------------------------------------------
          Ron Klatchko - Manager, Advanced Technology Group          
           UCSF Library and Center for Knowledge Management          

 
 
 

1. Solais 9 does not start yp.yppasswdd for NIS+

I just upgraded from Solaris 8 to Solaris 9. The system does not allow
to change passwords.

The system has NIS+ running. At the passwd prompt, it asks for the
passwd and then gives the message:
Permission Denied.

I found out that the system was not starting rpc.yppasswdd and that if
the master's hostname is fully qualified, then ypstart as distributed,
won't start ypserv, ypxfrd and yp.passwdd. How do I set up my system to
make ypstart start this?

Please HELP!

--
Posted via http://dbforums.com

2. ULtra 30 with 72gb disks?

3. Apache: .htaccess does not work

4. Asus P5A and AMD K-2

5. NCSA .htaccess resolving of AuthName not working

6. how to rm somthing strange?

7. .htaccess problem: numerical ips work, names do not

8. C from SunOS -> Linux

9. .htaccess Apache Virtual Host not working

10. .htaccess not working

11. .htaccess does not work !

12. Why does redirect in .htaccess not work?

13. Apache .htaccess problem (dbmmanage not working)