Please help with HTML::Mason installation

Please help with HTML::Mason installation

Post by Boris Pela » Mon, 21 Apr 2003 13:30:55



I am trying to re-install a complete site on a new server. The site was
written using HTML::Mason by a third party, which is no longer reachable.
The server is running RedHat 8/Apache 2.0.40 with mod_perl support.
After installing most of the module requested by the Makefile.PL from
the Mason bundle, I still get 'need Apache::Request'. That is part of
libapreq, which requires some parts from mod_perl (Apache/src.pm, etc).
And that requires the Apache source. Now, I pulled and built the source
for 2.0.45 (most recent release), but I am very confused as to what my
next steps should be.

Somehow, I should be able to build mod_perl, pointing it to my new 2.0.45
Apache sources, then build libapreq, and then complete Mason. However,
the mod_perl install only wants Apache 1.x.

Please help, for I am lost - this is my first major Linux configuration
project, having always hosted on 3rd party systems before.

-- Boris

 
 
 

Please help with HTML::Mason installation

Post by Andre Dal » Tue, 22 Apr 2003 11:43:30


There is a mod_perl for Apache2.  It is still under development though,
and I don't know anyone using mod_perl with Apache2 in production.

Goto http://perl.apache.org/ and download the mod_perl 2.0 beta: v1.99_08.

Mod_perl 1.0 (1.27 currently) is for Apache 1.3.

If you can't get it to go though, you may have to run an Apache 1.3 server
until you can migrate away from mod_perl, or until mod_perl2 is stable.


> I am trying to re-install a complete site on a new server. The site was
> written using HTML::Mason by a third party, which is no longer reachable.
> The server is running RedHat 8/Apache 2.0.40 with mod_perl support.
> After installing most of the module requested by the Makefile.PL from
> the Mason bundle, I still get 'need Apache::Request'. That is part of
> libapreq, which requires some parts from mod_perl (Apache/src.pm, etc).
> And that requires the Apache source. Now, I pulled and built the source
> for 2.0.45 (most recent release), but I am very confused as to what my
> next steps should be.

> Somehow, I should be able to build mod_perl, pointing it to my new 2.0.45
> Apache sources, then build libapreq, and then complete Mason. However,
> the mod_perl install only wants Apache 1.x.

> Please help, for I am lost - this is my first major Linux configuration
> project, having always hosted on 3rd party systems before.

> -- Boris

--

Systems Administrator,
National Capital Freenet        [http://www.ncf.ca]