KeepAlive in Apache 1.3.19 Proxy

KeepAlive in Apache 1.3.19 Proxy

Post by Atu » Fri, 31 Aug 2001 23:07:15



I am trying to have persistent connection in Apache PROXY 1.3.19 but I
am unable to get it so far.
I applied the latest patch available on apache's site
(http://dev.apache.org/dist/patches/apply_to_1.3-current/). Still the
connection doesn't remain persistent.

Has anyone tried to have persistent connection in Apache PROXY 1.3.19?
If so, did you get it or not? Do you have the same problem?. My
browser is making the request with HTTP/1.1 and Connection: KeepAlive
but after the request passes the proxy, it becomes HTTP/1.0 and
Connection: parameter is missing. Without the proxy, I do get
persistent connection.

Even after applying the patch, I still see in proxy_http.c file that
the code for keepalive is not there (line # 351).

If you have any useful links for the files or documentation for
persistent connection in Proxy, please send me.

Also, when Apache 2.0.16 is going to be available in production
version? It is available in beta version right now.

Thanks a lot!!!!
Atul

 
 
 

1. is keepalive buggy ? apache 1.3.19/linux

Hello,

I have a linux server, and even if I reduce the KeepAlive Timeout
to 10 seconds or below, the processes stays in the "K" status,
for 15000 seconds sometimes (SS-field).

Server Version: Apache/1.3.19 (Unix) PHP/4.0.5 mod_ssl/2.8.2 OpenSSL/0.9.6
Server Built: May 1 2001 08:25:03

Current Time: Tuesday, 01-May-2001 19:21:54 CEST
Restart Time: Tuesday, 01-May-2001 11:34:41 CEST
Parent Server Generation: 0
Server uptime: 7 hours 47 minutes 13 seconds
Total accesses: 37260 - Total Traffic: 187.7 MB
CPU Usage: u123.78 s21.93 cu113.28 cs10.1 - .96% CPU load
1.33 requests/sec - 6.9 kB/second - 5.2 kB/request
115 requests currently being processed, 14 idle servers

KKKKKKKKKKKRKKKK__WKK_KKKKKKKKKKK_KKKK_KKKK_KKKKKKKKKKKKKKKKKK_K
KKKKKKKK_KKKKKKKKKKKK_K_KKKKKKKKKKKKWKKKKKKKKKKKK__KKKKKKKKK__K.
............K.....K.............................................
................................................................

Is that normal, and am I the only one ? :)  Alle these processes
h?nging takes lots of RAM...

If I turn KeepAlive off, it works better, but then the acces
to pages with many graphics is much slower, so I guess it's better
to leave it on.

Thanks for any hint!

Regards,
Olivier
--
_________________________________________________________________

qmail projects: http://omail.omnis.ch  -  http://webmail.omnis.ch

2. CDWRITE: trouble w/ Yamaha CDR400t

3. Does apache 1.3.19 support HTTP/1.1 if configured as reverse proxy

4. Linking problem with 1.2.13-help!

5. apache 1.3.19 on linux 7 startup error

6. Problems with object files

7. Apache 1.3.19 return 403 Forbidden on PDF file

8. Apache filename resolution problem

9. Apache 1.3.19 crashing?

10. apache 1.3.19, mod_ssl, Authentification

11. Apache 1.3.19

12. Tomcat 3.2.1 + apache 1.3.19 + solaris 2.7(sparc) = impossible?

13. Apache 1.3.19 ans Solaris8 errors