Apache 2.0.39

Apache 2.0.39

Post by Reginald McAllist » Thu, 10 Jul 2003 01:15:16



Here is what I did.
(1)
/usr/local/apache2/bin>./httpd -l
Compiled in modules:
  core.c
  mod_access.c
  mod_auth.c
  mod_auth_dbm.c
  mod_auth_digest.c
  mod_example.c
(2)
/usr/local/apache2/bin>./httpd -V
Server version: Apache/2.0.39
Server built:   Jul  2 2003 08:34:47
Server's Module Magic Number: 20020612:1
Architecture:   32-bit

I added the lines below to my httpd.conf file
(3)
# LoadModule foo_module libexec/mod_foo.so
LoadModule dbm_auth_module  modules/mod_auth_dbm.so
(3a)
<Directory "/webfs/prod/reports/CLW/sun">
IndexOptions FancyIndexing
require group admin1
AuthName "CLW Tech Support Unix"
AuthType Basic
AuthDBUserFile /disk6/SEC/access_users
</Directory>

(4) I tested the configuration and this is what I get. I even copy all
the *.so files into the directory modules, I thought it would help.

/usr/local/apache2/bin>./apachectl -t
Syntax error on line 205 of /usr/local/apache2/conf/httpd.conf:
Can't locate API module structure `dbm_auth_module' in file
/usr/local/apache2/modules/mod_auth_dbm.so: ld.so.1:
/usr/local/apache2/bin/httpd: fatal: dbm_auth_module: can't find
symbol

I am just trying to use the data base mode to make the web more
secure.
Can anyone point me in the right direction?
Or show me what I am doing so wrong.

Thanks for any help
Reginald McAllister System Eng

 
 
 

Apache 2.0.39

Post by Ray Pearc » Thu, 10 Jul 2003 01:32:53



> I added the lines below to my httpd.conf file
> (3)
> # LoadModule foo_module libexec/mod_foo.so
> LoadModule dbm_auth_module  modules/mod_auth_dbm.so
> (4) I tested the configuration and this is what I get. I even copy all
> the *.so files into the directory modules, I thought it would help.

> /usr/local/apache2/bin>./apachectl -t
> Syntax error on line 205 of /usr/local/apache2/conf/httpd.conf:
> Can't locate API module structure `dbm_auth_module' in file
> /usr/local/apache2/modules/mod_auth_dbm.so: ld.so.1:
> /usr/local/apache2/bin/httpd: fatal: dbm_auth_module: can't find
> symbol

As the message says - it can't find module dbm_auth_module in
mod_auth_dbm.so

A quick check of the module documentation shows the module name to be
auth_dbm_module. So try:

LoadModule auth_dbm_module modules/mod_auth_dbm.so

Ray

 
 
 

Apache 2.0.39

Post by Reginald McAllist » Fri, 11 Jul 2003 01:04:55


Thanks Ray,

I did modify the httpd.conf and made the change, what I get now is different.
(4)
/usr/local/apache2/bin>./apachectl start
Syntax error on line 205 of /usr/local/apache2/conf/httpd.conf:
module auth_dbm_module is built-in and can't be loaded

I am trying to get the step below.
(5)
<Directory "/webfs/prod/reports/CLW/sun">
IndexOptions FancyIndexing
require group admin1
AuthName "CLW Tech Support Unix"
AuthType Basic
AuthDBUserFile /disk6/SEC/access_users
</Directory>

Thanks for the help....

------------------------------------



> > I added the lines below to my httpd.conf file
> > (3)
> > # LoadModule foo_module libexec/mod_foo.so
> > LoadModule dbm_auth_module  modules/mod_auth_dbm.so
> > (4) I tested the configuration and this is what I get. I even copy all
> > the *.so files into the directory modules, I thought it would help.

> > /usr/local/apache2/bin>./apachectl -t
> > Syntax error on line 205 of /usr/local/apache2/conf/httpd.conf:
> > Can't locate API module structure `dbm_auth_module' in file
> > /usr/local/apache2/modules/mod_auth_dbm.so: ld.so.1:
> > /usr/local/apache2/bin/httpd: fatal: dbm_auth_module: can't find
> > symbol

> As the message says - it can't find module dbm_auth_module in
> mod_auth_dbm.so

> A quick check of the module documentation shows the module name to be
> auth_dbm_module. So try:

> LoadModule auth_dbm_module modules/mod_auth_dbm.so

> Ray

 
 
 

1. Apache 2.0.18a - 'Make' error re 'apr' - *.lo missing?

Apache friends:

Am attempting an install of v2.0.18-alpha on SuSE 7.1 SPARC.

All works well through configure and build process...

At 'make install', I get a 'no such file or directory' error on
make[2]: Entering directory '.../httpd-2_0_18/srclib/apr'
'ar: lib/*.o: No such file or directory'

However, the file '*.o' does exist in this directory.  It is a link file,
pointing to *.lo, and properties report it as an Object Code file.

Please note: no file named '*.lo' exists anywhere in the apache src tree...
Does anyone know how I can fix this?

Many TIA,  Lou

2. Multimedia Software

3. Apache mod_auth_dbm err:'can't open dbm file'

4. WGET multiple URLs -> single file

5. Apache + apache-ssl won't start

6. uugetty blocks /dev/cua1

7. Stronghold, Apache mod_ssl, Apache-SSL - what's the difference?

8. Apache 2.0.35 | server-status prob

9. Apache and netstat 'CLOSE' hangs

10. apache: form based 'basic' authentication ?

11. Apache 'make' dies

12. Apache/CGI: $ENV{'REMOTE_USER'} and POST

13. Apache-SSL won't compile: Can't find ssl.h!