mod_ssl for 1.3.19 prob

mod_ssl for 1.3.19 prob

Post by Phil Alle » Fri, 20 Apr 2001 12:18:32



Anyone seen anything like this?

httpd.conf - line 206:

LoadModule ssl_module libexec/libssl.so

getting systax error:

"Syntax error on line 206 of /usr/local/conf/httpd.conf:
Cannot load libssl.so into server: ld.so.1: /usr/local/apache/bin/httpd:
fatal: /usr/local/apache/libexec/libssl.so: open failed: No such file or
directory"

I have all the neccesary lib paths in LD_LIBRARY_PATH.

I don't know what it is looking for to open.  ServerRoot is right and
LoadModule is right.

Using Sol 7 on an Ultra2 and built everthing using openssl with shared libs.

Baffled!

Thanks
Phil Allen

--

 
 
 

mod_ssl for 1.3.19 prob

Post by Paul Rubi » Fri, 20 Apr 2001 12:47:07


Make sure the permissions are set properly on libssl.so so the server
can read them.  

 
 
 

mod_ssl for 1.3.19 prob

Post by Phil Alle » Sat, 21 Apr 2001 08:10:12


Got it going.  Apache no like 64bit libs!!

Beware of building 64bit libs when doing configure with openssl.

God I feel like a fool!

Phil Allen

--


Quote:> Anyone seen anything like this?

> httpd.conf - line 206:

> LoadModule ssl_module libexec/libssl.so

> getting systax error:

> "Syntax error on line 206 of /usr/local/conf/httpd.conf:
> Cannot load libssl.so into server: ld.so.1: /usr/local/apache/bin/httpd:
> fatal: /usr/local/apache/libexec/libssl.so: open failed: No such file or
> directory"

> I have all the neccesary lib paths in LD_LIBRARY_PATH.

> I don't know what it is looking for to open.  ServerRoot is right and
> LoadModule is right.

> Using Sol 7 on an Ultra2 and built everthing using openssl with shared
libs.

> Baffled!

> Thanks
> Phil Allen

> --

 
 
 

1. apache 1.3.19, mod_ssl, Authentification

Hello ng,
how can I force an authentification-window in a VirtualHost context with SSLEngine on ?
I don't want to use Fake basic_auth, I want to choose login/pass by myself. Does anybody
know? Thanks.

Until now we have the following 'Solution':

8< -------------------------------
<Directory "/www/wwwroot/auth">
Options -Indexes FollowSymLinks MultiViews
# has to be through https
    RewriteEngine        on
    RewriteCond          %{HTTPS} !=on
    RewriteRule          (.*)$ https://%{SERVER_NAME}/$1 [R]
# has to be from local subnet
    Order deny,allow
    Deny from all
    Allow from 192.168.134.151/16
#
  Satisfy all
</Directory>
---------------------------- >8

if you want to access it via http, basic_auth appears and after successful login a rewrite
to https follows, but if you want to access a file via https, you don't need a login/pass.
But https must force a login, too.

--
Norman Wehrle

2. TEQL setup get - RTNETLINK invalid argument

3. mod_ssl and Apache 1.3.19

4. (FTP install) Booting off a USB floppy drive ?

5. Apache 1.3.19+mod_ssl Installation troubles

6. scroll mouse

7. apache 1.3.19 on linux 7 startup error

8. mounting floppy

9. Apache 1.3.19 return 403 Forbidden on PDF file

10. Apache 1.3.19 crashing?

11. KeepAlive in Apache 1.3.19 Proxy

12. Apache 1.3.19

13. Tomcat 3.2.1 + apache 1.3.19 + solaris 2.7(sparc) = impossible?