Installed PHP3 and PHP4, but can't restart httpd

Installed PHP3 and PHP4, but can't restart httpd

Post by Tom Cruickshan » Fri, 09 Feb 2001 03:20:46



Hello,
    I configured and compiled apache with this configuration line...

./configure --prefix=/usr/local/apache/ --enable-shared=max

   I then compiled PHP3 and PHP4 with this configure line without any
problems...

./configure --with-mysql=../mysql --with-imap=../imap-4.7
--with-ldap=/usr/local --with-apxs=/usr/local/apache/bin/apxs
--enable-versioning --enable-track-vars                              

After getting both PHP3 and PHP4 compiled I didn't reconfigure apache
since I read during
the installation of PHP3 and PHP4 that both modules were being
activated.

But when I tried restarting the httpd daemon, I got this error...


Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp3.so into server:
/usr/local/apache/libexec/libphp3.so: undefined
symbol: uncompress
./apachectl start: httpd could not be started

Would anybody know how to fix this? Thanks for any help!

Sincerely,

Tom Cruickshank

 
 
 

Installed PHP3 and PHP4, but can't restart httpd

Post by Todd Osborn » Fri, 09 Feb 2001 14:02:41


Maybe a stupid answer, but...

Did you look in /usr/local/apache/libexec to see if libphp3.so is there?
Maybe PHP got the install directory wrong, maybe the LoadModule line in
httpd.conf is using relative or sym-linked paths. At any rate, that is where
Apache is expecting to find the file(s). If they are not there, move them
there, or fix the LoadModule lines in httpd.conf to point to them.

Todd


> Hello,
>     I configured and compiled apache with this configuration line...

> ./configure --prefix=/usr/local/apache/ --enable-shared=max

>    I then compiled PHP3 and PHP4 with this configure line without any
> problems...

> ./configure --with-mysql=../mysql --with-imap=../imap-4.7
> --with-ldap=/usr/local --with-apxs=/usr/local/apache/bin/apxs
> --enable-versioning --enable-track-vars

> After getting both PHP3 and PHP4 compiled I didn't reconfigure apache
> since I read during
> the installation of PHP3 and PHP4 that both modules were being
> activated.

> But when I tried restarting the httpd daemon, I got this error...


> Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp3.so into server:
> /usr/local/apache/libexec/libphp3.so: undefined
> symbol: uncompress
> ./apachectl start: httpd could not be started

> Would anybody know how to fix this? Thanks for any help!

> Sincerely,

> Tom Cruickshank


 
 
 

Installed PHP3 and PHP4, but can't restart httpd

Post by Raghuram » Fri, 09 Feb 2001 17:39:38


Hi!


> But when I tried restarting the httpd daemon, I got this error...


> Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp3.so into server:
> /usr/local/apache/libexec/libphp3.so: undefined
> symbol: uncompress

Looks like the code/executable for "uncompress" is not available on or
not in the search path of your system.

Hope this helps.

Cheers,
Raghuram

Disclaimer: My opinions are my own

 
 
 

1. PHP4 doesn't like PHP3 ?????

Hi !

Sorry, me again. But this time I will hold it short:

I'm running Apache with PHP4 module on a Suse Linux (7.0).
Everything works fine if I work with .php files, but
I can't open .php3 files.

Well, this doesn't surprise me this much because I only
have PHP4 installed, but hey, it can't be that I have to
rename (and much worse: change the content in every link
in every file) from php3 to php ?????
[take phpmyadmin for example; every sole file has the
extension .php3!!!!!!]

So: Can anyone tell me where I can change the setting,
so that php3 is automatically seen as .php ?

Thanks, and enjoy your weekend.

George

Sent via Deja.com
http://www.deja.com/

2. syslog.conf with strange entries?

3. Can't install PHP4 by DSO

4. sun4m per-processor timer driver.

5. Apache, DSO, PHP4, httpd.conf

6. Ethernet Driver goes goofy.

7. Add PHP4 support for existing HTTPD without breaking other mods

8. support for phone line networks?

9. PHP4 not working on new RedHat 7.2 install

10. Pls Help Newbie - PHP4/glibc2.2 rpm install woes

11. PHP4 as CGI: Pages don't view properly

12. easy to install PHP4 & Ghostscript binaries for OSR5.0.x ??

13. PHP4 on Debian woody (won't run) (newbie)