Newbie APACHE question

Newbie APACHE question

Post by Disembowl » Fri, 16 Nov 2001 04:40:50



Hi,

I just installed Apache (latest version) on my Linux (Mandrake)
machine and now I can't connect to it from remote pc's. I can connect
and see my homepage from another pc in my house (on the same ISP but
with a different IP) but I can't connect from anywhere else.

I have no firewall and the machine is connected to a cablemodem via a
hub shared with two other pc's (I pay my ISP for 3 IP addresses). So
far I've made no changes to my httpd.conf and I installed from a
binary.

The machine also runs FTP and TELNET servers and these both work just
fine from anywhere.

So what could my problem be? Should Apache work using the default
httpd.conf or is there something I need to enable?

Thanks for any help,

Jon C

 
 
 

Newbie APACHE question

Post by David Efflan » Fri, 16 Nov 2001 09:41:03



Quote:

> I just installed Apache (latest version) on my Linux (Mandrake)
> machine and now I can't connect to it from remote pc's. I can connect
> and see my homepage from another pc in my house (on the same ISP but
> with a different IP) but I can't connect from anywhere else.

> I have no firewall and the machine is connected to a cablemodem via a
> hub shared with two other pc's (I pay my ISP for 3 IP addresses). So
> far I've made no changes to my httpd.conf and I installed from a
> binary.

> The machine also runs FTP and TELNET servers and these both work just
> fine from anywhere.

> So what could my problem be? Should Apache work using the default
> httpd.conf or is there something I need to enable?

Do you bind apache to an specific IP(s)?  If not, it should work on any
interface.  Does your hostname resolve on the internet?  Did you read the
docs for ServerName and UseCanonicalName?

From somewhere on the internet try:

telnet yourhostname 80
HEAD / HTTP/1.0
(hit Enter again for blank line)

Do you get a response or any errors?

--
David Efflandt - All spam is ignored - http://www.de-srv.com/
http://www.autox.chicago.il.us/  http://www.berniesfloral.net/
http://cgi-help.virtualave.net/  http://hammer.prohosting.com/~cgi-wiz/

 
 
 

1. newbie apache-question

hi all,
i hope i'm in the right forum for my question - i'm a solaris newbie
(2.6) and i have the following problem: when i install apache 1.3.12
everthing works fine - ./install,make, make install passes without
errors - but when i try to launch 'apachectl start' i get the following
error-message:

so, does anybody know why  ???

thx a lot

sven

2. Problems installing majordomo...

3. Total Newbie Apache Question

4. pipe buffer size

5. Newbie Apache question

6. kpppd dialing problem

7. Another newbie Apache question

8. setsid on 4.3+BSD

9. Silly Newbie Apache Question

10. Newbie Apache Question

11. newbie Apache question: How do I allow CGI execution in any directory?

12. Newbie Apache question

13. Newbie Apache question: redirect amd 3rd level domains