Apache 1.3.12 and Tomcat 4.0

Apache 1.3.12 and Tomcat 4.0

Post by John Englis » Fri, 30 Nov 2001 23:11:08



Can anyone tell me how I integrate Tomcat 4 into Apache? I have
Apache running on ports 80 and 8080, I have Tomcat running on port
2000, but I'd like my standard Apache ports to be able to handle
servlet requests.

In previous versions of Tomcat there was a tomcat-apache.conf file
that you included in the main httpd.conf, but that doesn't seem to
exist in Tomcat 4. I'm currently trying this out with Windows 2000,
but I'll also need to get it working for Linux later.

Anyone know how to do this?

TIA,

-----------------------------------------------------------------

 Senior Lecturer           | http://www.comp.it.bton.ac.uk/je
 Dept. of Computing        | ** NON-PROFIT CD FOR CS STUDENTS **
 University of Brighton    |    -- see http://burks.bton.ac.uk
-----------------------------------------------------------------

 
 
 

Apache 1.3.12 and Tomcat 4.0

Post by Dr Hackenbus » Sun, 02 Dec 2001 05:06:48



Quote:> Can anyone tell me how I integrate Tomcat 4 into Apache? I have
> Apache running on ports 80 and 8080, I have Tomcat running on port
> 2000, but I'd like my standard Apache ports to be able to handle
> servlet requests.

> In previous versions of Tomcat there was a tomcat-apache.conf file
> that you included in the main httpd.conf, but that doesn't seem to
> exist in Tomcat 4. I'm currently trying this out with Windows 2000,
> but I'll also need to get it working for Linux later.

Apache 2.0 will support something called mod_webapp. I tried to use
this a few nights ago and had no luck. Whether I downloaded the
binary version, or built it from scratch, I had problems.

At this time, I have settled on Apache 1.3.22, Tomcat 3.2.3 and
JBoss 2.4.4 which should all work together. I had a ot of
problems getting JBoss to work with Tomcat. These were
all resolved by an obscure Unix problem allegedly documented by
Sun as a bug in Java 1.3.1. Use 'ulimit -s 2048' of your app server
written in Java crashes.

 
 
 

Apache 1.3.12 and Tomcat 4.0

Post by Alberto Adrián Schian » Sun, 02 Dec 2001 10:57:37


Dr Hackenbush dijo:

Quote:> Apache 2.0 will support something called mod_webapp. I tried to use
> this a few nights ago and had no luck. Whether I downloaded the
> binary version, or built it from scratch, I had problems.

> At this time, I have settled on Apache 1.3.22, Tomcat 3.2.3 and
> JBoss 2.4.4 which should all work together. I had a ot of
> problems getting JBoss to work with Tomcat. These were
> all resolved by an obscure Unix problem allegedly documented by
> Sun as a bug in Java 1.3.1. Use 'ulimit -s 2048' of your app server
> written in Java crashes.

Hi,
I tryied the Windows version all compiled for autoinstalling with .msi and
works fine. But it is hard to download. And also hard for me to append
other utilities such as PHP and MySQL, since I am still starting.
I think the windows version is easier that the Linux one.

/--------------------/-----------\----------------------------\
| Linux Mandrake 8.1 | KDE 2.2.1 | Pentium III - 256Mb - 10Gb |
\--------------------\-----------/----------------------------/
        -Alberto Adrin Schiano -

        -LINUX  Counter # 240133-
        -= Gallactic  Firewall =-