apache listening on udp ports?

apache listening on udp ports?

Post by scott thomas » Fri, 06 Jul 2001 04:19:57



Hi. I just installed Apache 1.3.20 on AIX 4.3.3, and when I did an
"lsof -i" to confirm ports, I noticed that each httpd process has a
UDP connection. The ports were from about 600 thru 1023. My configure
was this:

  ./configure \
    --verbose \
    --prefix=/apache \
    --with-layout=mine \
    --server-uid=500 \
    --server-gid=100 \
    --enable-module=all \
    --enable-shared=max \
    --activate-module=src/modules/fastcgi/libfastcgi.a \
    --disable-shared=fastcgi \
    --enable-rule=EXPAT \
    --enable-rule=PARANOID \
    --disable-module=auth_dbm \
    --disable-module=auth_db \
    --disable-rule=WANTHSREGEX \
    --disable-rule=IRIXN32

Any ideas what might be on these UDP connections?
---scott

 
 
 

apache listening on udp ports?

Post by adam » Fri, 06 Jul 2001 22:05:11



> Hi. I just installed Apache 1.3.20 on AIX 4.3.3, and when I did an
> "lsof -i" to confirm ports, I noticed that each httpd process has a
> UDP connection. The ports were from about 600 thru 1023. My configure
> was this:

>   ./configure \
>     --verbose \
>     --prefix=/apache \
>     --with-layout=mine \
>     --server-uid=500 \
>     --server-gid=100 \
>     --enable-module=all \
>     --enable-shared=max \
>     --activate-module=src/modules/fastcgi/libfastcgi.a \
>     --disable-shared=fastcgi \
>     --enable-rule=EXPAT \
>     --enable-rule=PARANOID \
>     --disable-module=auth_dbm \
>     --disable-module=auth_db \
>     --disable-rule=WANTHSREGEX \
>     --disable-rule=IRIXN32

> Any ideas what might be on these UDP connections?

I'm running AIX 4.3.3 and don't see that.  Might be the fastcgi module?
I haven't used fastcgi before, so you might check how httpd child
processes communicate w/ it.

--
-adam                 | "Be liberal in what you accept, and
Systems Administrator |  conservative in what you send"
Indiana University    |      -Jon Postel
Bloomington, Indiana  |