PROBLEM: apache 1.2.6 with SSLeay

PROBLEM: apache 1.2.6 with SSLeay

Post by Oliver Hause » Fri, 24 Apr 1998 04:00:00



i have installed apache 1.2.6 with SSLeay 0.8.1 which work
great.
But serveral hundrets hits after restarting the server,
i get the following error message:

connect: Connection refused
httpd: gcacheclient.c:37: OpenServer: Assertion `0' failed.

now, i am not able to connect to my SSL virtual server,
but my unencrypted virtual server works great.

anyone has an idea?

hausi

 
 
 

1. Compilation Problem w/ Apache+SSLeay

Hi folks,

When I compile Apache, everything goes smoothly up to the file daemon
compilation, when I get the following  linkage error:

cc    -o httpsd alloc.o http_main.o http_core.o http_config.o http_request.o
http_log.o http_protocol.o rfc1413.o util.o util_script.o modules.o buff.o
util_snprintf.o md5c.o util_md5.o explain.o http_bprintf.o util_date.o
mod_mime.o  mod_access.o  mod_auth.o  mod_negotiation.o  mod_include.o
mod_dir.o  mod_cgi.o  mod_userdir.o  mod_alias.o  mod_env.o
mod_log_config.o  mod_asis.o  mod_imap.o  mod_actions.o  mod_browser.o
mod_log_agent.o  mod_log_referer.o  mod_rewrite.o  mod_cern_meta.o
mod_status.o  mod_info.o  mod_auth_anon.o  mod_digest.o  mod_expires.o
mod_headers.o  mod_usertrack.o  mod_auth_external.o  libmodssl.a  -L. -lphp
-lm -lmodssl -lkrb5 -lcom_err -lm -ldbm -L/usr/local/ssl/lib -lssl -lcrypto
-L. -lmodssl
ld:
Unresolved:
X509_verify_cert_error_string
des_set_key
des_ecb3_encrypt
DH_new
BN_bin2bn

// about fifty lines removed

What am I missing here?

TIA,
Adam

2. gdk_gc_set_background use in gtk theme engine notif

3. Problems building Apache with SSLeay+RSAref

4. usleep() is unreliable when sleeping for less then 10000 micro

5. Problems with Apache/SSL/ssleay on redhat 5.2

6. search example of a Webbased Email with sourcecode

7. Apache 1.1.1 SSLeay-0.6.1 Digital UNIX V3.2C compile problem

8. Telnet problem.

9. SSLeay and apache problem?

10. SSLeay, Apache-SSL, Netscape

11. SSLeay & Apache on Linux

12. Apache/SSLeay CAs?

13. Apache 1.3.3 and ssleay 0.9