apachectl start: httpd could not be started on AIX 4.3.2

apachectl start: httpd could not be started on AIX 4.3.2

Post by Brya » Fri, 05 Jan 2001 01:41:09



system:
IBM RS/6000 H70, 2gig Ram with SSA drives
AIX ver 4.3.2

Apache ver 1.3.14

After running the install-bindist.sh with no errors. I receveive the
follow error when I attempt to
start the Apache server (/usr/local/apache/bin/apachectl start  ):
**************************START ERROR MSG*********************
exec(): 0509-036 Cannot load program /usr/local/apache/bin/httpd
because of the following errors:

           0509-023 Symbol dlsym in httpd is not defined.

           0509-023 Symbol dlerror in httpd is not defined.

           0509-023 Symbol dlopen in httpd is not defined.

           0509-023 Symbol dlclose in httpd is not defined.

           0509-026 System error: Cannot run a file that does not have
a valid format
/usr/local/apache/bin/apachectl start: httpd could not be started
***************************END ERROR MSG*************************
Could you please tell me how to correct this error or where to start
looking to help correct this error.

Remove _nospam when replying.

TIA

 
 
 

apachectl start: httpd could not be started on AIX 4.3.2

Post by Joshua Sliv » Fri, 05 Jan 2001 08:08:45



> system:
> IBM RS/6000 H70, 2gig Ram with SSA drives
> AIX ver 4.3.2
> Apache ver 1.3.14
> After running the install-bindist.sh with no errors. I receveive the
> follow error when I attempt to
> start the Apache server (/usr/local/apache/bin/apachectl start  ):

I have heard of other problems with this binary.  Your best
solution is probably to grab the source code and compile it yourself.

--
Joshua Slive

http://slive.ca/

 
 
 

apachectl start: httpd could not be started on AIX 4.3.2

Post by Nick K » Fri, 05 Jan 2001 08:22:27




Quote:> Could you please tell me how to correct this error or where to start
> looking to help correct this error.

You're missing a library, probably something like libdl.so.
Find it, and make sure Apache can find it.  Or (better) compile apache
from source to avoid any such problems.

--
Nick Kew

I procrastinate.  Efficient people never get around to it.
Therefore I am more efficient than an efficient person.

 
 
 

1. "apachectl start" problem in AIX

os = AIX 4.3.1

I compiled using apaci, all seemd ok, but when i try to start using apchectl, I
get the error:

[escala] /home/apache_1.3.11 # ./bin/apachectl start
Syntax error on line 334 of /home/apache_1.3.11/conf/httpd.
conf:
Expected </Directory> but saw </Directory>
./bin/apachectl start: httpd could not be started
[escala] /home/apache_1.3.11 #

After this, i commented out the entire block, and got the same error on the
another <Directory> block, until i commented out all <Directory> blocks, i also
got the same error with a <File> block which i commented out as well. After
this, it did start, but not surprisingly could not access a test html page (a
security violation error message appeared).

Any help is appreciated.

2. DEBUTANT!

3. apachect1 start in Apache/1.3.12 doesn′t start httpd

4. Quantum DLT4000

5. XWindows starts and starts and starts!!!

6. Anyone seen this/know what it is?

7. Error starting httpd on AIX 4.3

8. kwm window placement

9. KPPP: Will not start as user unless started under root first

10. GL programs do not start on local X when started from xdm/kdm

11. Syntax Error 'LoadMoudle' when starting apachectl for first time

12. help: httpd could not be started

13. Error when running ./apachectl start