apache 1.3.22 problems

apache 1.3.22 problems

Post by 12r3 » Fri, 19 Oct 2001 03:35:35



I am to to apache and am having the following problem.

I can run ./configure --prefix=/usr/local/apache and that is ok, but when I
run make I get the following

# make
===> src
make[1]: Entering directory `/russell/apache_1.3.22'
make[2]: Entering directory `/russell/apache_1.3.22/src'
===> src/os/unix
rm -f libos.a
ar cr libos.a os.o os-inline.o
make[3]: ar: Command not found
make[3]: *** [libos.a] Error 127
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/russell/apache_1.3.22/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/russell/apache_1.3.22'
make: *** [build] Error 2

I am trying to find out what the errors mean but am not having much luck.

TIA, Russell

 
 
 

apache 1.3.22 problems

Post by Nemesis Service » Fri, 19 Oct 2001 03:54:14


See this in your posting:

make[3]: ar: Command not found

you need to get ar installed I have it installed and here is my version

ar -V
GNU ar 2.9.5
Copyright 1997, 1998, 1999 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.


> I am to to apache and am having the following problem.

> I can run ./configure --prefix=/usr/local/apache and that is ok, but when
I
> run make I get the following

> # make
> ===> src
> make[1]: Entering directory `/russell/apache_1.3.22'
> make[2]: Entering directory `/russell/apache_1.3.22/src'
> ===> src/os/unix
> rm -f libos.a
> ar cr libos.a os.o os-inline.o
> make[3]: ar: Command not found
> make[3]: *** [libos.a] Error 127
> make[2]: *** [subdirs] Error 1
> make[2]: Leaving directory `/russell/apache_1.3.22/src'
> make[1]: *** [build-std] Error 2
> make[1]: Leaving directory `/russell/apache_1.3.22'
> make: *** [build] Error 2

> I am trying to find out what the errors mean but am not having much luck.

> TIA, Russell


 
 
 

apache 1.3.22 problems

Post by 12r3 » Fri, 19 Oct 2001 05:35:13


I have installed GNU gcc 2.9.5 can you tell me what ar is I have looked and
do not see it either on gnu.org or sunfreeware.com.

By the way tthis is on Sparc under Sun Solaris 8



> See this in your posting:

> make[3]: ar: Command not found

> you need to get ar installed I have it installed and here is my version

> ar -V
> GNU ar 2.9.5
> Copyright 1997, 1998, 1999 Free Software Foundation, Inc.
> This program is free software; you may redistribute it under the terms of
> the GNU General Public License.  This program has absolutely no warranty.


> > I am to to apache and am having the following problem.

> > I can run ./configure --prefix=/usr/local/apache and that is ok, but
when
> I
> > run make I get the following

> > # make
> > ===> src
> > make[1]: Entering directory `/russell/apache_1.3.22'
> > make[2]: Entering directory `/russell/apache_1.3.22/src'
> > ===> src/os/unix
> > rm -f libos.a
> > ar cr libos.a os.o os-inline.o
> > make[3]: ar: Command not found
> > make[3]: *** [libos.a] Error 127
> > make[2]: *** [subdirs] Error 1
> > make[2]: Leaving directory `/russell/apache_1.3.22/src'
> > make[1]: *** [build-std] Error 2
> > make[1]: Leaving directory `/russell/apache_1.3.22'
> > make: *** [build] Error 2

> > I am trying to find out what the errors mean but am not having much
luck.

> > TIA, Russell

 
 
 

apache 1.3.22 problems

Post by Nemesis Service » Fri, 19 Oct 2001 06:20:22


http://gcc.gnu.org/ml/gcc-bugs/2000-05/msg00641.html


> I have installed GNU gcc 2.9.5 can you tell me what ar is I have looked
and
> do not see it either on gnu.org or sunfreeware.com.

> By the way tthis is on Sparc under Sun Solaris 8



> > See this in your posting:

> > make[3]: ar: Command not found

> > you need to get ar installed I have it installed and here is my version

> > ar -V
> > GNU ar 2.9.5
> > Copyright 1997, 1998, 1999 Free Software Foundation, Inc.
> > This program is free software; you may redistribute it under the terms
of
> > the GNU General Public License.  This program has absolutely no
warranty.


> > > I am to to apache and am having the following problem.

> > > I can run ./configure --prefix=/usr/local/apache and that is ok, but
> when
> > I
> > > run make I get the following

> > > # make
> > > ===> src
> > > make[1]: Entering directory `/russell/apache_1.3.22'
> > > make[2]: Entering directory `/russell/apache_1.3.22/src'
> > > ===> src/os/unix
> > > rm -f libos.a
> > > ar cr libos.a os.o os-inline.o
> > > make[3]: ar: Command not found
> > > make[3]: *** [libos.a] Error 127
> > > make[2]: *** [subdirs] Error 1
> > > make[2]: Leaving directory `/russell/apache_1.3.22/src'
> > > make[1]: *** [build-std] Error 2
> > > make[1]: Leaving directory `/russell/apache_1.3.22'
> > > make: *** [build] Error 2

> > > I am trying to find out what the errors mean but am not having much
> luck.

> > > TIA, Russell

 
 
 

apache 1.3.22 problems

Post by <12r3> » Fri, 19 Oct 2001 08:14:32


Thanks that fixed it.


> http://gcc.gnu.org/ml/gcc-bugs/2000-05/msg00641.html


> > I have installed GNU gcc 2.9.5 can you tell me what ar is I have looked
> and
> > do not see it either on gnu.org or sunfreeware.com.

> > By the way tthis is on Sparc under Sun Solaris 8


in

> > > See this in your posting:

> > > make[3]: ar: Command not found

> > > you need to get ar installed I have it installed and here is my
version

> > > ar -V
> > > GNU ar 2.9.5
> > > Copyright 1997, 1998, 1999 Free Software Foundation, Inc.
> > > This program is free software; you may redistribute it under the terms
> of
> > > the GNU General Public License.  This program has absolutely no
> warranty.


> > > > I am to to apache and am having the following problem.

> > > > I can run ./configure --prefix=/usr/local/apache and that is ok, but
> > when
> > > I
> > > > run make I get the following

> > > > # make
> > > > ===> src
> > > > make[1]: Entering directory `/russell/apache_1.3.22'
> > > > make[2]: Entering directory `/russell/apache_1.3.22/src'
> > > > ===> src/os/unix
> > > > rm -f libos.a
> > > > ar cr libos.a os.o os-inline.o
> > > > make[3]: ar: Command not found
> > > > make[3]: *** [libos.a] Error 127
> > > > make[2]: *** [subdirs] Error 1
> > > > make[2]: Leaving directory `/russell/apache_1.3.22/src'
> > > > make[1]: *** [build-std] Error 2
> > > > make[1]: Leaving directory `/russell/apache_1.3.22'
> > > > make: *** [build] Error 2

> > > > I am trying to find out what the errors mean but am not having much
> > luck.

> > > > TIA, Russell

 
 
 

apache 1.3.22 problems

Post by Dr Hackenbus » Fri, 19 Oct 2001 09:53:28


You might find it as /usr/css/bin/ar that's where my IA32 Solaris 8
has it.


> I have installed GNU gcc 2.9.5 can you tell me what ar is I have
looked and
> do not see it either on gnu.org or sunfreeware.com.

> By the way tthis is on Sparc under Sun Solaris 8

 
 
 

1. Apache SCRIPT_NAME problem after upgrade 1.3.14 - 1.3.22

Hi.

I have run into problems trying to upgrade Apache from 1.3.14 to 1.3.22
on a Sun Solaris 8 machine. 1.3.22 does not handle SCRIPT_NAME the same
way (bug?). This is my scenario:

A cgi-script called script.cgi (the same problem occurs for
php-scripts).

Accessing the script with http://server/script.cgi
  both gives SCRIPT_NAME=/script.cgi.

Accessing the script with http://server/script.cgi/foo/bar
  both gives SCRIPT_NAME=/script.cgi and PATH_INFO=/foo/bar.

Accessing the script with http://server/script
  1.3.14 gives SCRIPT_NAME=/script
  1.3.22 gives SCRIPT_NAME=/script.cgi (!)

Accessing the script with http://server/script/
  1.3.14 gives SCRIPT_NAME=/script and PATH_INFO=/
  1.3.22 gives SCRIPT_NAME=/script/script.cgi (!) and PATH_INFO=/

Accessing the script with http://server/script/foo/bar
  1.3.14 gives SCRIPT_NAME=/script and PATH_INFO=/foo/bar.
  1.3.22 gives SCRIPT_NAME=/script/foo/script.cgi (!!!),
PATH_INFO=/foo/bar.

What's going on here???

-----------------------------------------------------------------------------
?ke Holmlund                                    Tel:  +46 - 90 786 57 16
Ume? University                                 Fax:  +46 - 90 786 65 50
Dept of informatics                             Email:

SE-901 87 Ume?
Sweden

2. can't install metamail

3. Apache 1.3.22 Virtual Server Problems

4. Unresolved symbols upgrading libc from 5.2.18 to 5.3.12?

5. Problems starting Apache 1.3.22

6. graphics in xdos(emu)?

7. apache 1.3.22 start problem (core dump)

8. Really strange problem with XP & SAMBA

9. Problem upgrading to apache 1.3.22-1

10. Apache 1.3.22 start problem

11. problems enabling mod_auth_db in Apache 1.3.22

12. How to use httpd/apache 1.3.22/2.0?

13. chroot apache 1.3.22 on aix 4.3.3