problem with 4.1.1, apache 1.3.23

problem with 4.1.1, apache 1.3.23

Post by Dario Nue » Mon, 11 Feb 2002 23:16:14



hi folks..

i've installed a new apache (1.2.23) with mod_ssl,
compiled all without errors.. then i built php
(4.1.1), the so-module with apxs.. how it's usual..

from this point on, apache doesn't came up anymore
;-(.. he showed no errors when making startssl, but
no processes were started when making a ps aux..

for testing if it's php's or mod_ssl's thing, i
commented the loadmodule-line in the httpd.conf from
the php4_module.. et voil, after that it came up
without any problems (startssl).. so i think it must
be php's problem..
has anyone seen this behaviour already? how can i
solve it? it were really nice to have an apache with
php, he's really "*" this way ;-))

here's my configure i did..:
./configure --with-apxs=/usr/apache/bin/apxs --with-
openssl --disable-short-tags --with-bz2 --with-ccvs
--
enable-ftp --with-mcrypt --with-
mysql=/usr/local/mysql
--with-ncurses --enable-shared

then, sure, apache produced an entry into the error-
log, here is it:
[Thu Feb  7 23:59:13 2002] [warn] pid file
/usr/apache/logs/httpd.pid overwritten -- Unclean
shutdown of previous Apache run?

as i read that message, i tried to fire up apache
every time with deleting the pid-file before making
a new try. also that had no affect..

massive thanks if you can help me, my home-
mailinglist (the german one) had no comments for me
;-( so you are one of my last chances ;-)

greetings from switzerland
bye dario

ps: the server is a debian potato, newest kernel
build..

 
 
 

1. Apache 1.3.23 syncronization problem

I have installed on my linux (mandrake 8.2) Apache Server 1.3.23 and Tomcat
4.0.4.

My web running well and I'm happy.......but......

I have developed a small pushlet application in java (JSP+Servlet) that
automatically send  to clients browser some small info in semi-real/time.

The problem is that if a single browser client ask two pushlet windows in
the same session, my apache+tomcat4 running well and send any push-message,
but now, if a people click an any button (html button which ref to another
html or jsp page) present on one of pushlet-window, the window freeze!!!
until user kill the other window....

I think that is a syncronize problem from apache and tomcat4.

The problem not exist with two different clients.

I'v been tryed my Web-Application in a different context: I use IIS and
Tomcat 3.2.4 - My pushlet application (no code change) running well and a
single client can open more of two pushlet-windows with any problem!!

Is there some special setting I need to make in the httpd.conf file or
something that will allow me resolve my 'problem'?

Thanks in advance,
Luca

2. 1 * xXbzgSUYw-Intermittent problems.....

3. Problems running Apache 1.3.23 on Solaris 8

4. Cable modem dynamic addressing

5. Strange Name-Based Virtual Host problem with Apache 1.3.23 on Linux

6. Please introduce good books and make advice on system

7. Newbie Basic Config Problem - RH 7.3 + Apache 1.3.23

8. Linux/DOS on a BIOS unsupported EIDE HDD

9. problem with starting Apache 1.3.23

10. Apache 1.3.23/SSL named virtual host problems?

11. Customs log problem with Apache/1.3.23

12. apache 1.3.23 mod_proxy proxy pass problem with swf files on Solaris 2.7

13. Apache 1.3.23 produces high load