Apache & IRIX 6.2 => Re: what happened to somaxconn in 6.2?

Apache & IRIX 6.2 => Re: what happened to somaxconn in 6.2?

Post by Ian Kalle » Tue, 22 Oct 1996 04:00:00



Interesting: thanks!  How can I identify what, if any, Apache (I'm using
1.1.1) would be using as limit or is it the same as MaxClients in the
httpd.conf? (there's no reference to somaxconn in the Apache sources...)

tia



> >Is the somaxconn default value for 6.2 published anywhere (maybe I don't
> >need to change it :)?

> In 6.2, your application can specify any limit it wants; the system silently
> clamps at 1000, which is really 1500 given the 3/2 scaling applied in the
> kernel.  It was felt that this limit was sufficiently high that nobody would
> ever need to go over it.

> --
> Steve Alexander | Silicon Graphics, Inc.     | +1 (415) 933-6172 (Voice)


--

        Director of Technology & Web Administration
            http://www.gamespot.com
 
 
 

Apache & IRIX 6.2 => Re: what happened to somaxconn in 6.2?

Post by Steve Alexand » Wed, 23 Oct 1996 04:00:00



Quote:>Interesting: thanks!  How can I identify what, if any, Apache (I'm using
>1.1.1) would be using as limit or is it the same as MaxClients in the
>httpd.conf? (there's no reference to somaxconn in the Apache sources...)

I don't know anything about Apache, but that's a good guess.  In 6.4, you can
use 'netstat -anq' to find out, but that doesn't really help you.  You could
use icrash to find the file in the user structure and trace down to the socket,
but that's excruciatingly painful.  You could also use the address displayed
in 'netstat -Aan | grep 80' to trace back to the PCB and then to the socket,
but icrash seems to get confused about TCB structures sometimes, so that's
probably also too painful.

If it were me, I'd restart the server under par and see what argument it passes
to listen().  That seems fairly straightforward.
--
Steve Alexander | Silicon Graphics, Inc.     | +1 (415) 933-6172 (Voice)


 
 
 

1. Follow Up: Irix 6.2 Hangs On Console Login ("amd" on Irix 6.2)

I have done some more digging and I have discovered that this same problem
manifests itself even on machines local to the NIS server. What is
happening is that somehow the automount daemon "amd" is dying at about
the time "clogin -f" and "Xlogin" are being run. So, of course the login
hangs because a home directory cannot be found. "amd" *never* dies if I
login over the network using "rsh" or "telnet" so I have to imagine this a bug
in "clogin" or similar. Anyone have any ideas?

Is anyone else out there running "amd" on Irix 6.2?

Dimitri

2. LinuxPPC on IBM 7248 100 : 43P - HELP !

3. Apache apache_1.3.1 and IRIX 6.2 DSOs with most & max set ?

4. Newbie with FAT32 2nd hard drive

5. Apache 1.3.1, IRIX 6.2 & shared core

6. PANIC during 2.1 x86 installation

7. IRIX 6.5.3 - shell changes from IRIX 6.2?

8. Please help a Newless Cluebee...

9. Binary port Irix 6.2 to Irix 6.4

10. Netscape Server and IRIX 5.3 > 6.2

11. NFS from IRIX 6.2->AIX 3.2.5

12. IRIX 6.2 export -> Sun 4

13. Apache 1.1.1 and IRIX 6.2