Server-side includes in Apache-1.3.14

Server-side includes in Apache-1.3.14

Post by sz.. » Thu, 16 Nov 2000 04:00:00



You may note that I've just upgraded to Apache-1.3.14 from 1.3.6 and
besides my php problems I face another one: server-side includes don't
work anymore even though I set it to enabled, see excerpts from
httpd.conf:
..
LoadModule includes_module    libexec/mod_include.so
AddModule mod_include.c
...

<Directory "/usr/local/apache/htdocs">
...
    Options Includes Indexes FollowSymLinks ExecCGI
...
</Directory>

Regards,

Zoltan

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

Server-side includes in Apache-1.3.14

Post by adam » Thu, 16 Nov 2000 04:00:00



> You may note that I've just upgraded to Apache-1.3.14 from 1.3.6 and
> besides my php problems I face another one: server-side includes don't
> work anymore even though I set it to enabled, see excerpts from
> httpd.conf:
> ..
> LoadModule includes_module    libexec/mod_include.so
> AddModule mod_include.c
> ...

> <Directory "/usr/local/apache/htdocs">
> ...
>     Options Includes Indexes FollowSymLinks ExecCGI
> ...
> </Directory>

Could you clarify "don't work anymore".  What exactly happens?  Are
there error messages in the error_log related to parsing the files?  Do
your SSI directives appear in the HTML source when you've requested a
page w/ a browser and view source?  Do you have
AddHandler server-parsed .shtml
??

-adam

 
 
 

Server-side includes in Apache-1.3.14

Post by sz.. » Thu, 16 Nov 2000 04:00:00




...
Quote:> AddHandler server-parsed .shtml

That's the right question! That solved the case:)
 The problem was that I use SSI in 'normal' html files, they don't
have '.shtml', but '.html' extensions. Also forgot to transfer
the "AddHandler server-parsed .html" to the new httpd.conf while
upgrading. Now it works again.

Regards,

Zoltan

Sent via Deja.com http://www.deja.com/
Before you buy.