apache httpd virtualhost on linux

apache httpd virtualhost on linux

Post by BBMC/W » Tue, 19 Sep 1995 04:00:00



u hu everyone,

I'm running a stand alone linux that is not connected to internet
or a network....its just sitting at home.
I'm using netscape 1.1N as my browser and running apache 0.8.13

I can get netscape to access both virtual hosts on my apache. However,
httpd/logs show that only one virtual host is sending out documents
and the other virtual host is just repeating documents from the 1st
virtual host. It seems that in the httpd.conf the last virtualhost
entry is the one that is being access.

Anyone know if this is a bug or a normal problem for stand alone
pc running apache. I know apache virtual hosts works nicely on
network and internet pc...with real DNS hostname.
Please send replies via emails if possible..thnx in advance.

 
 
 

apache httpd virtualhost on linux

Post by Ken V. Yanovs » Sat, 23 Sep 1995 04:00:00



>u hu everyone,

>I'm running a stand alone linux that is not connected to internet
>or a network....its just sitting at home.
>I'm using netscape 1.1N as my browser and running apache 0.8.13

>I can get netscape to access both virtual hosts on my apache. However,
>httpd/logs show that only one virtual host is sending out documents
>and the other virtual host is just repeating documents from the 1st
>virtual host. It seems that in the httpd.conf the last virtualhost
>entry is the one that is being access.

[cut]

Yes, unfortunately I seem to have the same problem. I know I should
implement VIF, however with one virtual host it seemed to be working
fine without VIF. My machine is on the net,unlike the gentleman's
above, but my problem seems similar. Seems that the last virtual host
entry is the one thats being accessed. _plus_ my real machine name
became redirected to that last virtual host page. Ack.
If anyone has any clue as to how to fix it, any feedback would be
greatly appreciated. =)

Ken.

--
----------------------------------------------------------------------
Documentation is like sex: when it is good, it is very, very good; and
when it is bad, it is better than nothing.  --* Brandon

 
 
 

apache httpd virtualhost on linux

Post by Eric Sorens » Thu, 28 Sep 1995 04:00:00




: >u hu everyone,
: >[standalone virtual hosts snipped]

: Yes, unfortunately I seem to have the same problem. I know I should
: implement VIF, however with one virtual host it seemed to be working
: fine without VIF. My machine is on the net,unlike the gentleman's
: above, but my problem seems similar. Seems that the last virtual host
: entry is the one thats being accessed. _plus_ my real machine name
: became redirected to that last virtual host page. Ack.
: If anyone has any clue as to how to fix it, any feedback would be
: greatly appreciated. =)

: Ken.

Are you using the bind-address virtual hosts or the hostname-based?
I'm assuming name-based, because otherwise you should have multiple
config files. Anyways, do you have the hostnames configured for different
IP addresses?  I don't know if linux is different, but BSD uses the
ifconfig command, with a corresponding A name in the nameserver...

Might be off base here, so--*details upon request.
--