Cannot get Apache to load Any Modules.

Cannot get Apache to load Any Modules.

Post by pacm.. » Mon, 28 Feb 2000 04:00:00



Hello,

My web server's working but I cannot add any extra modules.

Example:
Here's the first part of my current httpd.conf file and at this time I
would just love to be able to load ANY "LoadModule".
I have tried uncommenting just about everyone one below, individually:
------------
#LoadModule mime_magic_module  libexec/apache/mod_mime_magic.so
#LoadModule info_module        libexec/apache/mod_info.so
#LoadModule speling_module     libexec/apache/mod_speling.so
#LoadModule proxy_module       libexec/apache/libproxy.so
#LoadModule rewrite_module     libexec/apache/mod_rewrite.so
#LoadModule anon_auth_module   libexec/apache/mod_auth_anon.so
#LoadModule db_auth_module     libexec/apache/mod_auth_db.so
#LoadModule digest_module      libexec/apache/mod_digest.so
#LoadModule cern_meta_module   libexec/apache/mod_cern_meta.so
#LoadModule expires_module     libexec/apache/mod_expires.so
#LoadModule headers_module     libexec/apache/mod_headers.so
#LoadModule usertrack_module   libexec/apache/mod_usertrack.so
#LoadModule unique_id_module   libexec/apache/mod_unique_id.so
#LoadModule random_module      libexec/apache/mod_random.so
-----------------

Offcourse this is followed by uncommenting the matching AddModule:
-----------------
####AddModule mod_env.c
AddModule mod_log_config.c
#AddModule mod_mime_magic.c
AddModule mod_mime.c
####AddModule mod_negotiation.c
####AddModule mod_status.c
#AddModule mod_info.c
####AddModule mod_include.c    # for .shtml code
####AddModule mod_autoindex.c
AddModule mod_dir.c
AddModule mod_cgi.c
####AddModule mod_asis.c
####AddModule mod_imap.c
####AddModule mod_actions.c
#AddModule mod_speling.c
####AddModule mod_userdir.c
#AddModule mod_proxy.c
AddModule mod_alias.c
#AddModule mod_rewrite.c
AddModule mod_access.c
####AddModule mod_auth.c
#AddModule mod_auth_anon.c
#AddModule mod_auth_db.c
#AddModule mod_digest.c
#AddModule mod_cern_meta.c
#AddModule mod_expires.c
#AddModule mod_headers.c
#AddModule mod_usertrack.c
#AddModule mod_unique_id.c
AddModule mod_so.c
AddModule mod_setenvif.c
#AddModule mod_random.c
------------------

Example, if I uncommenting:
LoadModule headers_module     libexec/apache/mod_headers.so
and
AddModule mod_headers.c
and then run:
/usr/local/sbin/apachectl configtest
I always get some kind of cannot find error such as:
Syntax error on line 36 of /usr/local/etc/apache/httpd.conf:
Cannot load /usr/local/libexec/apache/mod_headers.so into
server: /usr/local/lib
exec/apache/mod_headers.so: Undefined symbol "ap_make_array"

I have DSO loaded.

Any suggestions.

Thanks,
Paul

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

1. dlopen: cannot load /usr/local/apache/modules/mod_cntr.so

Hi,

I'm getting the following error when attempting to start apache. The weird
thing is that I get the syntax error when trying to star apache, I can leave
it for a few minutes and then try and start it again and it will start.

Here's the relevant section of my error_log

[Thu Mar 13 06:05:38 2003] [notice] Graceful restart requested, doing
restart
Syntax error on line 189 of /usr/local/apache_2.0.44/conf/httpd.conf:
Cannot load /usr/local/apache/modules/mod_cntr.so into server: dlopen:
cannot
load /usr/local/apache/modules/mod_cntr.so

Here's my mod_cntr configuration the LoadModule line is line 189 that apache
is complaining about.

<snip>

LoadModule cntr_module modules/mod_cntr.so
<IfModule mod_cntr.c>
#CounterAutoAdd    On
#CounterFile       /virtual/%v/site/counter/counter.db
CounterTimeFmt   "%A, %d-%b-%y %T %Z"
CounterFaceDir   /usr/local/html/share/digits

<Location /server-cntr>
SetHandler server-cntr
</Location>

<Location /server-cntr-debug>
SetHandler server-cntr-debug
</Location>

<snip>

I have checked that the file is in the modules directory specified

bash-2.05# ls -l  /usr/local/apache/modules/mod_cntr.so
-rwxr-xr-x   1 root     system     98304 Feb 19 09:52
/usr/local/apache/modules/mod_cntr.so

Please help!

Cheers,
Zammo

2. problem with ethernet card - eth0: card reports no resources

3. 2.4.21-pre1: cannot load af-packet as module on Athlon

4. PPP: current speed of connection bps=?

5. cannot load ehternet module

6. Command

7. Problem: Modprobe: Cannot load module binfmt-XXXXX ?

8. kernel compiling errors - help needed

9. cannot load module for my ethernet card

10. Cannot load modules?

11. cannot load modules with 2.4 kernel

12. cannot load module 'pdwa' error after Solaris 8 upgrade

13. Cannot load ppa module for ParallelPort ZipDrive