Apache 1.3.1 won't start on hpux10.20

Apache 1.3.1 won't start on hpux10.20

Post by HH » Thu, 06 Aug 1998 04:00:00



I have just compiled Apache 1.3.1 on hpux10.20 and run make install.
I have not noticed any error messages so I assume all went well.

However, when I try to start the server, this is what I get:

# /opt/apache1.3.1/sbin/apachectl start
/opt/apache1.3.1/sbin/apachectl[71]: /opt/apache1.3.1/sbin/httpd: Execute
permission denied.
/opt/apache1.3.1/sbin/apachectl start: httpd could not be started

The permissions on the httpd file are as follows
# ll sbin/httpd
-rwxr-xr-x   1 root       sys         420222 Aug  5 15:06 sbin/httpd
#

Thanks for any suggestions,

Hubert

 
 
 

Apache 1.3.1 won't start on hpux10.20

Post by Yong Huan » Thu, 06 Aug 1998 04:00:00


If you don't have superuser permission, make sure you're using port number >
1024, which is not default.

Yong


> I have just compiled Apache 1.3.1 on hpux10.20 and run make install.
> I have not noticed any error messages so I assume all went well.

> However, when I try to start the server, this is what I get:

> # /opt/apache1.3.1/sbin/apachectl start
> /opt/apache1.3.1/sbin/apachectl[71]: /opt/apache1.3.1/sbin/httpd: Execute
> permission denied.
> /opt/apache1.3.1/sbin/apachectl start: httpd could not be started

> The permissions on the httpd file are as follows
> # ll sbin/httpd
> -rwxr-xr-x   1 root       sys         420222 Aug  5 15:06 sbin/httpd
> #

> Thanks for any suggestions,

> Hubert


 
 
 

Apache 1.3.1 won't start on hpux10.20

Post by Richard Llo » Sun, 09 Aug 1998 04:00:00




> If you don't have superuser permission, make sure you're using port number >
> 1024, which is not default.

Not true any more - the default port in Apache 1.3.1 is now 8080 (bizarre
that really, cos that's the default port for most proxy servers !).

On HP-UX, make *sure* you set valid "User" and "Group" strings (and don't
use "-1" or "nobody" or "root") in httpd.conf otherwise httpd won't fire up
nicely.

You can get the (slightly tweaked for paths) source code and pre-built
binaries for HP-UX 10.20 here:

http://hpux.csc.liv.ac.uk/hppd/hpux/Networking/WWW/apache-1.3.1/

The HPUX.Install in the source code explains any further caveats (though
it is reasonably straightforward to get running).


Computer Science Dept.,   Official HP-UX Archive WWW sites:
Liverpool University,     United Kingdom: http://hpux.csc.liv.ac.uk/
United Kingdom.           Germany:        http://hpux.ask.uni-karlsruhe.de/
                          United States:  http://hpux.cae.wisc.edu/ [Wisconsin]
                          France:         http://hpux.cict.fr/
                          Netherlands:    http://hpux.tn.tudelft.nl/
                          Canada:         http://hpux.ee.ualberta.ca/
                          Italy:          http://hpux.dsi.unimi.it/
                          United States:  http://hpux.cs.utah.edu/ [Utah]
                          South Africa:   http://hpux.petech.ac.za/
                          Japan:          http://hpux.u-aizu.ac.jp/

 
 
 

Apache 1.3.1 won't start on hpux10.20

Post by Marc Slemk » Sun, 09 Aug 1998 04:00:00





>> If you don't have superuser permission, make sure you're using port number >
>> 1024, which is not default.
>Not true any more - the default port in Apache 1.3.1 is now 8080 (bizarre
>that really, cos that's the default port for most proxy servers !).

No, the default port is _NOT_ 8080, it is only 8080 is you build
using the silly configure interface as a non-root user.
 
 
 

1. Seg fault in Apache 1.39 on HPUX10.20

I get a segmentation fault when I use streams in a C++ module that is
called from Apache 1.3.9 on HPUX 10.20.  I also get a bus error when I
try to load a shared library from the module.  I have tried similar
programs without Apache and they work fine.  Any ideas as to what could
cause this?

Thanks,

Allen Brookes
Rogue Wave Software

Sent via Deja.com http://www.deja.com/
Before you buy.

2. Netscape Audio

3. Sparc 20 won't boot and won't display errors, either.

4. clean up net/802/Makefile (small version)

5. Can I setup nis hosts-map to case-insensitive ?

6. RealAudio Player for HPUX10.20?

7. Konq 2.1 Render Bug

8. IP_HDRINCL in HPUX10.20? Raw IP programming

9. 1.3.12 + mod_perl+mod_ssl+hpux10.20 problem

10. Stevens code on HPUX a1.1 OS HPUX10.20

11. HPUX10.20-written 4mm 90m DAT unreadable from Linux Slackware-1.2.13

12. Xheaders on HPUX10.20