Problem with Apache 1.3.4 on OSF1 (4.0)

Problem with Apache 1.3.4 on OSF1 (4.0)

Post by D. Emilio Grimaldo Tuno » Fri, 21 May 1999 04:00:00



Hi,
   I built Apache 1.3.4 on a Digital Unix OSF/1 (v4.0)
alpha machine , it configures and builds without any problem
(DSO enabled). I installed the whole thing, configuration files
are ok, has the magic and mime.types and all. The problem is,
if I use apachectl start it says "apache started" but if you
look at the process list, it isn't running! I tried httpd -X
as well and it says "nxm upcall: can't grow stack, pid 28722, proc
httpd" and it core dumps :'(. The log files don't show a thing.

Anybody had this problem? how can I fix it? this is actually
the first time I use OSF/1 so I don't know if I need to
configure something else...

                TIA,
                        EMilio
--
D. Emilio Grimaldo Tunon       Compuware Europe B.V. (Uniface Lab)
Software Engineer              Amsterdam, The Netherlands

*** The opinions expressed hereby are mine and not my employer's ***

 
 
 

Problem with Apache 1.3.4 on OSF1 (4.0)

Post by D. Emilio Grimaldo Tuno » Fri, 21 May 1999 04:00:00



Quote:

> Hi,
>    I built Apache 1.3.4 on a Digital Unix OSF/1 (v4.0)
> alpha machine , it configures and builds without any problem
> (DSO enabled). I installed the whole thing, configuration files
> are ok, has the magic and mime.types and all. The problem is,
> if I use apachectl start it says "apache started" but if you
> look at the process list, it isn't running! I tried httpd -X
> as well and it says "nxm upcall: can't grow stack, pid 28722, proc
> httpd" and it core dumps :'(. The log files don't show a thing.

> Anybody had this problem? how can I fix it? this is actually
> the first time I use OSF/1 so I don't know if I need to
> configure something else...

  Some extra information (still no luck...), the module in question
is compiled/linked in the same way Apache builds its own standard
DSO's. The difference is... our module is multi-threaded. Same
problem happens if I use Apache 1.3.6.

Also, if I run it as "httpd -X" I get the message given in the
previous post and a core dump. If I simply run in multi-server
mode "httpd" then I get *nothing*, the server doesn't run, no
core dump, and no message in the error logfile.

Any clues are appreciated as I am not familiar with Digital
Unix...        

--
D. Emilio Grimaldo Tunon       Compuware Europe B.V. (Uniface Lab)
Software Engineer              Amsterdam, The Netherlands

*** The opinions expressed hereby are mine and not my employer's ***

 
 
 

Problem with Apache 1.3.4 on OSF1 (4.0)

Post by Adam Pric » Fri, 21 May 1999 04:00:00


Can't grow stack? could that be ulimits?
Other thoughts, just got 4.0f and looked at the freeware sources disk, there
is a version of Apache on there, but I'm at home and I can't remember if it
was a 'modified' source tree or an original. Either way digitals ftp site
may have a precompiled binary to look at.

Hope this helps

Adam

 
 
 

Problem with Apache 1.3.4 on OSF1 (4.0)

Post by nm » Tue, 25 May 1999 04:00:00


try getting 1.3.6 and build it out of the box
if that works, then go back and add any special modules you might have

i've never had a problem compiling apache on digital unix 4.0d or 4.0e


Quote:> Can't grow stack? could that be ulimits?
> Other thoughts, just got 4.0f and looked at the freeware sources disk,
there
> is a version of Apache on there, but I'm at home and I can't remember if
it
> was a 'modified' source tree or an original. Either way digitals ftp site
> may have a precompiled binary to look at.

> Hope this helps

> Adam